summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-12 11:32:58 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-12 11:32:58 +0000
commit52fe8715bc1daf50339e5120e64644ce18e710e4 (patch)
treec7e5f628d575df9d59c1bf80fe26ab7196bf4ec4 /sci-chemistry/pdbcat/pdbcat-1.3.ebuild
parentmake build verbose, bug #437904 by Vicente Olivert Riera (diff)
downloadgentoo-2-52fe8715bc1daf50339e5120e64644ce18e710e4.tar.gz
gentoo-2-52fe8715bc1daf50339e5120e64644ce18e710e4.tar.bz2
gentoo-2-52fe8715bc1daf50339e5120e64644ce18e710e4.zip
sci-chemistry/pdbcat: New addition
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pdbcat/pdbcat-1.3.ebuild')
-rw-r--r--sci-chemistry/pdbcat/pdbcat-1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-chemistry/pdbcat/pdbcat-1.3.ebuild b/sci-chemistry/pdbcat/pdbcat-1.3.ebuild
new file mode 100644
index 000000000000..b868dc63528c
--- /dev/null
+++ b/sci-chemistry/pdbcat/pdbcat-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdbcat/pdbcat-1.3.ebuild,v 1.1 2012/10/12 11:32:58 jlec Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Manipulate and process PDB files using commonly available tools such as Perl, awk, etc"
+HOMEPAGE="http://www.ks.uiuc.edu/Development/MDTools/pdbcat/"
+SRC_URI="http://www.ks.uiuc.edu/Development/MDTools/${PN}/files/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-gcc.patch )
+DOCS=( README )
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+ base_src_prepare
+}