summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-06-23 15:58:56 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-06-23 15:58:56 +0000
commit050177dd3c143954ed601bbd94f5b626b8b8e87c (patch)
treed5cf0f645d77bff3f1ac1ee3e027b8311acb2e38 /sci-chemistry/platon
parentdocumentation update: make install -> emake install (diff)
downloadgentoo-2-050177dd3c143954ed601bbd94f5b626b8b8e87c.tar.gz
gentoo-2-050177dd3c143954ed601bbd94f5b626b8b8e87c.tar.bz2
gentoo-2-050177dd3c143954ed601bbd94f5b626b8b8e87c.zip
(#137734) Bump -- old versions no longer accessible.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sci-chemistry/platon')
-rw-r--r--sci-chemistry/platon/ChangeLog8
-rw-r--r--sci-chemistry/platon/files/digest-platon-200606213
-rw-r--r--sci-chemistry/platon/platon-20060621.ebuild73
3 files changed, 83 insertions, 1 deletions
diff --git a/sci-chemistry/platon/ChangeLog b/sci-chemistry/platon/ChangeLog
index ba7440fd7291..84e667ce962a 100644
--- a/sci-chemistry/platon/ChangeLog
+++ b/sci-chemistry/platon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/platon
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.2 2006/06/03 06:17:36 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.3 2006/06/23 15:58:56 spyderous Exp $
+
+*platon-20060621 (23 Jun 2006)
+
+ 23 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ -platon-20051215.ebuild, -platon-20060530.ebuild, +platon-20060621.ebuild:
+ (#137734) Bump -- old versions no longer accessible.
*platon-20060530 (03 Jun 2006)
diff --git a/sci-chemistry/platon/files/digest-platon-20060621 b/sci-chemistry/platon/files/digest-platon-20060621
new file mode 100644
index 000000000000..3e9497b5ae52
--- /dev/null
+++ b/sci-chemistry/platon/files/digest-platon-20060621
@@ -0,0 +1,3 @@
+MD5 a1bf1469361bc4c1ed90b90b5d3135bf platon-20060621.tar.gz 6691191
+RMD160 8fb36d1029d980fbe7e5b3d5d77cfb332b80024a platon-20060621.tar.gz 6691191
+SHA256 32b2ac1cc35f66486662f8822dc430f7e16c8664a1e7ef024bb35d1082205337 platon-20060621.tar.gz 6691191
diff --git a/sci-chemistry/platon/platon-20060621.ebuild b/sci-chemistry/platon/platon-20060621.ebuild
new file mode 100644
index 000000000000..0a8797f679dd
--- /dev/null
+++ b/sci-chemistry/platon/platon-20060621.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/platon-20060621.ebuild,v 1.1 2006/06/23 15:58:56 spyderous Exp $
+
+inherit fortran toolchain-funcs
+
+FORTRAN="g77 gfortran"
+DESCRIPTION="Versatile, SHELX-97 compatible, multipurpose crystallographic tool"
+HOMEPAGE="http://www.cryst.chem.uu.nl/platon/"
+SRC_URI="${P}.tar.gz"
+RESTRICT="fetch"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+# Can't do libf2c dependent on whether <gcc-4 is selected for the build,
+# so we must always require it
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
+ dev-libs/libf2c"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+
+pkg_nofetch() {
+ einfo "Download ${A/-${PV}} from ${HOMEPAGE},"
+ einfo "rename it to ${A} and place it"
+ einfo "in ${DISTDIR}."
+ einfo "If there is a digest mismatch, please file a bug"
+ einfo "at https://bugs.gentoo.org/ -- a version bump"
+ einfo "is probably required."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gunzip platon.f.Z xdrvr.c.gz
+}
+
+src_compile() {
+ local F2C
+ # Needs signal_ and system_, which g77 and libf2c provide,
+ # but gfortran does not
+ if [[ ${FORTRANC} != g77 ]]; then
+ F2C="-lf2c"
+ fi
+
+ COMMAND="$(tc-getCC) -c ${CFLAGS} xdrvr.c"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of xdrvr.c failed"
+ COMMAND="${FORTRANC} -c ${FFLAGS:- -O2} -fno-second-underscore platon.f"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of platon.f failed"
+ COMMAND="${FORTRANC} -o platon ${LDFLAGS} platon.o xdrvr.o -lX11 ${F2C}"
+ echo ${COMMAND}
+ ${COMMAND} || die "Linking failed"
+}
+
+src_install() {
+ dobin platon
+
+ dosym platon /usr/bin/pluton
+ dosym platon /usr/bin/s
+ dosym platon /usr/bin/cifchk
+ dosym platon /usr/bin/helena
+ dosym platon /usr/bin/stidy
+
+ insinto /usr/lib/platon
+ doins check.def
+
+ echo "CHECKDEF=\"/usr/lib/platon/check.def\"" > ${T}/env.d
+ newenvd ${T}/env.d 50platon
+
+ dodoc README.* VALIDATION.DOC
+}