summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-20 15:50:11 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-20 15:50:11 +0000
commit3abd799f441fa502995e2180b517612984bd467e (patch)
tree09d39bf6b8a89e1f8e3b7bed5da4300e787fe534 /sci-chemistry/refmac
parentKeyword ~arm (diff)
downloadgentoo-2-3abd799f441fa502995e2180b517612984bd467e.tar.gz
gentoo-2-3abd799f441fa502995e2180b517612984bd467e.tar.bz2
gentoo-2-3abd799f441fa502995e2180b517612984bd467e.zip
sci-chemistry/refmac: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry/refmac')
-rw-r--r--sci-chemistry/refmac/ChangeLog6
-rw-r--r--sci-chemistry/refmac/refmac-5.5.0110-r3.ebuild6
-rw-r--r--sci-chemistry/refmac/refmac-5.6.0119.ebuild8
3 files changed, 12 insertions, 8 deletions
diff --git a/sci-chemistry/refmac/ChangeLog b/sci-chemistry/refmac/ChangeLog
index b02bcf38b817..63b41b340fa3 100644
--- a/sci-chemistry/refmac/ChangeLog
+++ b/sci-chemistry/refmac/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/refmac
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.55 2013/02/03 18:24:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.56 2013/02/20 15:50:11 jlec Exp $
+
+ 20 Feb 2013; Justin Lecher <jlec@gentoo.org> refmac-5.5.0110-r3.ebuild,
+ refmac-5.6.0119.ebuild:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
03 Feb 2013; Justin Lecher <jlec@gentoo.org> -refmac-5.5.0110-r2.ebuild:
Drop old, fixes build problem with stable gcc, #454290
diff --git a/sci-chemistry/refmac/refmac-5.5.0110-r3.ebuild b/sci-chemistry/refmac/refmac-5.5.0110-r3.ebuild
index 6c15fc63acf0..750f78667cd7 100644
--- a/sci-chemistry/refmac/refmac-5.5.0110-r3.ebuild
+++ b/sci-chemistry/refmac/refmac-5.5.0110-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.5.0110-r3.ebuild,v 1.9 2013/02/03 17:56:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.5.0110-r3.ebuild,v 1.10 2013/02/20 15:50:11 jlec Exp $
EAPI=4
@@ -56,8 +56,8 @@ src_compile() {
VERSION="" \
XFFLAGS="" \
XCFLAGS="" \
- LLIBCCP="-lccp4f -lccp4c -lccif $(pkg-config --libs mmdb)" \
- LLIBLAPACK="$(pkg-config --libs lapack blas)" \
+ LLIBCCP="-lccp4f -lccp4c -lccif $($(tc-getPKG_CONFIG) --libs mmdb)" \
+ LLIBLAPACK="$($(tc-getPKG_CONFIG) --libs lapack blas)" \
LLIBOTHERS="${LIBS}" \
${PN} libcheck
}
diff --git a/sci-chemistry/refmac/refmac-5.6.0119.ebuild b/sci-chemistry/refmac/refmac-5.6.0119.ebuild
index f5d8ee90f8e9..451ae0f848fb 100644
--- a/sci-chemistry/refmac/refmac-5.6.0119.ebuild
+++ b/sci-chemistry/refmac/refmac-5.6.0119.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.6.0119.ebuild,v 1.2 2012/10/19 10:25:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.6.0119.ebuild,v 1.3 2013/02/20 15:50:11 jlec Exp $
EAPI=4
@@ -57,8 +57,8 @@ src_compile() {
VERSION="" \
XFFLAGS="-fwhole-file" \
XCFLAGS="" \
- LLIBCCP="-lccp4f -lccp4c -lccif $(pkg-config --libs mmdb)" \
- LLIBLAPACK="$(pkg-config --libs lapack blas)" \
+ LLIBCCP="-lccp4f -lccp4c -lccif $($(tc-getPKG_CONFIG) --libs mmdb)" \
+ LLIBLAPACK="$($(tc-getPKG_CONFIG) --libs lapack blas)" \
LLIBOTHERS="${LIBS}"
}