summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-08-13 17:48:01 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-08-13 17:48:01 +0000
commit1f6a1a4fa4d9f9adebf5dda196c56d88f10c4084 (patch)
tree2f4ed40f8db3b8173f2be9a1fec5c624325901ea /sci-chemistry
parentsimplified fortran handling in pkg_setup (see bug 82431) (diff)
downloadgentoo-2-1f6a1a4fa4d9f9adebf5dda196c56d88f10c4084.tar.gz
gentoo-2-1f6a1a4fa4d9f9adebf5dda196c56d88f10c4084.tar.bz2
gentoo-2-1f6a1a4fa4d9f9adebf5dda196c56d88f10c4084.zip
VMD now depends on stride in order to properly display secondary structure information. Also patched a paratool plugin error under tcl-8.4.13.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/vmd/ChangeLog10
-rw-r--r--sci-chemistry/vmd/files/digest-vmd-1.8.4-r13
-rw-r--r--sci-chemistry/vmd/files/vmd-1.8.4-paratool.patch28
-rw-r--r--sci-chemistry/vmd/vmd-1.8.4-r1.ebuild152
4 files changed, 192 insertions, 1 deletions
diff --git a/sci-chemistry/vmd/ChangeLog b/sci-chemistry/vmd/ChangeLog
index 64d86d114d80..b96cf4168098 100644
--- a/sci-chemistry/vmd/ChangeLog
+++ b/sci-chemistry/vmd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/vmd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.5 2006/04/29 00:39:08 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.6 2006/08/13 17:48:01 markusle Exp $
+
+*vmd-1.8.4-r1 (13 Aug 2006)
+
+ 13 Aug 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/vmd-1.8.4-paratool.patch, +vmd-1.8.4-r1.ebuild:
+ VMD now depends on stride in order to properly display secondary
+ structure information. Also patched a paratool plugin error under
+ tcl-8.4.13.
29 Apr 2006; Marien Zwart <marienz@gentoo.org> Manifest:
Fix SHA256 digests.
diff --git a/sci-chemistry/vmd/files/digest-vmd-1.8.4-r1 b/sci-chemistry/vmd/files/digest-vmd-1.8.4-r1
new file mode 100644
index 000000000000..9ea1e6202b57
--- /dev/null
+++ b/sci-chemistry/vmd/files/digest-vmd-1.8.4-r1
@@ -0,0 +1,3 @@
+MD5 3cf6f2e23898ace4ffe022115470ec28 vmd-1.8.4.src.tar.gz 12042149
+RMD160 f49a68ae63a607cd37a58d894df2f22d7df55b85 vmd-1.8.4.src.tar.gz 12042149
+SHA256 29b046767f1efe90d5f3e3dbbdcd4988d5335d1db226405f5ddb9f171c811cac vmd-1.8.4.src.tar.gz 12042149
diff --git a/sci-chemistry/vmd/files/vmd-1.8.4-paratool.patch b/sci-chemistry/vmd/files/vmd-1.8.4-paratool.patch
new file mode 100644
index 000000000000..d0d5e63bcf5b
--- /dev/null
+++ b/sci-chemistry/vmd/files/vmd-1.8.4-paratool.patch
@@ -0,0 +1,28 @@
+diff -Naur plugins/paratool/paratool_readwrite.tcl plugins-new/paratool/paratool_readwrite.tcl
+--- plugins/paratool/paratool_readwrite.tcl 2006-04-05 18:53:03.000000000 -0400
++++ plugins-new/paratool/paratool_readwrite.tcl 2006-08-01 22:05:50.000000000 -0400
+@@ -651,12 +651,8 @@
+ ##########################################################
+
+ proc ::Paratool::load_basemolecule { file {file2 {}}} {
+-<<<<<<< paratool_readwrite.tcl
+- puts "Files $file $file2"
+-=======
+ puts "Loading base molecule $file"
+
+->>>>>>> 1.20
+ save_viewpoint_orig
+ set newmolid [mol new $file]
+ if {[llength $file2]} {
+diff -Naur plugins/resptool/resptool.tcl plugins-new/resptool/resptool.tcl
+--- plugins/resptool/resptool.tcl 2005-12-20 11:08:16.000000000 -0500
++++ plugins-new/resptool/resptool.tcl 2006-08-01 22:06:00.000000000 -0400
+@@ -14,7 +14,7 @@
+ # * Clear selection button
+
+ package provide resptool 1.0
+-package require paratool
++#package require paratool
+
+ namespace eval ::RESPTool:: {
+ variable w
diff --git a/sci-chemistry/vmd/vmd-1.8.4-r1.ebuild b/sci-chemistry/vmd/vmd-1.8.4-r1.ebuild
new file mode 100644
index 000000000000..fcc3ccbbc917
--- /dev/null
+++ b/sci-chemistry/vmd/vmd-1.8.4-r1.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.4-r1.ebuild,v 1.1 2006/08/13 17:48:01 markusle Exp $
+
+inherit eutils toolchain-funcs python
+
+DESCRIPTION="Visual Molecular Dynamics"
+LICENSE="vmd"
+HOMEPAGE="http://www.ks.uiuc.edu/Research/vmd/"
+SRC_URI="${P}.src.tar.gz"
+
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="hardened"
+
+RESTRICT="fetch"
+
+DEPEND="app-shells/tcsh
+ || ( x11-libs/libXft virtual/x11 )
+ virtual/opengl
+ x11-libs/fltk
+ sci-libs/netcdf
+ =dev-lang/tcl-8.4*
+ =dev-lang/tk-8.4*
+ >=dev-lang/python-2.3
+ sci-biology/stride
+ hardened? ( sys-apps/paxctl )"
+
+
+VMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD"
+
+pkg_nofetch() {
+ echo
+ einfo "Please download ${SRC_URI} from"
+ einfo "${VMD_DOWNLOAD}"
+ einfo "after agreeing to the license and then move it to "
+ einfo "${DISTDIR}"
+ echo
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # apply LINUX-arch patches to vmd configure
+ epatch "${FILESDIR}"/${P}-config-gentoo.patch
+ epatch "${FILESDIR}"/${P}-plugin-autopsf.patch
+ epatch "${FILESDIR}"/${P}-paratool.patch
+
+ # prepare the plugins
+
+ cd "${WORKDIR}"/plugins
+
+ sed -e "s/CC = gcc/CC = $(tc-getCC)/" \
+ -e "s/CXX = g++/CXX = $(tc-getCXX)/" \
+ -e "s/COPTO = -o /COPTO = -fPIC -o /" \
+ -e "s/LOPTO = -o /LOPTO = -fPIC -o /" \
+ -e "s/CCFLAGS = -O2 -Wall/CCFLAGS = ${CFLAGS}/" \
+ -e "s/CXXFLAGS = -O2 -Wall/CXXFLAGS = ${CXXFLAGS}/" \
+ -i Make-arch || die "Failed to set up plugins Makefile"
+
+ # prepare vmd itself
+
+ cd "${S}"
+
+ sed -e "s:gentoo-bindir:${D}/usr/bin:" \
+ -e "s:gentoo-libdir:${D}/usr/$(get_libdir):" \
+ -i configure || die "failed to adjust install paths"
+
+
+ sed -e "s:gentoo-gcc:$(tc-getCC):" \
+ -e "s:gentoo-g++:$(tc-getCXX):" \
+ -e "s:gentoo-cflags:${CFLAGS}:" \
+ -i configure || die "Failed to adjust C compiler/flags"
+
+
+ sed -e "s:gentoo-plugindir:${WORKDIR}/plugins:" \
+ -i configure || die "Failed to set up linking to plugin files"
+
+ sed -e "s:gentoo-fltk-include:/usr/include/fltk-1.1:" \
+ -e "s:gentoo-fltk-libs:/usr/$(get_libdir)/fltk-1.1:" \
+ -i configure || die "failed setting up fltk"
+
+
+ # get installed python version
+ python_version
+ local PY="python${PYVER}"
+
+ sed -e "s:gentoo-python-include:/usr/include/${PY}:" \
+ -e "s:gentoo-python-lib:/usr/$(get_libdir)/${PY}:" \
+ -e "s:gentoo-python-link:${PY}:" \
+ -i configure || die "failed setting up python"
+
+ sed -e "s:LINUXPPC:LINUX:g" \
+ -e "s:LINUXALPHA:LINUX:g" \
+ -e "s:LINUXAMD64:LINUX:g" \
+ -i ${S}/bin/vmd || die "failed setting up vmd wrapper script"
+
+ local myconfig="LINUX OPENGL FLTK TK TCL PTHREADS PYTHON"
+
+ rm -f configure.options && echo $myconfig >> configure.options
+
+ ./configure &> /dev/null || die "failed to configure"
+
+}
+
+src_compile() {
+ # build plugins
+ cd "${WORKDIR}"/plugins
+ make LINUX TCLINC="-I/usr/include" \
+ TCLLIB="-L/usr/$(get_libdir)/tcl8.4" || \
+ die "failed to build plugins"
+
+ # build vmd
+ cd "${S}"/src
+ make || die "failed to build vmd"
+}
+
+src_install() {
+ # install plugins
+ cd "${WORKDIR}"/plugins
+ PLUGINDIR=${D}/usr/$(get_libdir)/${PN}/plugins make distrib || \
+ die "failed to install plugins"
+
+ # install vmd
+ cd "${S}"/src
+ make install || die "failed to install vmd"
+
+ # export STRIDE_BIN so VMD find stride
+ echo "STRIDE_BIN=/usr/bin/stride" > ${T}/99${PN} || \
+ die "Failed to create vmd env file"
+ doenvd ${T}/99${PN} || die "Failed to install vmd env file"
+
+ # install docs
+ cd "${S}"
+ dodoc Announcement README doc/ig.pdf doc/ug.pdf
+
+ # remove some of the things we don't want and need in
+ # /usr/lib
+ cd "${D}"/usr/$(get_libdir)/vmd
+ rm -fr doc README Announcement LICENSE || \
+ die "failed to clean up /usr/lib/vmd directory"
+
+ # adjust path in vmd wrapper
+ sed -e "s:${D}::" -i "${D}"/usr/bin/${PN} \
+ || die "failed to set up vmd wrapper script"
+
+ # adjust paxctl settings on hardened systems
+ if use hardened; then
+ /sbin/paxctl -pemrxs ${D}/usr/$(get_libdir)/${PN}/${PN}_LINUX
+ fi
+}
+