summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-21 11:45:27 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-21 11:45:27 +0000
commit2bedf0bcc2e1333d9f19515093285250214ebd12 (patch)
tree0f2211414915f6c6f949ff29cfe50400efee3881 /sci-chemistry
parentDrop www-server herd as discussed in gentoo-dev ML. (diff)
downloadgentoo-2-2bedf0bcc2e1333d9f19515093285250214ebd12.tar.gz
gentoo-2-2bedf0bcc2e1333d9f19515093285250214ebd12.tar.bz2
gentoo-2-2bedf0bcc2e1333d9f19515093285250214ebd12.zip
Initital addition, written by me
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mmtk/ChangeLog10
-rw-r--r--sci-chemistry/mmtk/Manifest4
-rw-r--r--sci-chemistry/mmtk/metadata.xml31
-rw-r--r--sci-chemistry/mmtk/mmtk-2.7.5.ebuild33
4 files changed, 78 insertions, 0 deletions
diff --git a/sci-chemistry/mmtk/ChangeLog b/sci-chemistry/mmtk/ChangeLog
new file mode 100644
index 000000000000..86ee80320efb
--- /dev/null
+++ b/sci-chemistry/mmtk/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/mmtk
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mmtk/ChangeLog,v 1.1 2012/03/21 11:45:27 jlec Exp $
+
+*mmtk-2.7.5 (21 Mar 2012)
+
+ 21 Mar 2012; Justin Lecher <jlec@gentoo.org> +mmtk-2.7.5.ebuild,
+ +metadata.xml:
+ Initital addition, written by me
+
diff --git a/sci-chemistry/mmtk/Manifest b/sci-chemistry/mmtk/Manifest
new file mode 100644
index 000000000000..5377cdd1ce6f
--- /dev/null
+++ b/sci-chemistry/mmtk/Manifest
@@ -0,0 +1,4 @@
+DIST MMTK-2.7.5.tar.gz 1269533 RMD160 2fb4a020147c1ffed785a0b471128736c46fa2a4 SHA1 b4f274e6c5472f4450120278789c5e382db4007e SHA256 34cb5636643805d52903a58a96215bf81b3229bfb34cac754a3d715aadad3dfe
+EBUILD mmtk-2.7.5.ebuild 654 RMD160 2158c94bbc50e6ef2fda1744e7ea9a0a66a1f00e SHA1 4818ee4d0454bd3a4fa4cb16814c9eff87703883 SHA256 a940fa0c524829d620cf594aea8a91df1e6769884443cec59b7f59ff56663c4e
+MISC ChangeLog 266 RMD160 297d9569e7fd54567daabc219ce9745b431d40e8 SHA1 21c05145bf8860a63652b2f3137fc79786bb6749 SHA256 0dd808f2798ddfe5b0aa36085976e2fe58dd1c85d6a6c6317a12cbed0ae21a52
+MISC metadata.xml 1594 RMD160 581de42c25d70aa895e34434a26f3bc789aaa048 SHA1 243063e2316d89024e33ec518209b8070a00b4d4 SHA256 0631937d92098d7e70451b5aec324fccba7be5538fe4e8fec3e7bd446c8529f1
diff --git a/sci-chemistry/mmtk/metadata.xml b/sci-chemistry/mmtk/metadata.xml
new file mode 100644
index 000000000000..17d378df8960
--- /dev/null
+++ b/sci-chemistry/mmtk/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+The Molecular Modelling Toolkit (MMTK) is an Open Source program library for
+molecular simulation applications. In addition to providing ready-to-use
+implementations of standard algorithms, MMTK serves as a code basis that can be
+easily extended and modified to deal with standard and non-standard problems
+in molecular simulations.
+
+The three most common usage patterns of MMTK are
+
+Writing Python scripts that make use of MMTK functions for standard simulation
+and modelling applications. This is similar to using other simulation packages
+with a scripting language (i.e. CHARMM or Gromos), but with the added
+advantage of having access to lots of useful Python modules from elsewhere.
+The example section shows what such scripts look like.
+Writing modules that interact closely with MMTK (and perhaps other packages)
+to solve problems for which no standard solution exists. For example, adding
+a particular force field term or a particular simulation or analysis
+algorithm. There is not much competition for MMTK in that domain.
+Writing application programs in Python that use MMTK internally, for users that
+do not need to know anything about such internals. Those programs can provide
+easy-to-use graphical interfaces (see e.g. DomainFinder and nMOLDYN) or be
+integrated into a Web service (see e.g. WEBnm@).
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/mmtk/mmtk-2.7.5.ebuild b/sci-chemistry/mmtk/mmtk-2.7.5.ebuild
new file mode 100644
index 000000000000..5a0b10ce64a1
--- /dev/null
+++ b/sci-chemistry/mmtk/mmtk-2.7.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mmtk/mmtk-2.7.5.ebuild,v 1.1 2012/03/21 11:45:27 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-*"
+
+inherit distutils
+
+DL_ID=3794
+MY_PN=MMTK
+MY_P=${MY_PN}-${PV}
+
+PYTHON_MODNAME="${MY_PN}"
+
+DESCRIPTION="The Molecular Modelling Toolkit"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="https://sourcesup.cru.fr/frs/download.php/${DL_ID}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy
+ dev-python/scientificpython"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}