summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-03 15:06:13 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-03 15:06:13 +0000
commit2e19930399581c3baf7ab38420de67ea059ae683 (patch)
tree7c2d860f94408c1abb6cbc32248d003368f00b2f /sci-chemistry
parentFix libpolymake.so.0 symlink (diff)
downloadgentoo-2-2e19930399581c3baf7ab38420de67ea059ae683.tar.gz
gentoo-2-2e19930399581c3baf7ab38420de67ea059ae683.tar.bz2
gentoo-2-2e19930399581c3baf7ab38420de67ea059ae683.zip
sci-chemistry/dssp: Version Bump
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/dssp/ChangeLog10
-rw-r--r--sci-chemistry/dssp/dssp-2.0.4.ebuild37
-rw-r--r--sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch46
-rw-r--r--sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch70
-rw-r--r--sci-chemistry/dssp/metadata.xml8
5 files changed, 165 insertions, 6 deletions
diff --git a/sci-chemistry/dssp/ChangeLog b/sci-chemistry/dssp/ChangeLog
index 999dbd11ba28..ad610fc75a66 100644
--- a/sci-chemistry/dssp/ChangeLog
+++ b/sci-chemistry/dssp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/dssp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/dssp/ChangeLog,v 1.5 2011/04/13 09:25:37 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/dssp/ChangeLog,v 1.6 2012/06/03 15:06:13 jlec Exp $
+
+*dssp-2.0.4 (03 Jun 2012)
+
+ 03 Jun 2012; Justin Lecher <jlec@gentoo.org> +dssp-2.0.4.ebuild,
+ +files/dssp-2.0.4-gcc47.patch, +files/dssp-2.0.4-gentoo.patch, metadata.xml:
+ Version Bump
13 Apr 2011; Justin Lecher <jlec@gentoo.org> dssp-101007.ebuild:
Fixed URL for download, #363175
diff --git a/sci-chemistry/dssp/dssp-2.0.4.ebuild b/sci-chemistry/dssp/dssp-2.0.4.ebuild
new file mode 100644
index 000000000000..7b8f77bda909
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-2.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/dssp/dssp-2.0.4.ebuild,v 1.1 2012/06/03 15:06:13 jlec Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="http://swift.cmbi.ru.nl/gv/dssp/"
+SRC_URI="ftp://ftp.cmbi.ru.nl/pub/molbio/software/dssp-2/dssp-2.0.4.tgz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ tc-export CXX
+
+ cat >> make.config <<- EOF
+ BOOST_LIB_SUFFIX = -mt
+ BOOST_LIB_DIR = "${EPREFIX}/usr/$(get_libdir)"
+ BOOST_INC_DIR = "${EPREFIX}/usr/include"
+ EOF
+
+ epatch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ dobin mkdssp
+ dosym mkdssp /usr/bin/dssp
+ doman doc/mkdssp.1
+ dodoc README.txt changelog
+}
diff --git a/sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch b/sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch
new file mode 100644
index 000000000000..5db1437beb1f
--- /dev/null
+++ b/sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch
@@ -0,0 +1,46 @@
+ src/matrix.h | 5 +++--
+ src/primitives-3d.cpp | 1 +
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/matrix.h b/src/matrix.h
+index 1053ad9..d7dae5f 100644
+--- a/src/matrix.h
++++ b/src/matrix.h
+@@ -14,6 +14,7 @@
+ #include <istream>
+ #include <cassert>
+ #include <stdexcept>
++#include <unistd.h>
+
+ // --------------------------------------------------------------------
+ // uBlas compatible matrix types
+@@ -284,7 +285,7 @@ class identity_matrix : public matrix_base<T>
+ template<typename T>
+ matrix<T> operator*(const matrix_base<T>& lhs, const matrix_base<T>& rhs)
+ {
+- matrix<T> result(min(lhs.dim_m(), rhs.dim_m()), min(lhs.dim_n(), rhs.dim_n()));
++ matrix<T> result(std::min(lhs.dim_m(), rhs.dim_m()), std::min(lhs.dim_n(), rhs.dim_n()));
+
+ for (uint32 i = 0; i < result.dim_m(); ++i)
+ {
+@@ -310,7 +311,7 @@ matrix<T> operator*(const matrix_base<T>& lhs, T rhs)
+ template<typename T>
+ matrix<T> operator-(const matrix_base<T>& lhs, const matrix_base<T>& rhs)
+ {
+- matrix<T> result(min(lhs.dim_m(), rhs.dim_m()), min(lhs.dim_n(), rhs.dim_n()));
++ matrix<T> result(std::min(lhs.dim_m(), rhs.dim_m()), std::min(lhs.dim_n(), rhs.dim_n()));
+
+ for (uint32 i = 0; i < result.dim_m(); ++i)
+ {
+diff --git a/src/primitives-3d.cpp b/src/primitives-3d.cpp
+index b04e7c4..4532ecd 100644
+--- a/src/primitives-3d.cpp
++++ b/src/primitives-3d.cpp
+@@ -9,6 +9,7 @@
+
+ #include <valarray>
+ #include <cmath>
++#include <unistd.h>
+
+ #include <boost/foreach.hpp>
+ #define foreach BOOST_FOREACH
diff --git a/sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch b/sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch
new file mode 100644
index 000000000000..3db40f640ccd
--- /dev/null
+++ b/sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch
@@ -0,0 +1,70 @@
+ makefile | 24 ++++++++++++++----------
+ 1 files changed, 14 insertions(+), 10 deletions(-)
+
+diff --git a/makefile b/makefile
+index df699b7..9d2167b 100644
+--- a/makefile
++++ b/makefile
+@@ -2,7 +2,7 @@
+ #
+ # Copyright Maarten L. Hekkelman, Radboud University 2008-2011.
+ # Distributed under the Boost Software License, Version 1.0.
+-# (See accompanying file LICENSE_1_0.txt or copy at
++# (See aCXXompanying file LICENSE_1_0.txt or copy at
+ # http://www.boost.org/LICENSE_1_0.txt)
+ #
+ # This makefile includes a file called make.config. It will create a
+@@ -24,22 +24,23 @@ BOOST_LIBS = thread regex filesystem program_options date_time iostreams math_
+ LIBS = $(BOOST_LIBS:%=boost_%$(BOOST_LIB_SUFFIX)) z bz2
+
+ DEFINES = USE_COMPRESSION LINUX VERSION='"$(VERSION)"'
+-CC = c++
++CXX ?= c++
+
+-CFLAGS = $(INC_DIR:%=-I%) -iquote src -g -Wall -Wno-multichar -pthread
+-LDOPTS = $(LIB_DIR:%=-L%) $(LIBS:%=-l%) -g -pthread
++CPPFLAGS += $(INC_DIR:%=-I%) -iquote src
++CXXFLAGS += -Wall -Wno-multichar -pthread
++LDOPTS = $(LIB_DIR:%=-L%) $(LIBS:%=-l%) -pthread
+
+ OBJ_DIR = obj
+
+ ifeq ($(DEBUG),1)
+ OBJ_DIR := $(OBJ_DIR).dbg
+-CFLAGS += -g3
++CFLAGS +=
+ else
+ DEFINES += NDEBUG
+-CFLAGS += -O3
++CFLAGS +=
+ endif
+
+-CFLAGS += $(DEFINES:%=-D%)
++CPPFLAGS += $(DEFINES:%=-D%)
+
+ DIST_NAME = dssp-$(VERSION)
+
+@@ -49,17 +50,20 @@ OBJECTS = $(OBJ_DIR)/mkdssp.o $(OBJ_DIR)/dssp.o $(OBJ_DIR)/primitives-3d.o $(OBJ
+
+ mkdssp: $(OBJECTS)
+ @ echo linking $@
+- @ $(CC) -static -o $@ $^ $(LDOPTS)
++ $(CXX) $(LDFLAGS) -o $@ $^ $(LDOPTS)
+ @ echo OK
+
+ include $(OBJECTS:%.o=%.d)
+
+ $(OBJECTS:.o=.d):
+
+-$(OBJ_DIR)/%.o: %.cpp
++OBJ_DIR:
+ @ if [ ! -d $(OBJ_DIR) ]; then mkdir $(OBJ_DIR); fi
++
++
++$(OBJ_DIR)/%.o: %.cpp OBJ_DIR
+ @ echo compiling $@
+- @ $(CC) -MD -c -o $@ $< $(CFLAGS)
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -MD -c -o $@ $<
+
+ clean:
+ rm -rf $(OBJ_DIR)/* mkdssp
diff --git a/sci-chemistry/dssp/metadata.xml b/sci-chemistry/dssp/metadata.xml
index c6856dc7f2cf..210ad0db014c 100644
--- a/sci-chemistry/dssp/metadata.xml
+++ b/sci-chemistry/dssp/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>