summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-10 19:57:31 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-10 19:57:31 +0000
commit346fb6280873b72a83c137939fb159bf67cec209 (patch)
tree2603ddb51cad4e7de0f16d84bc087bd1d96d0a71 /sci-chemistry
parentClean old (diff)
downloadgentoo-2-346fb6280873b72a83c137939fb159bf67cec209.tar.gz
gentoo-2-346fb6280873b72a83c137939fb159bf67cec209.tar.bz2
gentoo-2-346fb6280873b72a83c137939fb159bf67cec209.zip
sci-chemistry/pdb-tools: Fix double prefix installation
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pdb-tools/ChangeLog7
-rw-r--r--sci-chemistry/pdb-tools/pdb-tools-0.2.1-r1.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/sci-chemistry/pdb-tools/ChangeLog b/sci-chemistry/pdb-tools/ChangeLog
index ad360d17a127..107d9894de74 100644
--- a/sci-chemistry/pdb-tools/ChangeLog
+++ b/sci-chemistry/pdb-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/pdb-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/ChangeLog,v 1.11 2013/04/26 10:20:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/ChangeLog,v 1.12 2013/05/10 19:57:31 jlec Exp $
+
+*pdb-tools-0.2.1-r1 (10 May 2013)
+
+ 10 May 2013; Justin Lecher <jlec@gentoo.org> +pdb-tools-0.2.1-r1.ebuild:
+ Fix double prefix installation
*pdb-tools-0.2.1 (26 Apr 2013)
diff --git a/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r1.ebuild b/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..4a2e2c3b1fe9
--- /dev/null
+++ b/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r1.ebuild,v 1.1 2013/05/10 19:57:31 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_8,1_9} )
+
+inherit fortran-2 python-single-r1 toolchain-funcs
+
+MY_PN="pdbTools"
+
+DESCRIPTION="Tools for manipulating and doing calculations on wwPDB macromolecule structure files"
+HOMEPAGE="http://code.google.com/p/pdb-tools/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}"/${MY_PN}_${PV}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ sed \
+ -e "s:script_dir,\"pdb_data\":\"${EPREFIX}/usr/share/${PN}\",\"pdb_data\":g" \
+ -i pdb_sasa.py || die
+ sed \
+ -e "/satk_path =/s:^.*$:satk_path = \"${EPREFIX}/usr/bin\":g" \
+ -i pdb_satk.py || die
+ sed \
+ -e 's:> %:>%:g' \
+ -i pdb_seq.py || die
+}
+
+src_compile() {
+ mkdir bin
+ cd satk
+ for i in *.f; do
+ einfo "$(tc-getFC) ${FFLAGS} ${LDFLAGS} ${i} -o ${i/.f}"
+ $(tc-getFC) ${FFLAGS} -c ${i} -o ${i/.f/.o} || die
+ $(tc-getFC) ${LDFLAGS} -o ../bin/${i/.f} ${i/.f/.o} || die
+ sed \
+ -e "s:${i/.f}.out:${i/.f}:g" \
+ -i ../pdb_satk.py || die
+ done
+}
+
+src_install() {
+ local script
+ insinto /usr/share/${PN}
+ doins -r pdb_data/peptides
+ rm -rf pdb_data/peptides || die
+
+ python_domodule helper pdb_data
+
+ python_moduleinto ${PN/-/_}
+ python_domodule *.py
+
+ for i in pdb_*.py; do
+ cat > ${i/.py} <<- EOF
+ #!${EPREFIX}/bin/bash
+ ${PYTHON} -O "$(python_get_sitedir)/${PN/-/_}/${i}" \$@
+ EOF
+ dobin ${i/.py}
+ done
+
+ dobin bin/*
+ dodoc README
+}