summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-21 16:50:09 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-21 16:50:09 +0000
commit7715afd2e66a7c131136b54d032d625abc1a4bea (patch)
tree04f1b2ca9a22c7a533c376e362ac2e6c6c1188d2 /sci-chemistry
parentx86 stable wrt bug #398613 (diff)
downloadgentoo-2-7715afd2e66a7c131136b54d032d625abc1a4bea.tar.gz
gentoo-2-7715afd2e66a7c131136b54d032d625abc1a4bea.tar.bz2
gentoo-2-7715afd2e66a7c131136b54d032d625abc1a4bea.zip
Version Bump, #399289
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/autodock_vina/ChangeLog10
-rw-r--r--sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild44
-rw-r--r--sci-chemistry/autodock_vina/files/1.1.2-gentoo.patch72
-rw-r--r--sci-chemistry/autodock_vina/metadata.xml12
4 files changed, 130 insertions, 8 deletions
diff --git a/sci-chemistry/autodock_vina/ChangeLog b/sci-chemistry/autodock_vina/ChangeLog
index 131dd6268cfe..6c3913f29c50 100644
--- a/sci-chemistry/autodock_vina/ChangeLog
+++ b/sci-chemistry/autodock_vina/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/autodock_vina
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock_vina/ChangeLog,v 1.3 2011/04/06 16:42:37 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock_vina/ChangeLog,v 1.4 2012/01/21 16:50:09 jlec Exp $
+
+*autodock_vina-1.1.2 (21 Jan 2012)
+
+ 21 Jan 2012; Justin Lecher <jlec@gentoo.org> +files/1.1.2-gentoo.patch,
+ +autodock_vina-1.1.2.ebuild, metadata.xml:
+ Version Bump, #399289
06 Apr 2011; Justin Lecher <jlec@gentoo.org> autodock_vina-1.1.1-r1.ebuild:
Fix compilation problem with =dev-libs/boost-1.46, #362243; thanks few and
diff --git a/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild b/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
new file mode 100644
index 000000000000..a88aebaa92d5
--- /dev/null
+++ b/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild,v 1.1 2012/01/21 16:50:09 jlec Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic versionator
+
+MY_P="${PN}_$(replace_all_version_separators _)"
+
+DESCRIPTION="Program for drug discovery, molecular docking and virtual screening"
+HOMEPAGE="http://vina.scripps.edu/"
+SRC_URI="http://vina.scripps.edu/download/${MY_P}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE="debug"
+
+RDEPEND="dev-libs/boost"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}/build/linux/release
+
+src_prepare() {
+ cd "${WORKDIR}"/${MY_P} && epatch "${FILESDIR}"/${PV}-gentoo.patch
+}
+
+src_compile() {
+ local c_options
+
+ use debug || c_options="-DNDEBUG"
+
+ append-cxxflags -DBOOST_FILESYSTEM_VERSION=2
+
+ emake \
+ BASE="${EPREFIX}"/usr/ \
+ GPP="$(tc-getCXX)" \
+ C_OPTIONS="${c_options}"
+}
+
+src_install() {
+ dobin vina{,_split}
+}
diff --git a/sci-chemistry/autodock_vina/files/1.1.2-gentoo.patch b/sci-chemistry/autodock_vina/files/1.1.2-gentoo.patch
new file mode 100644
index 000000000000..61ae8bec36f5
--- /dev/null
+++ b/sci-chemistry/autodock_vina/files/1.1.2-gentoo.patch
@@ -0,0 +1,72 @@
+ build/linux/debug/Makefile | 2 +-
+ build/linux/release/Makefile | 2 +-
+ build/makefile_common | 14 +++++++-------
+ 3 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/build/linux/debug/Makefile b/build/linux/debug/Makefile
+index 6a41cfc..8097fb9 100644
+--- a/build/linux/debug/Makefile
++++ b/build/linux/debug/Makefile
+@@ -1,7 +1,7 @@
+ BASE=/usr/local
+ BOOST_VERSION=1_41
+ BOOST_INCLUDE = $(BASE)/include
+-C_PLATFORM=-static -pthread
++C_PLATFORM=-pthread
+ GPP=/usr/local/bin/g++
+ C_OPTIONS= -g
+ BOOST_LIB_VERSION=
+diff --git a/build/linux/release/Makefile b/build/linux/release/Makefile
+index 1de1063..ded8133 100644
+--- a/build/linux/release/Makefile
++++ b/build/linux/release/Makefile
+@@ -1,7 +1,7 @@
+ BASE=/usr/local
+ BOOST_VERSION=1_41
+ BOOST_INCLUDE = $(BASE)/include
+-C_PLATFORM=-static -pthread
++C_PLATFORM=-pthread
+ GPP=/usr/local/bin/g++
+ C_OPTIONS= -O3 -DNDEBUG
+ BOOST_LIB_VERSION=
+diff --git a/build/makefile_common b/build/makefile_common
+index a940329..96336e8 100644
+--- a/build/makefile_common
++++ b/build/makefile_common
+@@ -2,29 +2,29 @@ LIBOBJ = cache.o coords.o current_weights.o everything.o grid.o szv_grid.o manif
+ MAINOBJ = main.o
+ SPLITOBJ = split.o
+
+-INCFLAGS = -I $(BOOST_INCLUDE)
++INCFLAGS = -I$(BOOST_INCLUDE)
+
+ # -pedantic fails on Mac with Boost 1.41 (syntax problems in their headers)
+ #CC = ${GPP} ${C_PLATFORM} -ansi -pedantic -Wno-long-long ${C_OPTIONS} $(INCFLAGS)
+ CC = ${GPP} ${C_PLATFORM} -ansi -Wno-long-long ${C_OPTIONS} $(INCFLAGS)
+
+-LDFLAGS = -L$(BASE)/lib -L.
++LDFLAGS += -L.
+
+-LIBS = -l boost_system${BOOST_LIB_VERSION} -l boost_thread${BOOST_LIB_VERSION} -l boost_serialization${BOOST_LIB_VERSION} -l boost_filesystem${BOOST_LIB_VERSION} -l boost_program_options${BOOST_LIB_VERSION}#-l pthread
++LIBS = -lboost_system -lboost_thread -lboost_serialization -lboost_filesystem -lboost_program_options -lpthread
+
+ .SUFFIXES: .cpp .o
+
+ %.o : ../../../src/lib/%.cpp
+- $(CC) $(CFLAGS) -o $@ -c $<
++ $(CC) $(CXXFLAGS) -o $@ -c $<
+
+ %.o : ../../../src/design/%.cpp
+- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
++ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<
+
+ %.o : ../../../src/main/%.cpp
+- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
++ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<
+
+ %.o : ../../../src/split/%.cpp
+- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
++ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<
+
+ all: vina vina_split
+
diff --git a/sci-chemistry/autodock_vina/metadata.xml b/sci-chemistry/autodock_vina/metadata.xml
index 3663c619b433..8836d2a13a76 100644
--- a/sci-chemistry/autodock_vina/metadata.xml
+++ b/sci-chemistry/autodock_vina/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
-<longdescription>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
AutoDock Vina is a new open-source program for drug discovery, molecular
docking and virtual screening, offering multi-core capability, high
performance and enhanced accuracy and ease of use. [1]
@@ -17,7 +17,7 @@ of docking with a new scoring function, efficient optimization and
multithreading
Journal of Computational Chemistry 31 (2010) 455-461
</longdescription>
-<!--
+ <!--
<use>
<flag name='flag'>Description of how USE='flag' affects this package</flag>
<flag name='userland_GNU'>Description of how USERLAND='GNU' affects this