summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-13 09:59:22 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-13 09:59:22 +0000
commit9375542ad1e069f2e58699a11b2334ea98f0499e (patch)
tree7ff1f16dbfaf6d79949b820f2daf31bab70b0090 /sci-chemistry
parentForce usbmon device for USB capturing, bug #318359, thank David Relson for re... (diff)
downloadgentoo-2-9375542ad1e069f2e58699a11b2334ea98f0499e.tar.gz
gentoo-2-9375542ad1e069f2e58699a11b2334ea98f0499e.tar.bz2
gentoo-2-9375542ad1e069f2e58699a11b2334ea98f0499e.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/refmac/ChangeLog8
-rw-r--r--sci-chemistry/refmac/files/5.5.0110-allow-dynamic-linking.patch68
-rw-r--r--sci-chemistry/refmac/refmac-5.5.0110.ebuild67
3 files changed, 142 insertions, 1 deletions
diff --git a/sci-chemistry/refmac/ChangeLog b/sci-chemistry/refmac/ChangeLog
index 6383d6808eb0..30c1710d47e7 100644
--- a/sci-chemistry/refmac/ChangeLog
+++ b/sci-chemistry/refmac/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/refmac
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.3 2010/03/28 20:43:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.4 2010/05/13 09:59:22 jlec Exp $
+
+*refmac-5.5.0110 (13 May 2010)
+
+ 13 May 2010; Justin Lecher <jlec@gentoo.org>
+ +files/5.5.0110-allow-dynamic-linking.patch, +refmac-5.5.0110.ebuild:
+ Version Bump
28 Mar 2010; Justin Lecher <jlec@gentoo.org> refmac-5.5.0109.ebuild:
Keyworded for ~x86-linux ~amd64-linux
diff --git a/sci-chemistry/refmac/files/5.5.0110-allow-dynamic-linking.patch b/sci-chemistry/refmac/files/5.5.0110-allow-dynamic-linking.patch
new file mode 100644
index 000000000000..480d6025575a
--- /dev/null
+++ b/sci-chemistry/refmac/files/5.5.0110-allow-dynamic-linking.patch
@@ -0,0 +1,68 @@
+diff --git a/makefile_refmac.inc1 b/makefile_refmac.inc1
+index 371d84d..643bf5e 100644
+--- a/makefile_refmac.inc1
++++ b/makefile_refmac.inc1
+@@ -68,9 +68,7 @@ messy_pdb.o \
+ bridge.o \
+ i0.o \
+ i1.o \
+-chbevl.o \
+-$(LLIBCIF) \
+-$(LLIBLAPACK)
++chbevl.o
+ #$(LLIBCCP) \
+ #crt0.o \
+ #heavy.o \
+@@ -95,8 +93,7 @@ make_unix_ccp4.o \
+ emin.o \
+ libcheck_min.o \
+ mol2_file.o \
+-sdf_files.o \
+-$(LLIBCCP)
++sdf_files.o
+
+ SUBM = \
+ main_makecif.o \
+@@ -116,9 +113,7 @@ make_rst2.o \
+ make_PDB.o \
+ makecif.o \
+ make_unix_ccp4.o \
+-make_vdw.o \
+-$(LLIBCCP) \
+-$(LLIBCIF)
++make_vdw.o
+
+ SUBT = \
+ tlsgroups.o \
+@@ -142,9 +137,7 @@ make_refmac_dummy.o \
+ inout_routines.o \
+ errwrt_1.o \
+ linalgebra.o \
+-subnumrec.o \
+-$(LLIBCCP) \
+-$(LLIBCIF)
++subnumrec.o
+ #--------------------------------------------------------------------------------
+
+ ed = echo 'g/^CMDW-5.0/s// /@w@q@' | tr "@" "\012" | ed -s
+@@ -154,16 +147,16 @@ ed = echo 'g/^CMDW-5.0/s// /@w@q@' | tr "@" "\012" | ed -s
+ all: refmac libcheck makecif
+
+ refmac: $(SUBR)
+- $(FC) $(FFLAGS) $(LDFLAGF)-o refmac${VERSION} ${SUBR} $(LLIBOTHERS) $(LLIBCCP)
++ $(FC) $(FFLAGS) $(LDFLAGS) -o refmac${VERSION} ${SUBR} $(LLIBOTHERS) $(LLIBCCP) $(LLIBCIF) $(LLIBLAPACK)
+
+ libcheck: $(SUBL)
+- $(FC) $(FFLAGS) -o libcheck${VERSION} $(SUBL)
++ $(FC) $(FFLAGS) $(LDFLAGS) -o libcheck${VERSION} $(SUBL) $(LLIBCCP)
+
+ makecif: $(SUBM)
+- $(FC) $(FFLAGS) -o makecif${VERSION} $(SUBM)
++ $(FC) $(FFLAGS) $(LDFLAGS) -o makecif${VERSION} $(SUBM) $(LLIBCCP) $(LLIBCIF)
+
+ tlsgroups: $(SUBT)
+- $(FC) $(FFLAGS) -o tlsgroups${VERSION} $(SUBT)
++ $(FC) $(FFLAGS) $(LDFLAGS) -o tlsgroups${VERSION} $(SUBT) $(LLIBCCP) $(LLIBCIF)
+
+ clean:
+ /bin/rm *.o
diff --git a/sci-chemistry/refmac/refmac-5.5.0110.ebuild b/sci-chemistry/refmac/refmac-5.5.0110.ebuild
new file mode 100644
index 000000000000..0fbf693c30d6
--- /dev/null
+++ b/sci-chemistry/refmac/refmac-5.5.0110.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.5.0110.ebuild,v 1.1 2010/05/13 09:59:22 jlec Exp $
+
+EAPI="2"
+
+inherit fortran base toolchain-funcs versionator
+
+DESCRIPTION="Macromolecular crystallographic refinement program"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~garib/refmac/"
+SRC_URI="${HOMEPAGE}data/refmac_stable/refmac_${PV}.tar.gz
+ test? ( http://dev.gentooexperimental.org/~jlec/distfiles/test-framework.tar.gz )"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ sci-libs/ccp4-libs
+ sci-libs/mmdb
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-allow-dynamic-linking.patch
+ )
+
+src_prepare() {
+ base_src_prepare
+ use test && epatch "${FILESDIR}"/$(get_version_component_range 1-2 ${PV})-test.log.patch
+}
+
+src_compile() {
+ emake \
+ FC=$(tc-getFC) \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ COPTIM="${CFLAGS}" \
+ FOPTIM="${FFLAGS:- -O2}" \
+ VERSION="" \
+ XFFLAGS="-fno-second-underscore" \
+ LLIBCCP="-lccp4f -lccp4c -lccif -lmmdb -lstdc++" \
+ LLIBLAPACK="-llapack -lblas" \
+ || die
+}
+
+src_test() {
+ einfo "Starting tests ..."
+ export PATH="${WORKDIR}/test-framework/scripts:${S}:${PATH}"
+ export CCP4_TEST="${WORKDIR}"/test-framework
+ export CCP4_SCR="${T}"
+ ln -sf refmac "${S}"/refmac5
+ sed '/^ANISOU/d' -i ${CCP4_TEST}/data/pdb/1vr7.pdb
+ ccp4-run-thorough-tests -v test_refmac5 || die
+}
+
+src_install() {
+ for i in refmac libcheck makecif; do
+ dobin ${i} || die
+ done
+ dosym refmac /usr/bin/refmac5 || die
+ dodoc refmac_keywords.pdf bugs_and_features.pdf || die
+}