summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-02-23 17:07:45 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-02-23 17:07:45 +0000
commita2ab4e32bd49c1e97b90706f741f9fec471b7ae8 (patch)
tree26ce66464a02ef77321fa4cfae98415ddb72f85a /sci-chemistry
parentAdded dazuko_events.h, thanks to Frantisek Mensik. (diff)
downloadgentoo-2-a2ab4e32bd49c1e97b90706f741f9fec471b7ae8.tar.gz
gentoo-2-a2ab4e32bd49c1e97b90706f741f9fec471b7ae8.tar.bz2
gentoo-2-a2ab4e32bd49c1e97b90706f741f9fec471b7ae8.zip
Add apbs-0.5.0.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog7
-rw-r--r--sci-chemistry/apbs/apbs-0.5.0.ebuild72
-rw-r--r--sci-chemistry/apbs/files/digest-apbs-0.5.03
3 files changed, 81 insertions, 1 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index 72c40eb5a466..2c4d07b3a210 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.11 2007/01/06 22:21:57 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.12 2007/02/23 17:07:45 je_fro Exp $
+
+*apbs-0.5.0 (23 Feb 2007)
+
+ 23 Feb 2007; Jeff Gardner <je_fro@gentoo.org> +apbs-0.5.0.ebuild:
+ Add apbs-0.5.0 with Big Thanks(tm) to Stephen Floor.
06 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -apbs-0.3.2.ebuild:
QA: Removed unused versions.
diff --git a/sci-chemistry/apbs/apbs-0.5.0.ebuild b/sci-chemistry/apbs/apbs-0.5.0.ebuild
new file mode 100644
index 000000000000..8cc541e05a55
--- /dev/null
+++ b/sci-chemistry/apbs/apbs-0.5.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-0.5.0.ebuild,v 1.1 2007/02/23 17:07:45 je_fro Exp $
+
+inherit eutils fortran
+
+MY_P="${P}-source-2"
+S="${WORKDIR}"/"${MY_P}"
+
+DESCRIPTION=" Software for evaluating the electrostatic properties of nanoscale biomolecular systems"
+LICENSE="GPL-2"
+HOMEPAGE="http://agave.wustl.edu/apbs/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+IUSE="blas mpi"
+KEYWORDS="~ppc ~x86 ~amd64"
+
+DEPEND="blas? ( virtual/blas )
+ sys-libs/readline
+ mpi? ( virtual/mpi )"
+
+FORTRAN="g77 gfortran"
+
+pkg_setup() {
+ # It is important that you use the same compiler to compile
+ # APBS that you used when compiling MPI.
+ fortran_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+
+ # use blas
+ use blas && local myconf="--with-blas=-lblas"
+
+ use mpi && myconf="${myconf} --with-mpiinc=/usr/include"
+
+ econf ${myconf} || die "configure failed"
+
+ # build
+ make DESTDIR=${D} || die "make failed"
+}
+
+src_install() {
+
+ # install apbs binary
+ dobin bin/apbs || die "failed to install apbs binary"
+
+ # remove useless files and install docs
+ find ./examples -name 'test.sh' -exec rm -f {} \; || \
+ die "Failed to remove test.sh files"
+ find ./examples -name 'Makefile*' -exec rm -f {} \; || \
+ die "Failed to remove Makefiles"
+ find ./tools -name 'Makefile*' -exec rm -f {} \; || \
+ die "Failed to remove Makefiles"
+
+ dohtml -r doc/index.html doc/programmer doc/tutorial \
+ doc/user-guide doc/license || \
+ die "Failed to install html docs"
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || \
+ die "Failed to install examples"
+
+ insinto /usr/share/${PF}/tools
+ doins -r tools/* || die "failed to install tools"
+
+}
diff --git a/sci-chemistry/apbs/files/digest-apbs-0.5.0 b/sci-chemistry/apbs/files/digest-apbs-0.5.0
new file mode 100644
index 000000000000..00ed5b63f7dd
--- /dev/null
+++ b/sci-chemistry/apbs/files/digest-apbs-0.5.0
@@ -0,0 +1,3 @@
+MD5 80b201d182536cb5f914a23fca4a4732 apbs-0.5.0-source-2.tar.gz 10171621
+RMD160 31a00f89052cc32d0fdf3272c214f2145ac62067 apbs-0.5.0-source-2.tar.gz 10171621
+SHA256 5f99cc6141d34800cf9e93e0e23215b3f740f6e208318698e7011602e1630a08 apbs-0.5.0-source-2.tar.gz 10171621