summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-19 08:57:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-19 08:57:24 +0000
commitb0e11bed08742fe0de66fbbc5d2622062329fdb8 (patch)
tree6477c5274d6b0c6a0053ce594d4a77d6d5d1243f /sci-chemistry
parentDrop USE=aac like upstream has #345939 by BT. (diff)
downloadgentoo-2-b0e11bed08742fe0de66fbbc5d2622062329fdb8.tar.gz
gentoo-2-b0e11bed08742fe0de66fbbc5d2622062329fdb8.tar.bz2
gentoo-2-b0e11bed08742fe0de66fbbc5d2622062329fdb8.zip
Dropp old
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/cns/ChangeLog7
-rw-r--r--sci-chemistry/cns/cns-1.2-r1.ebuild149
-rw-r--r--sci-chemistry/cns/cns-1.2.1-r1.ebuild187
-rw-r--r--sci-chemistry/cns/cns-1.2.1-r3.ebuild204
-rw-r--r--sci-chemistry/cns/cns-1.2.1-r4.ebuild215
-rw-r--r--sci-chemistry/cns/cns-1.2.ebuild125
6 files changed, 6 insertions, 881 deletions
diff --git a/sci-chemistry/cns/ChangeLog b/sci-chemistry/cns/ChangeLog
index 683ffcb43d09..4f2c8f0008ec 100644
--- a/sci-chemistry/cns/ChangeLog
+++ b/sci-chemistry/cns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/cns
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/ChangeLog,v 1.28 2010/11/18 17:05:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/ChangeLog,v 1.29 2010/11/19 08:57:24 jlec Exp $
+
+ 19 Nov 2010; Justin Lecher <jlec@gentoo.org> -cns-1.2.ebuild,
+ -cns-1.2-r1.ebuild, -cns-1.2.1-r1.ebuild, -cns-1.2.1-r3.ebuild,
+ -cns-1.2.1-r4.ebuild:
+ Dropp old
18 Nov 2010; Justin Lecher <jlec@gentoo.org> -cns-1.2.1-r2.ebuild,
cns-1.2.1-r3.ebuild, cns-1.2.1-r4.ebuild, cns-1.2.1-r5.ebuild,
diff --git a/sci-chemistry/cns/cns-1.2-r1.ebuild b/sci-chemistry/cns/cns-1.2-r1.ebuild
deleted file mode 100644
index dbec50254253..000000000000
--- a/sci-chemistry/cns/cns-1.2-r1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2-r1.ebuild,v 1.4 2010/02/06 21:49:39 jlec Exp $
-
-inherit eutils fortran toolchain-funcs
-
-MY_PN="${PN}_solve"
-MY_P="${MY_PN}_${PV}"
-
-DESCRIPTION="Crystallography and NMR System"
-HOMEPAGE="http://cns.csb.yale.edu/"
-SRC_URI="${MY_P}_all.tar.gz"
-RESTRICT="fetch"
-LICENSE="cns"
-SLOT="0"
-KEYWORDS="~ppc ~x86"
-IUSE=""
-RDEPEND="app-shells/tcsh
- !app-text/dos2unix"
-DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
-
-FORTRAN="g77 gfortran"
-
-pkg_nofetch() {
- einfo "Fill out the form at http://cns.csb.yale.edu/cns_request/"
- einfo "and place these files:"
- einfo ${A}
- einfo "in ${DISTDIR}."
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # The length of time must be at least 10, not 9
- # http://gcc.gnu.org/ml/fortran/2006-02/msg00198.html
- epatch "${FILESDIR}"/1.1-time-length-10.patch
-
- epatch "${FILESDIR}"/1.2-allow-unknown-architectures.patch
-
- # Set up location for the build directory
- # Uses obsolete `sort` syntax, so we set _POSIX2_VERSION
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nsetenv _POSIX2_VERSION 199209:g" \
- "${S}"/cns_solve_env
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nexport _POSIX2_VERSION; _POSIX2_VERSION=199209:g" \
- "${S}"/.cns_solve_env_sh
-}
-
-src_compile() {
- local GLOBALS
- local MALIGN=
- if [[ ${FORTRANC} = g77 ]]; then
- GLOBALS="-fno-globals"
- MALIGN='\$(CNS_MALIGN_I86)'
- fi
-
- # make install really means build, since it's expected to be used in-place
- emake \
- CC="$(tc-getCC)" \
- F77="${FORTRANC}" \
- LD="${FORTRANC}" \
- CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
- F77OPT="${FFLAGS:- -O2} ${MALIGN}" \
- F77STD="${GLOBALS}" \
- g77install \
- || die "emake failed"
-}
-
-src_test() {
- # We need to force on g77 manually, because we can't get aliases working
- # when we source in a -c
- einfo "Running tests ..."
- sh -c \
- "export CNS_G77=ON; source .cns_solve_env_sh; make run_tests" \
- || die "tests failed"
- einfo "Displaying test results ..."
- cat "${S}"/*_g77/test/*.diff-test
-}
-
-src_install() {
- # Install to locations resembling FHS
- sed -i \
- -e "s:${S}:usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_ROOT usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DATA \$CNS_ROOT/share/data:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DOC \$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_MODULE \$CNS_SOLVE/modules:CNS_MODULE \$CNS_DATA/modules:g" \
- -e "s:\$CNS_LIB:\$CNS_DATA:g" \
- -e "s:CNS_HELPLIB \$CNS_SOLVE/helplib:CNS_HELPLIB \$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/bin/cns_info:g" \
- "${S}"/cns_solve_env
- # I don't entirely understand why the sh version requires a leading /
- # for CNS_SOLVE and CNS_ROOT, but it does
- sed -i \
- -e "s:${S}:/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_ROOT=/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DATA=\$CNS_ROOT/share/data:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DOC=\$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_MODULE=\$CNS_SOLVE/modules:CNS_MODULE=\$CNS_DATA/modules:g" \
- -e "s:\$CNS_LIB:\$CNS_DATA:g" \
- -e "s:CNS_HELPLIB=\$CNS_SOLVE/helplib:CNS_HELPLIB=\$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/bin/cns_info:g" \
- "${S}"/.cns_solve_env_sh
-
- # Get rid of setup stuff we don't need in the installed script
- sed -i \
- -e "83,$ d" \
- -e "37,46 d" \
- "${S}"/cns_solve_env
- sed -i \
- -e "84,$ d" \
- -e "39,50 d" \
- "${S}"/.cns_solve_env_sh
-
- newbin "${S}"/*_g77/bin/cns_solve* cns_solve \
- || die "install cns_solve failed"
-
- # Can be run by either cns_solve or cns
- dosym cns_solve /usr/bin/cns
-
- # Don't want to install this
- rm -f "${S}"/*_g77/utils/Makefile
-
- dobin "${S}"/*_g77/utils/* || die "install utils failed"
-
- sed -i \
- -e "s:\$CNS_SOLVE/doc/:\$CNS_SOLVE/share/doc/${PF}/:g" \
- "${S}"/bin/cns_web
-
- dobin "${S}"/bin/cns_{edit,header,transfer,web} || die "install bin failed"
-
- insinto /usr/share/cns
- doins -r "${S}"/libraries "${S}"/modules "${S}"/helplib
- doins "${S}"/bin/cns_info
-
- insinto /etc/profile.d
- newins "${S}"/cns_solve_env cns_solve_env.csh
- newins "${S}"/.cns_solve_env_sh cns_solve_env.sh
-
- dohtml \
- -A iq,cgi,csh,cv,def,fm,gif,hkl,inp,jpeg,lib,link,list,mask,mtf,param,pdb,pdf,pl,ps,sc,sca,sdb,seq,tbl,top \
- -f all_cns_info_template,omac,def \
- -r doc/html/*
-}
diff --git a/sci-chemistry/cns/cns-1.2.1-r1.ebuild b/sci-chemistry/cns/cns-1.2.1-r1.ebuild
deleted file mode 100644
index 8d722bed9e09..000000000000
--- a/sci-chemistry/cns/cns-1.2.1-r1.ebuild
+++ /dev/null
@@ -1,187 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2.1-r1.ebuild,v 1.4 2010/11/17 13:14:53 jlec Exp $
-
-EAPI="2"
-
-inherit eutils fortran toolchain-funcs versionator flag-o-matic
-
-MY_PN="${PN}_solve"
-MY_PV="$(delete_version_separator 2)"
-MY_P="${MY_PN}_${MY_PV}"
-
-DESCRIPTION="Crystallography and NMR System"
-HOMEPAGE="http://cns.csb.yale.edu/"
-SRC_URI="${MY_P}_all-mp.tar.gz"
-
-SLOT="0"
-LICENSE="cns"
-KEYWORDS="~amd64 ~x86"
-IUSE="openmp"
-
-RDEPEND="app-shells/tcsh"
-DEPEND="${RDEPEND}"
-
-RESTRICT="fetch"
-S="${WORKDIR}/${MY_P}"
-
-FORTRAN="g77 gfortran"
-
-pkg_nofetch() {
- elog "Fill out the form at http://cns.csb.yale.edu/cns_request/"
- elog "and place these files:"
- elog ${A}
- elog "in ${DISTDIR}."
-}
-
-pkg_setup() {
- fortran_pkg_setup
- tc-has-openmp
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-gentoo.patch
-
- use openmp && append-fflags -fopenmp
-
- # the code uses Intel-compiler-specific directives
- epatch "${FILESDIR}"/${PV}-allow-gcc-openmp.patch
-
- use openmp && OMPLIB="-lgomp"
-
- use amd64 && \
- append-cflags "-DINTEGER='long long int'" && \
- append-fflags -fdefault-integer-8
-
- # Set up location for the build directory
- # Uses obsolete `sort` syntax, so we set _POSIX2_VERSION
- cp "${FILESDIR}"/cns_solve_env_sh "${T}"/
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nsetenv _POSIX2_VERSION 199209:g" \
- "${S}"/cns_solve_env
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nexport _POSIX2_VERSION; _POSIX2_VERSION=199209:g" \
- "${T}"/cns_solve_env_sh
-}
-
-src_compile() {
- local GLOBALS
- local MALIGN
- if [[ ${FORTRANC} = g77 ]]; then
- GLOBALS="-fno-globals"
- MALIGN='\$(CNS_MALIGN_I86)'
- fi
-
- # Set up the compiler to use
- pushd instlib/machine/unsupported/g77-unix 2>/dev/null
- ln -s Makefile.header Makefile.header.${FORTRANC} || die
- popd 2>/dev/null
-
- # make install really means build, since it's expected to be used in-place
- emake \
- CC="$(tc-getCC)" \
- F77="${FORTRANC}" \
- LD="${FORTRANC}" \
- CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
- LDFLAGS="${LDFLAGS}" \
- F77OPT="${FFLAGS:- -O2} ${MALIGN}" \
- F77STD="${GLOBALS}" \
- OMPLIB="${OMPLIB}" \
- g77install \
- || die "emake failed"
-
-}
-
-src_test() {
- # We need to force on g77 manually, because we can't get aliases working
- # when we source in a -c
- einfo "Running tests ..."
- sh -c \
- "export CNS_G77=ON; source ${T}/cns_solve_env_sh; make run_tests" \
- || die "tests failed"
- einfo "Displaying test results ..."
- cat "${S}"/*_g77/test/*.diff-test
-}
-
-src_install() {
- # Install to locations resembling FHS
- sed -i \
- -e "s:${S}:usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_ROOT /usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DATA \$CNS_ROOT/share/cns:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DOC \$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_LIB \$CNS_SOLVE/libraries:CNS_LIB \$CNS_DATA/libraries:g" \
- -e "s:CNS_MODULE \$CNS_SOLVE/modules:CNS_MODULE \$CNS_DATA/modules:g" \
- -e "s:CNS_HELPLIB \$CNS_SOLVE/helplib:CNS_HELPLIB \$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/cns_info:g" \
- "${S}"/cns_solve_env
- # I don't entirely understand why the sh version requires a leading /
- # for CNS_SOLVE and CNS_ROOT, but it does
- sed -i \
- -e "s:${S}:/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_ROOT=/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DATA=\$CNS_ROOT/share/cns:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DOC=\$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_LIB=\$CNS_SOLVE/libraries:CNS_LIB=\$CNS_DATA/libraries:g" \
- -e "s:CNS_MODULE=\$CNS_SOLVE/modules:CNS_MODULE=\$CNS_DATA/modules:g" \
- -e "s:CNS_HELPLIB=\$CNS_SOLVE/helplib:CNS_HELPLIB=\$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/cns_info:g" \
- "${T}"/cns_solve_env_sh
-
- # Get rid of setup stuff we don't need in the installed script
- sed -i \
- -e "83,$ d" \
- -e "37,46 d" \
- "${S}"/cns_solve_env
- sed -i \
- -e "84,$ d" \
- -e "39,50 d" \
- "${T}"/cns_solve_env_sh
-
- newbin "${S}"/*_g77/bin/cns_solve* cns_solve \
- || die "install cns_solve failed"
-
- # Can be run by either cns_solve or cns
- dosym cns_solve /usr/bin/cns
-
- # Don't want to install this
- rm -f "${S}"/*_g77/utils/Makefile
-
- dobin "${S}"/*_g77/utils/* || die "install utils failed"
-
- sed -i \
- -e "s:\$CNS_SOLVE/doc/:\$CNS_SOLVE/share/doc/${PF}/:g" \
- "${S}"/bin/cns_web
-
- dobin "${S}"/bin/cns_{edit,header,transfer,web} || die "install bin failed"
-
- insinto /usr/share/cns
- doins -r "${S}"/libraries "${S}"/modules "${S}"/helplib
- doins "${S}"/bin/cns_info
-
- insinto /etc/profile.d
- newins "${S}"/cns_solve_env cns_solve_env.csh
- newins "${T}"/cns_solve_env_sh cns_solve_env.sh
-
- dohtml \
- -A iq,cgi,csh,cv,def,fm,gif,hkl,inp,jpeg,lib,link,list,mask,mtf,param,pdb,pdf,pl,ps,sc,sca,sdb,seq,tbl,top \
- -f all_cns_info_template,omac,def \
- -r doc/html/* || die
-
- # Conflits with app-text/dos2unix
- rm -f "${D}"/usr/bin/dos2unix
-}
-
-pkg_info() {
- if use openmp; then
- elog "Set OMP_NUM_THREADS to the number of threads you want."
- elog "If you get segfaults on large structures, set the GOMP_STACKSIZE"
- elog "variable if using gcc (16384 should be good)."
- fi
-}
-
-pkg_postinst() {
- pkg_info
-}
diff --git a/sci-chemistry/cns/cns-1.2.1-r3.ebuild b/sci-chemistry/cns/cns-1.2.1-r3.ebuild
deleted file mode 100644
index d556cf1d4ec1..000000000000
--- a/sci-chemistry/cns/cns-1.2.1-r3.ebuild
+++ /dev/null
@@ -1,204 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2.1-r3.ebuild,v 1.4 2010/11/18 17:05:04 jlec Exp $
-
-EAPI="3"
-
-inherit eutils fortran toolchain-funcs versionator flag-o-matic
-
-MY_PN="${PN}_solve"
-MY_PV="$(delete_version_separator 2)"
-MY_P="${MY_PN}_${MY_PV}"
-
-DESCRIPTION="Crystallography and NMR System"
-HOMEPAGE="http://cns.csb.yale.edu/"
-SRC_URI="${MY_P}_all-mp.tar.gz
- aria? ( aria2.3.1.tar.gz )"
-
-SLOT="0"
-LICENSE="cns"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="aria openmp"
-
-RDEPEND="app-shells/tcsh"
-DEPEND="${RDEPEND}"
-
-RESTRICT="fetch"
-S="${WORKDIR}/${MY_P}"
-
-FORTRAN="g77 gfortran"
-
-pkg_nofetch() {
- elog "Fill out the form at http://cns.csb.yale.edu/cns_request/"
- use aria && elog "and http://aria.pasteur.fr/"
- elog "and place these files:"
- elog ${A}
- elog "in ${DISTDIR}."
-}
-
-pkg_setup() {
- fortran_pkg_setup
- tc-has-openmp
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-gentoo.patch
- epatch "${FILESDIR}"/${PV}-parallel.patch
-
- pushd "${WORKDIR}"/aria* >& /dev/null
- if use aria; then
- # Update the cns sources in aria for version 1.2.1
- epatch "${FILESDIR}"/1.2.1-aria2.3.patch
-
- # Update the code with aria specific things
- cp -rf cns/src/* "${S}"/source/
- fi
- popd >& /dev/null
-
- use openmp && append-fflags -fopenmp
-
- # the code uses Intel-compiler-specific directives
- epatch "${FILESDIR}"/${PV}-allow-gcc-openmp.patch
-
- use openmp && OMPLIB="-lgomp"
-
- use amd64 && \
- append-cflags "-DINTEGER='long long int'" && \
- append-fflags -fdefault-integer-8
-
- # Set up location for the build directory
- # Uses obsolete `sort` syntax, so we set _POSIX2_VERSION
- cp "${FILESDIR}"/cns_solve_env_sh "${T}"/
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nsetenv _POSIX2_VERSION 199209:g" \
- "${S}"/cns_solve_env
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nexport _POSIX2_VERSION; _POSIX2_VERSION=199209:g" \
- "${T}"/cns_solve_env_sh
-
- einfo "Fixing shebangs..."
- find "${S}" -type f \
- -exec sed "s:/bin/csh:${EPREFIX}/bin/csh:g" -i '{}' \; || die
-}
-
-src_compile() {
- local GLOBALS
- local MALIGN
- if [[ ${FORTRANC} = g77 ]]; then
- GLOBALS="-fno-globals"
- MALIGN='\$(CNS_MALIGN_I86)'
- fi
-
- # Set up the compiler to use
- pushd instlib/machine/unsupported/g77-unix 2>/dev/null
- ln -s Makefile.header Makefile.header.${FORTRANC} || die
- popd 2>/dev/null
-
- # make install really means build, since it's expected to be used in-place
- # -j1 doesn't mean we do no respect MAKEOPTS!
- emake -j1 \
- CC="$(tc-getCC)" \
- F77="${FORTRANC}" \
- LD="${FORTRANC}" \
- CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
- LDFLAGS="${LDFLAGS}" \
- F77OPT="${FFLAGS:- -O2} ${MALIGN}" \
- F77STD="${GLOBALS}" \
- OMPLIB="${OMPLIB}" \
- g77install \
- || die "emake failed"
-
-}
-
-src_test() {
- # We need to force on g77 manually, because we can't get aliases working
- # when we source in a -c
- einfo "Running tests ..."
- sh -c \
- "export CNS_G77=ON; source ${T}/cns_solve_env_sh; make run_tests" \
- || die "tests failed"
- einfo "Displaying test results ..."
- cat "${S}"/*_g77/test/*.diff-test
-}
-
-src_install() {
- # Install to locations resembling FHS
- sed -i \
- -e "s:${S}:usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_ROOT ${EPREFIX}/usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DATA \$CNS_ROOT/share/cns:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DOC \$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_LIB \$CNS_SOLVE/libraries:CNS_LIB \$CNS_DATA/libraries:g" \
- -e "s:CNS_MODULE \$CNS_SOLVE/modules:CNS_MODULE \$CNS_DATA/modules:g" \
- -e "s:CNS_HELPLIB \$CNS_SOLVE/helplib:CNS_HELPLIB \$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/cns_info:g" \
- "${S}"/cns_solve_env
- # I don't entirely understand why the sh version requires a leading /
- # for CNS_SOLVE and CNS_ROOT, but it does
- sed -i \
- -e "s:${S}:/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_ROOT=${EPREFIX}/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DATA=\$CNS_ROOT/share/cns:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DOC=\$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_LIB=\$CNS_SOLVE/libraries:CNS_LIB=\$CNS_DATA/libraries:g" \
- -e "s:CNS_MODULE=\$CNS_SOLVE/modules:CNS_MODULE=\$CNS_DATA/modules:g" \
- -e "s:CNS_HELPLIB=\$CNS_SOLVE/helplib:CNS_HELPLIB=\$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/cns_info:g" \
- "${T}"/cns_solve_env_sh
-
- # Get rid of setup stuff we don't need in the installed script
- sed -i \
- -e "83,$ d" \
- -e "37,46 d" \
- "${S}"/cns_solve_env
- sed -i \
- -e "84,$ d" \
- -e "39,50 d" \
- "${T}"/cns_solve_env_sh
-
- newbin "${S}"/*_g77/bin/cns_solve* cns_solve \
- || die "install cns_solve failed"
-
- # Can be run by either cns_solve or cns
- dosym cns_solve /usr/bin/cns
-
- # Don't want to install this
- rm -f "${S}"/*_g77/utils/Makefile
-
- dobin "${S}"/*_g77/utils/* || die "install utils failed"
-
- sed -i \
- -e "s:\$CNS_SOLVE/doc/:\$CNS_SOLVE/share/doc/${PF}/:g" \
- "${S}"/bin/cns_web || die
-
- dobin "${S}"/bin/cns_{edit,header,transfer,web} || die "install bin failed"
-
- insinto /usr/share/cns
- doins -r "${S}"/libraries "${S}"/modules "${S}"/helplib || die
- doins "${S}"/bin/cns_info || die
-
- insinto /etc/profile.d
- newins "${S}"/cns_solve_env cns_solve_env.csh || die
- newins "${T}"/cns_solve_env_sh cns_solve_env.sh || die
-
- dohtml \
- -A iq,cgi,csh,cv,def,fm,gif,hkl,inp,jpeg,lib,link,list,mask,mtf,param,pdb,pdf,pl,ps,sc,sca,sdb,seq,tbl,top \
- -f all_cns_info_template,omac,def \
- -r doc/html/* || die
- # Conflits with app-text/dos2unix
- rm -f "${D}"/usr/bin/dos2unix
-}
-
-pkg_info() {
- if use openmp; then
- elog "Set OMP_NUM_THREADS to the number of threads you want."
- elog "If you get segfaults on large structures, set the GOMP_STACKSIZE"
- elog "variable if using gcc (16384 should be good)."
- fi
-}
-
-pkg_postinst() {
- pkg_info
-}
diff --git a/sci-chemistry/cns/cns-1.2.1-r4.ebuild b/sci-chemistry/cns/cns-1.2.1-r4.ebuild
deleted file mode 100644
index 581854446537..000000000000
--- a/sci-chemistry/cns/cns-1.2.1-r4.ebuild
+++ /dev/null
@@ -1,215 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2.1-r4.ebuild,v 1.4 2010/11/18 17:05:04 jlec Exp $
-
-EAPI="3"
-
-inherit eutils fortran toolchain-funcs versionator flag-o-matic
-
-MY_PN="${PN}_solve"
-MY_PV="$(delete_version_separator 2)"
-MY_P="${MY_PN}_${MY_PV}"
-
-DESCRIPTION="Crystallography and NMR System"
-HOMEPAGE="http://cns.csb.yale.edu/"
-SRC_URI="${MY_P}_all-mp.tar.gz
- aria? ( aria2.3.1.tar.gz )"
-
-SLOT="0"
-LICENSE="cns"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="aria openmp"
-
-RDEPEND="app-shells/tcsh"
-DEPEND="${RDEPEND}"
-
-RESTRICT="fetch"
-S="${WORKDIR}/${MY_P}"
-
-FORTRAN="gfortran ifc"
-
-pkg_nofetch() {
- elog "Fill out the form at http://cns.csb.yale.edu/cns_request/"
- use aria && elog "and http://aria.pasteur.fr/"
- elog "and place these files:"
- elog ${A}
- elog "in ${DISTDIR}."
-}
-
-pkg_setup() {
- fortran_pkg_setup
- tc-has-openmp
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-gentoo.patch
- epatch "${FILESDIR}"/${PV}-parallel.patch
-
- if use aria; then
- pushd "${WORKDIR}"/aria* >& /dev/null
- # Update the cns sources in aria for version 1.2.1
- epatch "${FILESDIR}"/1.2.1-aria2.3.patch
-
- # Update the code with aria specific things
- cp -rf cns/src/* "${S}"/source/
- popd >& /dev/null
- fi
-
- # the code uses Intel-compiler-specific directives
- if [[ ${FORTRANC} == gfortran ]]; then
- epatch "${FILESDIR}"/${PV}-allow-gcc-openmp.patch
- use openmp && \
- OMPLIB="-lgomp" && append-flags -fopenmp
- COMP="gfortran"
- use amd64 && \
- append-fflags -fdefault-integer-8
- else
- epatch "${FILESDIR}"/${PV}-ifort.patch
- use openmp && OMPLIB="-lgomp" && \
- append-flags -openmp && append-ldflags -openmp
- COMP="ifort"
- use amd64 && append-fflags -i8
- append-fflags -Vaxlib
- append-ldflags -Vaxlib
- fi
-
- use amd64 && \
- append-cflags "-DINTEGER='long long int'"
-
- # Set up location for the build directory
- # Uses obsolete `sort` syntax, so we set _POSIX2_VERSION
- cp "${FILESDIR}"/cns_solve_env_sh "${T}"/
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nsetenv _POSIX2_VERSION 199209:g" \
- "${S}"/cns_solve_env
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nexport _POSIX2_VERSION; _POSIX2_VERSION=199209:g" \
- "${T}"/cns_solve_env_sh
-
- einfo "Fixing shebangs..."
- find "${S}" -type f \
- -exec sed "s:/bin/csh:${EPREFIX}/bin/csh:g" -i '{}' \; || die
-}
-
-src_compile() {
- local GLOBALS
- local MALIGN
- if [[ ${FORTRANC} = g77 ]]; then
- GLOBALS="-fno-globals"
- MALIGN='\$(CNS_MALIGN_I86)'
- fi
-
- # Set up the compiler to use
- pushd instlib/machine/unsupported/g77-unix 2>/dev/null
- ln -s Makefile.header Makefile.header.${FORTRANC} || die
- popd 2>/dev/null
-
- # make install really means build, since it's expected to be used in-place
- # -j1 doesn't mean we do no respect MAKEOPTS!
- emake -j1 \
- CC="$(tc-getCC)" \
- F77="${FORTRANC}" \
- LD="${FORTRANC}" \
- CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
- LDFLAGS="${LDFLAGS}" \
- F77OPT="${FFLAGS:- -O2} ${MALIGN}" \
- F77STD="${GLOBALS}" \
- OMPLIB="${OMPLIB}" \
- compiler="${COMP}" \
- install \
- || die "emake failed"
-
-}
-
-src_test() {
- # We need to force on g77 manually, because we can't get aliases working
- # when we source in a -c
- einfo "Running tests ..."
- sh -c \
- "export CNS_G77=ON; source ${T}/cns_solve_env_sh; make run_tests" \
- || die "tests failed"
- einfo "Displaying test results ..."
- cat "${S}"/*_g77/test/*.diff-test
-}
-
-src_install() {
- # Install to locations resembling FHS
- sed -i \
- -e "s:${S}:usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_ROOT ${EPREFIX}/usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DATA \$CNS_ROOT/share/cns:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DOC \$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_LIB \$CNS_SOLVE/libraries:CNS_LIB \$CNS_DATA/libraries:g" \
- -e "s:CNS_MODULE \$CNS_SOLVE/modules:CNS_MODULE \$CNS_DATA/modules:g" \
- -e "s:CNS_HELPLIB \$CNS_SOLVE/helplib:CNS_HELPLIB \$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/cns_info:g" \
- "${S}"/cns_solve_env
- # I don't entirely understand why the sh version requires a leading /
- # for CNS_SOLVE and CNS_ROOT, but it does
- sed -i \
- -e "s:${S}:/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_ROOT=${EPREFIX}/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DATA=\$CNS_ROOT/share/cns:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DOC=\$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_LIB=\$CNS_SOLVE/libraries:CNS_LIB=\$CNS_DATA/libraries:g" \
- -e "s:CNS_MODULE=\$CNS_SOLVE/modules:CNS_MODULE=\$CNS_DATA/modules:g" \
- -e "s:CNS_HELPLIB=\$CNS_SOLVE/helplib:CNS_HELPLIB=\$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/cns_info:g" \
- "${T}"/cns_solve_env_sh
-
- # Get rid of setup stuff we don't need in the installed script
- sed -i \
- -e "83,$ d" \
- -e "37,46 d" \
- "${S}"/cns_solve_env
- sed -i \
- -e "84,$ d" \
- -e "39,50 d" \
- "${T}"/cns_solve_env_sh
-
- newbin "${S}"/*linux*/bin/cns_solve* cns_solve \
- || die "install cns_solve failed"
-
- # Can be run by either cns_solve or cns
- dosym cns_solve /usr/bin/cns
-
- # Don't want to install this
- rm -f "${S}"/*linux*/utils/Makefile
-
- dobin "${S}"/*linux*/utils/* || die "install utils failed"
-
- sed -i \
- -e "s:\$CNS_SOLVE/doc/:\$CNS_SOLVE/share/doc/${PF}/:g" \
- "${S}"/bin/cns_web || die
-
- dobin "${S}"/bin/cns_{edit,header,transfer,web} || die "install bin failed"
-
- insinto /usr/share/cns
- doins -r "${S}"/libraries "${S}"/modules "${S}"/helplib || die
- doins "${S}"/bin/cns_info || die
-
- insinto /etc/profile.d
- newins "${S}"/cns_solve_env cns_solve_env.csh || die
- newins "${T}"/cns_solve_env_sh cns_solve_env.sh || die
-
- dohtml \
- -A iq,cgi,csh,cv,def,fm,gif,hkl,inp,jpeg,lib,link,list,mask,mtf,param,pdb,pdf,pl,ps,sc,sca,sdb,seq,tbl,top \
- -f all_cns_info_template,omac,def \
- -r doc/html/* || die
- # Conflits with app-text/dos2unix
- rm -f "${D}"/usr/bin/dos2unix
-}
-
-pkg_info() {
- if use openmp; then
- elog "Set OMP_NUM_THREADS to the number of threads you want."
- elog "If you get segfaults on large structures, set the GOMP_STACKSIZE"
- elog "variable if using gcc (16384 should be good)."
- fi
-}
-
-pkg_postinst() {
- pkg_info
-}
diff --git a/sci-chemistry/cns/cns-1.2.ebuild b/sci-chemistry/cns/cns-1.2.ebuild
deleted file mode 100644
index c33d0c0b3b85..000000000000
--- a/sci-chemistry/cns/cns-1.2.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2.ebuild,v 1.3 2010/02/06 21:49:39 jlec Exp $
-
-inherit eutils fortran toolchain-funcs
-
-MY_PN="${PN}_solve"
-MY_P="${MY_PN}_${PV}"
-
-DESCRIPTION="Crystallography and NMR System"
-HOMEPAGE="http://cns.csb.yale.edu/"
-SRC_URI="${MY_P}_all.tar.gz"
-RESTRICT="fetch"
-LICENSE="cns"
-SLOT="0"
-KEYWORDS="~ppc ~x86"
-IUSE=""
-RDEPEND="app-shells/tcsh
- !app-text/dos2unix"
-DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
-
-FORTRAN="g77 gfortran"
-
-pkg_nofetch() {
- einfo "Fill out the form at http://cns.csb.yale.edu/cns_request/"
- einfo "and place these files:"
- einfo ${A}
- einfo "in ${DISTDIR}."
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # The length of time must be at least 10, not 9
- # http://gcc.gnu.org/ml/fortran/2006-02/msg00198.html
- epatch "${FILESDIR}"/1.1-time-length-10.patch
-
- # Set up location for the build directory
- # Uses obsolete `sort` syntax, so we set _POSIX2_VERSION
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nsetenv _POSIX2_VERSION 199209:g" \
- "${S}"/cns_solve_env
-}
-
-src_compile() {
- local GLOBALS
- if [[ ${FORTRANC} = g77 ]]; then
- GLOBALS="-fno-globals"
- fi
-
- # make install really means build, since it's expected to be used in-place
- emake \
- CC="$(tc-getCC)" \
- F77="${FORTRANC}" \
- LD="${FORTRANC}" \
- CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
- F77OPT="${FFLAGS:- -O2} \$(CNS_MALIGN_I86)" \
- F77STD="${GLOBALS}" \
- LDFLAGS="${LDFLAGS}" \
- g77install \
- || die "emake failed"
-}
-
-src_test() {
- # We need to force on g77 manually, because we can't get aliases working
- # when we source in a -c
- einfo "Running tests ..."
- csh -c \
- "setenv CNS_G77; source cns_solve_env; make run_tests" \
- || die "tests failed"
- einfo "Displaying test results ..."
- cat "${S}"/*_g77/test/*.diff-test
-}
-
-src_install() {
- # Install to locations resembling FHS
- sed -i \
- -e "s:${S}:usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_ROOT usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DATA \$CNS_ROOT/share/data:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DOC \$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_MODULE \$CNS_SOLVE/modules:CNS_MODULE \$CNS_DATA/modules:g" \
- -e "s:\$CNS_LIB:\$CNS_DATA:g" \
- -e "s:CNS_HELPLIB \$CNS_SOLVE/helplib:CNS_HELPLIB \$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/bin/cns_info:g" \
- "${S}"/cns_solve_env
-
- # Get rid of setup stuff we don't need in the installed script
- sed -i \
- -e "83,$ d" \
- -e "37,46 d" \
- "${S}"/cns_solve_env
-
- newbin "${S}"/*_g77/bin/cns_solve* cns_solve \
- || die "install cns_solve failed"
-
- # Can be run by either cns_solve or cns
- dosym cns_solve /usr/bin/cns
-
- # Don't want to install this
- rm -f "${S}"/*_g77/utils/Makefile
-
- dobin "${S}"/*_g77/utils/* || die "install utils failed"
-
- dobin "${S}"/bin/cns_{edit,header,transfer,web} || die "install bin failed"
-
- insinto /usr/share/cns
- doins -r "${S}"/libraries "${S}"/modules "${S}"/helplib
- doins "${S}"/bin/cns_info
- doins "${S}"/cns_solve_env
-
- dohtml \
- -A iq,cgi,csh,cv,def,fm,gif,hkl,inp,jpeg,lib,link,list,mask,mtf,param,pdb,pdf,pl,ps,sc,sca,sdb,seq,tbl,top \
- -f all_cns_info_template,omac,def \
- -r doc/html/*
-}
-
-pkg_postinst() {
- ewarn "You must source ${ROOT}usr/share/cns/cns_solve_env"
- ewarn "before running CNS. It's a C-shell script,"
- ewarn "so you also must be using csh or tcsh."
-}