summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-02-21 16:58:18 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-02-21 16:58:18 +0000
commitbafc1ef8a97abb8d2b7231e091f236656086f6fb (patch)
tree6f12c1e314be1d1c89a8590e25310670c764de90 /sci-chemistry
parentvirtual/libintl is an hard dep. (diff)
downloadgentoo-2-bafc1ef8a97abb8d2b7231e091f236656086f6fb.tar.gz
gentoo-2-bafc1ef8a97abb8d2b7231e091f236656086f6fb.tar.bz2
gentoo-2-bafc1ef8a97abb8d2b7231e091f236656086f6fb.zip
(#123573) Build and install utilities; fix by hodak@nemo.physics.ncsu.edu.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gopenmol/ChangeLog10
-rw-r--r--sci-chemistry/gopenmol/files/digest-gopenmol-3.00-r13
-rw-r--r--sci-chemistry/gopenmol/gopenmol-3.00-r1.ebuild70
3 files changed, 81 insertions, 2 deletions
diff --git a/sci-chemistry/gopenmol/ChangeLog b/sci-chemistry/gopenmol/ChangeLog
index f0c980b08a1a..3a5f75572a71 100644
--- a/sci-chemistry/gopenmol/ChangeLog
+++ b/sci-chemistry/gopenmol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/gopenmol
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/ChangeLog,v 1.1 2005/12/03 04:25:44 spyderous Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/ChangeLog,v 1.2 2006/02/21 16:58:18 spyderous Exp $
+
+*gopenmol-3.00-r1 (21 Feb 2006)
+
+ 21 Feb 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +gopenmol-3.00-r1.ebuild:
+ (#123573) Build and install utilities; fix by hodak@nemo.physics.ncsu.edu.
*gopenmol-3.00 (03 Dec 2005)
diff --git a/sci-chemistry/gopenmol/files/digest-gopenmol-3.00-r1 b/sci-chemistry/gopenmol/files/digest-gopenmol-3.00-r1
new file mode 100644
index 000000000000..516dc395dd1e
--- /dev/null
+++ b/sci-chemistry/gopenmol/files/digest-gopenmol-3.00-r1
@@ -0,0 +1,3 @@
+MD5 4e12ee6680c093a3bf056dde1d28fea2 gopenmol-3.00-linux.tar.gz 29615195
+RMD160 8ed743925bf2c8583228fa19d8afbdc37c0af8de gopenmol-3.00-linux.tar.gz 29615195
+SHA256 314494a751f65c28d015fee854d2ee347fecbca6ccf31bb7e04db7eda6a16a23 gopenmol-3.00-linux.tar.gz 29615195
diff --git a/sci-chemistry/gopenmol/gopenmol-3.00-r1.ebuild b/sci-chemistry/gopenmol/gopenmol-3.00-r1.ebuild
new file mode 100644
index 000000000000..47a66fabbfae
--- /dev/null
+++ b/sci-chemistry/gopenmol/gopenmol-3.00-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/gopenmol-3.00-r1.ebuild,v 1.1 2006/02/21 16:58:18 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="gOpenMol is a tool for the visualization and analysis of molecular structures"
+HOMEPAGE="http://www.csc.fi/gopenmol"
+SRC_URI="${HOMEPAGE}/distribute/${P}-linux.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/tcl-8.4*
+ =dev-lang/tk-8.4*
+ dev-tcltk/bwidget
+ virtual/opengl
+ virtual/glut
+ media-libs/jpeg
+ dev-lang/python
+ || ( (
+ x11-libs/libXmu
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXi
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/gOpenMol-${PV}/src"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-include-config-for-plugins.patch
+}
+
+src_compile() {
+ econf || die "./configure failed"
+
+ emake || die "emake failed"
+
+ # Plugins are not built by default
+ cd ${S}/plugins
+ emake || die "emake plugins failed"
+
+ # Utilities are not built by default
+ cd ${S}/utility
+ emake || die "emake utility failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ cd ${S}/plugins
+ einstall || die "einstall plugins failed"
+
+ cd ${S}/utility
+ einstall || die "einstall utility failed"
+
+ dosed /usr/bin/rungOpenMol
+}
+
+pkg_postinst() {
+ einfo "Run gOpenMol using the rungOpenMol script."
+}