summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-24 10:49:49 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-24 10:49:49 +0000
commitf56d9dbddcc62915561f387493a22b9b94be7473 (patch)
treee45d68037d6dc4acf430b90e75390adf64efc690 /sci-chemistry
parentVersion bump. Fixes bug 349546, thanks to matsuu for providing patches. (diff)
downloadgentoo-2-f56d9dbddcc62915561f387493a22b9b94be7473.tar.gz
gentoo-2-f56d9dbddcc62915561f387493a22b9b94be7473.tar.bz2
gentoo-2-f56d9dbddcc62915561f387493a22b9b94be7473.zip
Don't mix FLAGS
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/refmac/ChangeLog8
-rw-r--r--sci-chemistry/refmac/files/5.5.0110-allow-dynamic-linking.patch20
-rw-r--r--sci-chemistry/refmac/refmac-5.5.0110-r2.ebuild70
3 files changed, 95 insertions, 3 deletions
diff --git a/sci-chemistry/refmac/ChangeLog b/sci-chemistry/refmac/ChangeLog
index f6058be2ed08..771c57beefc9 100644
--- a/sci-chemistry/refmac/ChangeLog
+++ b/sci-chemistry/refmac/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/refmac
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.28 2010/12/21 07:39:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.29 2010/12/24 10:49:49 jlec Exp $
+
+*refmac-5.5.0110-r2 (24 Dec 2010)
+
+ 24 Dec 2010; Justin Lecher <jlec@gentoo.org>
+ files/5.5.0110-allow-dynamic-linking.patch, +refmac-5.5.0110-r2.ebuild:
+ Don't mix FLAGS
*refmac-5.6.0096 (21 Dec 2010)
diff --git a/sci-chemistry/refmac/files/5.5.0110-allow-dynamic-linking.patch b/sci-chemistry/refmac/files/5.5.0110-allow-dynamic-linking.patch
index 480d6025575a..1efbaa04d9e6 100644
--- a/sci-chemistry/refmac/files/5.5.0110-allow-dynamic-linking.patch
+++ b/sci-chemistry/refmac/files/5.5.0110-allow-dynamic-linking.patch
@@ -1,5 +1,18 @@
+diff --git a/makefile b/makefile
+index 66d4cee..5270677 100644
+--- a/makefile
++++ b/makefile
+@@ -9,7 +9,7 @@ XFFLAGS = -fno-second-underscore -static
+ XCFLAGS = -DGFORTRAN -DPROTOTYPE
+ FFLAGS = $(FOPTIM) $(XFFLAGS)
+ CFLAGS = $(COPTIM) $(XCFLAGS)
+-CPPFLAGS = $(CFLAGS)
++CPPFLAGS = $(CXXFLAGS) $(XCFLAGS)
+
+ LLIBCIF =
+ LLIBCCP = $(CLIB)/libccp4f.a $(CLIB)/libccp4c.a
diff --git a/makefile_refmac.inc1 b/makefile_refmac.inc1
-index 371d84d..643bf5e 100644
+index 371d84d..557077f 100644
--- a/makefile_refmac.inc1
+++ b/makefile_refmac.inc1
@@ -68,9 +68,7 @@ messy_pdb.o \
@@ -45,7 +58,7 @@ index 371d84d..643bf5e 100644
#--------------------------------------------------------------------------------
ed = echo 'g/^CMDW-5.0/s// /@w@q@' | tr "@" "\012" | ed -s
-@@ -154,16 +147,16 @@ ed = echo 'g/^CMDW-5.0/s// /@w@q@' | tr "@" "\012" | ed -s
+@@ -154,18 +147,19 @@ ed = echo 'g/^CMDW-5.0/s// /@w@q@' | tr "@" "\012" | ed -s
all: refmac libcheck makecif
refmac: $(SUBR)
@@ -66,3 +79,6 @@ index 371d84d..643bf5e 100644
clean:
/bin/rm *.o
+
+ bridge.o: bridge.cpp llhood.h covmat.h Gauss.h tabfunc.h
++ $(CXX) $(CXXFLAGS) -c bridge.cpp
diff --git a/sci-chemistry/refmac/refmac-5.5.0110-r2.ebuild b/sci-chemistry/refmac/refmac-5.5.0110-r2.ebuild
new file mode 100644
index 000000000000..4614807adbef
--- /dev/null
+++ b/sci-chemistry/refmac/refmac-5.5.0110-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.5.0110-r2.ebuild,v 1.1 2010/12/24 10:49:49 jlec Exp $
+
+EAPI="2"
+
+inherit base toolchain-funcs versionator
+
+DESCRIPTION="Macromolecular crystallographic refinement program"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~garib/refmac/"
+SRC_URI="${HOMEPAGE}data/refmac_stable/refmac_${PV}.tar.gz
+ test? ( http://dev.gentooexperimental.org/~jlec/distfiles/test-framework.tar.gz )"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ sci-chemistry/makecif
+ sci-libs/ccp4-libs
+ sci-libs/mmdb
+ <sci-libs/monomer-db-1
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-allow-dynamic-linking.patch
+ )
+
+src_prepare() {
+ base_src_prepare
+ use test && epatch "${FILESDIR}"/$(get_version_component_range 1-2 ${PV})-test.log.patch
+}
+
+src_compile() {
+ emake \
+ FC=$(tc-getFC) \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ COPTIM="${CFLAGS}" \
+ FOPTIM="${FFLAGS:- -O2}" \
+ VERSION="" \
+ XFFLAGS="-fno-second-underscore" \
+ LLIBCCP="-lccp4f -lccp4c -lccif -lmmdb -lstdc++" \
+ LLIBLAPACK="-llapack -lblas" \
+ ${PN} libcheck || die
+}
+
+src_test() {
+ einfo "Starting tests ..."
+ export PATH="${WORKDIR}/test-framework/scripts:${S}:${PATH}"
+ export CCP4_TEST="${WORKDIR}"/test-framework
+ export CCP4_SCR="${T}"
+ ln -sf refmac "${S}"/refmac5
+ sed '/^ANISOU/d' -i ${CCP4_TEST}/data/pdb/1vr7.pdb
+ ccp4-run-thorough-tests -v test_refmac5 || die
+}
+
+src_install() {
+ exeinto /usr/libexec/ccp4/bin/
+ doexe ${PN} libcheck || die
+ dosym ../libexec/ccp4/bin/${PN} /usr/bin/${PN}
+ dosym ../libexec/ccp4/bin/libcheck /usr/bin/libcheck
+ dosym refmac /usr/bin/refmac5 || die
+ dodoc refmac_keywords.pdf bugs_and_features.pdf || die
+}