summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-10-01 17:33:55 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-10-01 17:33:55 +0000
commit8b3341a8b9821b3bc2c80ba74337a5c6547e4ab7 (patch)
treea455093e869301787e30710ffe5247ccb318f4b4 /sci-electronics/gerbv/gerbv-0.16-r1.ebuild
parentMarked Stable on amd64. (diff)
downloadgentoo-2-8b3341a8b9821b3bc2c80ba74337a5c6547e4ab7.tar.gz
gentoo-2-8b3341a8b9821b3bc2c80ba74337a5c6547e4ab7.tar.bz2
gentoo-2-8b3341a8b9821b3bc2c80ba74337a5c6547e4ab7.zip
Removing deprecated "gtk2" USE flag (bug #106560).
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-electronics/gerbv/gerbv-0.16-r1.ebuild')
-rw-r--r--sci-electronics/gerbv/gerbv-0.16-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-electronics/gerbv/gerbv-0.16-r1.ebuild b/sci-electronics/gerbv/gerbv-0.16-r1.ebuild
new file mode 100644
index 000000000000..aa48008e632e
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-0.16-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-0.16-r1.ebuild,v 1.1 2005/10/01 17:33:55 ribosome Exp $
+
+DESCRIPTION="gerbv - The gEDA Gerber Viewer"
+SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
+HOMEPAGE="http://www.geda.seul.org"
+
+IUSE="doc png"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ =x11-libs/gtk+-2*
+ png? ( media-libs/libpng
+ media-libs/gdk-pixbuf )
+ virtual/x11"
+
+src_compile() {
+ local confOptions
+ confOptions='--enable-gtk2'
+ use png || confOptions="$confOptions --disable-exportpng"
+
+ econf $confOptions || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ if use doc; then
+ cd doc
+ dodoc sources.txt
+ use png && dodoc PNG-print/PNGPrintMiniHowto.txt
+ docinto eagle
+ dodoc eagle/eagle2exc*
+ fi
+}