summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-11-30 22:45:08 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-11-30 22:45:08 +0000
commit3c54a63a6afa95621f156a5cd7f3faac960fcdae (patch)
treec34528c6f274dc69ca6999eecd247b2e5ac61029 /sci-electronics/gerbv
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-3c54a63a6afa95621f156a5cd7f3faac960fcdae.tar.gz
gentoo-2-3c54a63a6afa95621f156a5cd7f3faac960fcdae.tar.bz2
gentoo-2-3c54a63a6afa95621f156a5cd7f3faac960fcdae.zip
Version bump, bug #245962.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 i686)
Diffstat (limited to 'sci-electronics/gerbv')
-rw-r--r--sci-electronics/gerbv/ChangeLog7
-rw-r--r--sci-electronics/gerbv/gerbv-2.1.0.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-electronics/gerbv/ChangeLog b/sci-electronics/gerbv/ChangeLog
index 07267cb6430f..fdee37ef7611 100644
--- a/sci-electronics/gerbv/ChangeLog
+++ b/sci-electronics/gerbv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/gerbv
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.25 2008/08/06 15:42:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.26 2008/11/30 22:45:08 calchan Exp $
+
+*gerbv-2.1.0 (30 Nov 2008)
+
+ 30 Nov 2008; Denis Dupeyron <calchan@gentoo.org> +gerbv-2.1.0.ebuild:
+ Version bump, bug #245962.
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-electronics/gerbv/gerbv-2.1.0.ebuild b/sci-electronics/gerbv/gerbv-2.1.0.ebuild
new file mode 100644
index 000000000000..9d23fd826e45
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-2.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-2.1.0.ebuild,v 1.1 2008/11/30 22:45:08 calchan Exp $
+
+inherit fdo-mime
+
+DESCRIPTION="A free Gerber viewer"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gerbv.sourceforge.net/"
+
+IUSE="cairo doc examples png unit-mm"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="=x11-libs/gtk+-2*
+ cairo? ( x11-libs/cairo )
+ png? ( media-libs/libpng )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's/Education/Application/' "${S}"/desktop/gerbv.desktop || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-update-desktop-database \
+ $(use_enable cairo ) \
+ $(use_enable png exportpng ) \
+ $(use_enable unit-mm ) \
+ --with-maxfiles=50 \
+ || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog CONTRIBUTORS HACKING NEWS README* TODO
+
+ if use doc
+ then
+ find doc -name "Makefile*" -exec rm -f '{}' \;
+ find doc -name "*.txt" -exec ecompress '{}' \;
+ insinto /usr/share/doc/${PF}
+ doins -r doc/*
+ fi
+
+ if use examples
+ then
+ find example -name "Makefile*" -exec rm -f '{}' \;
+ find example -name "*.txt" -exec ecompress '{}' \;
+ insinto /usr/share/doc/${PF}/examples
+ doins -r example/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}