summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-19 09:02:50 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-19 09:02:50 +0000
commit7de9f3e49606a04051e7c6047a994f60d37eebc1 (patch)
tree7ae1edee5cadd98e1d38b5f79fb393dd6c19a348 /sci-electronics/kicad
parentAdded ~ppc64; bug #178310 (diff)
downloadgentoo-2-7de9f3e49606a04051e7c6047a994f60d37eebc1.tar.gz
gentoo-2-7de9f3e49606a04051e7c6047a994f60d37eebc1.tar.bz2
gentoo-2-7de9f3e49606a04051e7c6047a994f60d37eebc1.zip
Fix wxwidgets.eclass usage to work with upcoming changes.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sci-electronics/kicad')
-rw-r--r--sci-electronics/kicad/ChangeLog6
-rw-r--r--sci-electronics/kicad/kicad-20060828.ebuild12
-rw-r--r--sci-electronics/kicad/kicad-20070115.ebuild10
3 files changed, 16 insertions, 12 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index 9544d03d461e..6f8350a1d891 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/kicad
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.16 2007/04/12 13:11:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.17 2007/05/19 09:02:50 dirtyepic Exp $
+
+ 19 May 2007; Ryan Hill <dirtyepic@gentoo.org> kicad-20060828.ebuild,
+ kicad-20070115.ebuild:
+ Fix wxwidgets.eclass usage to work with upcoming changes.
12 Apr 2007; Markus Rothe <corsair@gentoo.org> kicad-20070115.ebuild:
Added ~ppc64
diff --git a/sci-electronics/kicad/kicad-20060828.ebuild b/sci-electronics/kicad/kicad-20060828.ebuild
index b0f69dcb6af6..0cfcc994e70d 100644
--- a/sci-electronics/kicad/kicad-20060828.ebuild
+++ b/sci-electronics/kicad/kicad-20060828.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20060828.ebuild,v 1.1 2006/09/12 05:41:00 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20060828.ebuild,v 1.2 2007/05/19 09:02:50 dirtyepic Exp $
inherit wxwidgets
@@ -15,12 +15,12 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="unicode doc examples minimal"
-DEPEND=">=x11-libs/wxGTK-2.6
+DEPEND="=x11-libs/wxGTK-2.6*
media-gfx/wings"
pkg_setup() {
- # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
- WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
+ # Tell wxwidgets.eclass the version we need.
+ WX_GTK_VER="2.6"
# Check for proper wxGTK USE flags.
if use unicode; then
@@ -28,7 +28,7 @@ pkg_setup() {
else
need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
fi
- built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
+ built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
}
src_unpack() {
diff --git a/sci-electronics/kicad/kicad-20070115.ebuild b/sci-electronics/kicad/kicad-20070115.ebuild
index 559c5b5501d2..fdc56fd09f1e 100644
--- a/sci-electronics/kicad/kicad-20070115.ebuild
+++ b/sci-electronics/kicad/kicad-20070115.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070115.ebuild,v 1.3 2007/04/12 13:11:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070115.ebuild,v 1.4 2007/05/19 09:02:50 dirtyepic Exp $
inherit wxwidgets
@@ -15,12 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc64 x86"
IUSE="unicode doc examples minimal"
-DEPEND=">=x11-libs/wxGTK-2.6
+DEPEND="=x11-libs/wxGTK-2.6*
media-gfx/wings"
pkg_setup() {
- # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
- WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
+ # Tell wxwidgets.eclass the version we need.
+ WX_GTK_VER="2.6"
# Check for proper wxGTK USE flags.
if use unicode; then
@@ -28,7 +28,7 @@ pkg_setup() {
else
need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
fi
- built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
+ built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
}
src_unpack() {