summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2011-09-23 14:53:47 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2011-09-23 14:53:47 +0000
commit3aeeaad7dbccfae283653f77bb04281651c50e49 (patch)
treec74893405d6dda772c2ceb481910876a45f7b7a8 /sci-electronics/linsmith
parentTry to enable tests again. (diff)
downloadgentoo-2-3aeeaad7dbccfae283653f77bb04281651c50e49.tar.gz
gentoo-2-3aeeaad7dbccfae283653f77bb04281651c50e49.tar.bz2
gentoo-2-3aeeaad7dbccfae283653f77bb04281651c50e49.zip
Version bump
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/linsmith')
-rw-r--r--sci-electronics/linsmith/ChangeLog7
-rw-r--r--sci-electronics/linsmith/linsmith-0.99.22.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sci-electronics/linsmith/ChangeLog b/sci-electronics/linsmith/ChangeLog
index 3f516976f78e..ffeb021a69cc 100644
--- a/sci-electronics/linsmith/ChangeLog
+++ b/sci-electronics/linsmith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/linsmith
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.5 2011/08/07 03:14:50 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.6 2011/09/23 14:53:47 tomjbe Exp $
+
+*linsmith-0.99.22 (23 Sep 2011)
+
+ 23 Sep 2011; Thomas Beierlein <tomjbe@gentoo.org> +linsmith-0.99.22.ebuild:
+ Version bump
07 Aug 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> linsmith-0.99.21.ebuild:
x86 stable wrt bug #376929
diff --git a/sci-electronics/linsmith/linsmith-0.99.22.ebuild b/sci-electronics/linsmith/linsmith-0.99.22.ebuild
new file mode 100644
index 000000000000..3e940416b615
--- /dev/null
+++ b/sci-electronics/linsmith/linsmith-0.99.22.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/linsmith-0.99.22.ebuild,v 1.1 2011/09/23 14:53:47 tomjbe Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Smith charting program, mainly designed for educational use."
+HOMEPAGE="http://www.jcoppens.com/soft/linsmith/index.en.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # This patch is to prevent make install copying
+ # the examples in /usr/share/linsmith
+ # Now they are cp to the correct location.
+ epatch \
+ "${FILESDIR}"/${PN}-datafiles.patch
+
+ # fix QA warnings about 'maintainer mode'
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto "/usr/share/${PN}"
+ doins datafiles/conv0809 || die
+
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO || die
+ doman doc/linsmith.1 || die
+
+ domenu linsmith.desktop || die
+ doicon linsmith_icon.xpm || die
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins doc/manual.pdf || die
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins datafiles/*.circ datafiles/*.load || die
+ fi
+}