summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-04-23 14:14:56 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-04-23 14:14:56 +0000
commit34cf813dfeed75b325b110471869085ae0cce937 (patch)
tree7a37093278fdceef35df87308404eaf7016a4e29 /sci-electronics/qucs
parentInitial import (diff)
downloadgentoo-2-34cf813dfeed75b325b110471869085ae0cce937.tar.gz
gentoo-2-34cf813dfeed75b325b110471869085ae0cce937.tar.bz2
gentoo-2-34cf813dfeed75b325b110471869085ae0cce937.zip
Version bump.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-electronics/qucs')
-rw-r--r--sci-electronics/qucs/ChangeLog7
-rw-r--r--sci-electronics/qucs/qucs-0.0.14.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/sci-electronics/qucs/ChangeLog b/sci-electronics/qucs/ChangeLog
index 1e33d9434935..19a5eee98453 100644
--- a/sci-electronics/qucs/ChangeLog
+++ b/sci-electronics/qucs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/qucs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/qucs/ChangeLog,v 1.17 2008/01/01 18:38:01 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/qucs/ChangeLog,v 1.18 2008/04/23 14:14:56 calchan Exp $
+
+*qucs-0.0.14 (23 Apr 2008)
+
+ 23 Apr 2008; Denis Dupeyron <calchan@gentoo.org> +qucs-0.0.14.ebuild:
+ Version bump.
01 Jan 2008; Carsten Lohrke <carlo@gentoo.org> qucs-0.0.12.ebuild,
qucs-0.0.13.ebuild:
diff --git a/sci-electronics/qucs/qucs-0.0.14.ebuild b/sci-electronics/qucs/qucs-0.0.14.ebuild
new file mode 100644
index 000000000000..c167b08d4e20
--- /dev/null
+++ b/sci-electronics/qucs/qucs-0.0.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/qucs/qucs-0.0.14.ebuild,v 1.1 2008/04/23 14:14:56 calchan Exp $
+
+EAPI=1
+
+inherit eutils
+
+DESCRIPTION="Quite Universal Circuit Simulator is a Qt based circuit simulator"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://qucs.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt:3"
+RDEPEND="x11-libs/qt:3"
+
+src_compile() {
+ myconf="--with-x $(use_enable debug)"
+
+ econf ${myconf} || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed."
+
+ doicon qucs/bitmaps/big.qucs.xpm
+ make_desktop_entry qucs Qucs qucs "Qt;Science;Electronics"
+}