summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2011-05-24 15:45:11 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2011-05-24 15:45:11 +0000
commit5a539d6524ed1a1deff3a776f7382e6e773dc4a2 (patch)
treed1c1e7ebf6ca221634a0d5f3accb4a65b6a7c29d /sci-electronics/splat
parentStable for HPPA (bug #368495). (diff)
downloadgentoo-2-5a539d6524ed1a1deff3a776f7382e6e773dc4a2.tar.gz
gentoo-2-5a539d6524ed1a1deff3a776f7382e6e773dc4a2.tar.bz2
gentoo-2-5a539d6524ed1a1deff3a776f7382e6e773dc4a2.zip
version bump
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/splat')
-rw-r--r--sci-electronics/splat/ChangeLog7
-rw-r--r--sci-electronics/splat/splat-1.4.0.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/sci-electronics/splat/ChangeLog b/sci-electronics/splat/ChangeLog
index 7de6a0dbf328..c2337f22c68f 100644
--- a/sci-electronics/splat/ChangeLog
+++ b/sci-electronics/splat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/splat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/splat/ChangeLog,v 1.12 2011/01/27 16:23:12 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/splat/ChangeLog,v 1.13 2011/05/24 15:45:11 tomjbe Exp $
+
+*splat-1.4.0 (24 May 2011)
+
+ 24 May 2011; Thomas Beierlein <tomjbe@gentoo.org> +splat-1.4.0.ebuild:
+ Version bump
*splat-1.3.0 (27 Jan 2011)
diff --git a/sci-electronics/splat/splat-1.4.0.ebuild b/sci-electronics/splat/splat-1.4.0.ebuild
new file mode 100644
index 000000000000..9ee93a7244cf
--- /dev/null
+++ b/sci-electronics/splat/splat-1.4.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/splat/splat-1.4.0.ebuild,v 1.1 2011/05/24 15:45:11 tomjbe Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="RF Signal Propagation, Loss, And Terrain analysis tool for the spectrum between 20 MHz and 20 GHz."
+HOMEPAGE="http://www.qsl.net/kd2bd/splat.html"
+SRC_URI="http://www.qsl.net/kd2bd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc linguas_es"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.2.2-gcc43.patch"
+}
+
+src_compile() {
+ # fake resulting file from interactive configuration script
+ # using default resolution
+ cat <<- EOF > "${S}/splat.h"
+ /* Parameters for 3 arc-second standard resolution mode of operation */
+ #define MAXPAGES 9
+ #define HD_MODE 0
+ EOF
+
+ local CC=$(tc-getCC) CXX=$(tc-getCXX)
+
+ ${CXX} -Wall ${CXXFLAGS} ${LDFLAGS} itwom3.0.cpp splat.cpp -o rfsplat -lm -lbz2 || die
+
+ cd utils
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} citydecoder.c -o citydecoder
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} usgs2sdf.c -o usgs2sdf
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} srtm2sdf.c -o srtm2sdf -lbz2
+ #${CC} -Wall ${CFLAGS} ${LDFLAGS} fontdata.c -o fontdata -lz
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} bearing.c -o bearing -lm
+}
+
+src_install() {
+ local SPLAT_LANG="english"
+ use linguas_es && SPLAT_LANG="spanish"
+ # splat binary
+ dobin rfsplat || die
+
+ # utilities
+ dobin utils/{citydecoder,usgs2sdf,srtm2sdf,postdownload,bearing} || die
+ newman docs/${SPLAT_LANG}/man/splat.man rfsplat.1 || die
+
+ dodoc CHANGES README utils/fips.txt || die
+ newdoc utils/README README.UTILS || die
+
+ if use doc; then
+ dodoc docs/${SPLAT_LANG}/{pdf/splat.pdf,postscript/splat.ps} || die
+ fi
+ #sample data
+ docinto sample_data
+ dodoc sample_data/* || die
+}
+
+pkg_postinst() {
+ elog "The original SPLAT! command got renamed to 'rfsplat' to avoid"
+ elog "filename collission with app-portage/splat."
+ elog ""
+ elog "Be aware that it is still referenced as 'splat' in the documentation."
+}