summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2013-09-15 14:40:07 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2013-09-15 14:40:07 +0000
commit22e834ddef9257467ec208646fe9728fea3d34a4 (patch)
treebf76ea744e50fa9c771cb95b93d04c5791be287c /sci-electronics/systemc
parentFix busted selinux patch, need to subst SELINUX_STATIC_LIBS (diff)
downloadgentoo-2-22e834ddef9257467ec208646fe9728fea3d34a4.tar.gz
gentoo-2-22e834ddef9257467ec208646fe9728fea3d34a4.tar.bz2
gentoo-2-22e834ddef9257467ec208646fe9728fea3d34a4.zip
Version bump (bug #481732). Thanks alexrenzi for reporting
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'sci-electronics/systemc')
-rw-r--r--sci-electronics/systemc/ChangeLog10
-rw-r--r--sci-electronics/systemc/files/systemc-2.3.0-config.patch21
-rw-r--r--sci-electronics/systemc/systemc-2.3.0.ebuild76
3 files changed, 105 insertions, 2 deletions
diff --git a/sci-electronics/systemc/ChangeLog b/sci-electronics/systemc/ChangeLog
index b3f4980c75f7..98286afcd600 100644
--- a/sci-electronics/systemc/ChangeLog
+++ b/sci-electronics/systemc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/systemc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.15 2012/04/26 15:40:20 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.16 2013/09/15 14:40:07 tomjbe Exp $
+
+*systemc-2.3.0 (15 Sep 2013)
+
+ 15 Sep 2013; Thomas Beierlein <tomjbe@gentoo.org> +systemc-2.3.0.ebuild,
+ +files/systemc-2.3.0-config.patch:
+ Version bump (bug #481732). Thanks alexrenzi for reporting
*systemc-2.2.0-r2 (26 Apr 2012)
diff --git a/sci-electronics/systemc/files/systemc-2.3.0-config.patch b/sci-electronics/systemc/files/systemc-2.3.0-config.patch
new file mode 100644
index 000000000000..581e625c6113
--- /dev/null
+++ b/sci-electronics/systemc/files/systemc-2.3.0-config.patch
@@ -0,0 +1,21 @@
+# drop compiler check to enable use of CXX
+--- configure.in.old 2013-09-15 09:38:54.000000000 +0200
++++ configure.in 2013-09-15 09:40:31.000000000 +0200
+@@ -134,15 +134,8 @@
+ AC_MSG_ERROR("sorry...architecture not supported")
+ ;;
+ esac
+- case "$CXX_COMP" in
+- c++ | g++)
+- EXTRA_CXXFLAGS="${EXTRA_CXXFLAGS} -m${CPU_ARCH}"
+- EXTRA_ASFLAGS="-m${CPU_ARCH}"
+- ;;
+- *)
+- AC_MSG_ERROR("sorry...compiler not supported")
+- ;;
+- esac
++ EXTRA_CXXFLAGS="${EXTRA_CXXFLAGS} -m${CPU_ARCH}"
++ EXTRA_ASFLAGS="-m${CPU_ARCH}"
+ ;;
+ *freebsd*)
+ case "$target_cpu" in
diff --git a/sci-electronics/systemc/systemc-2.3.0.ebuild b/sci-electronics/systemc/systemc-2.3.0.ebuild
new file mode 100644
index 000000000000..c4d1572f16bd
--- /dev/null
+++ b/sci-electronics/systemc/systemc-2.3.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/systemc-2.3.0.ebuild,v 1.1 2013/09/15 14:40:07 tomjbe Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs autotools-utils
+
+DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
+HOMEPAGE="http://www.systemc.org/"
+SRC_URI="${P}.tgz"
+
+SLOT="0"
+LICENSE="SOPLA-3.0"
+IUSE="doc static-libs"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="fetch test"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+pkg_nofetch() {
+ elog "${PN} developers require end-users to accept their license agreement"
+ elog "by registering on their Web site (${HOMEPAGE})."
+ elog "Please download ${A} manually and place it in ${DISTDIR}."
+}
+
+src_prepare() {
+ # drop compiler check to enable use of CXX
+ epatch "${FILESDIR}"/${P}-config.patch
+
+ sed -i -e "s:OPT_CXXFLAGS=\"-O3\":OPT_CXXFLAGS=\"\":g" configure.in || die "Patching configure.in failed"
+
+ sed -i -e "s:lib-\$(TARGET_ARCH):$(get_libdir):g" $(find . -name Makefile.am) || die "Patching Makefile.am failed"
+
+ # respect DESTDIR
+ sed -i -e "s:\$(prefix):\$(DESTDIR)\$(prefix):g" $(find . -name Makefile.am) || die "Patching Makefile.am failed"
+
+ eautoreconf
+
+ sed -i -e "s:\$(DESTDIR)\$(libdir):\$(libdir):g" src/sysc/Makefile.in || die
+
+ for sfile in src/sysc/qt/md/*.s ; do
+ sed -i -e '$a \
+#if defined(__linux__) && defined(__ELF__) \
+.section .note.GNU-stack,"",%progbits \
+#endif' "${sfile}" || die "Patching ${sfile} failed"
+ done
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) CXX=$(tc-getCXX)
+}
+
+src_compile() {
+ cd src
+ default
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog INSTALL NEWS README RELEASENOTES
+ rm docs/License.pdf || die
+ use doc && dodoc -r docs/*
+ cd src
+ autotools-utils_src_install
+}
+
+pkg_postinst() {
+ elog "If you want to run the examples, you need to :"
+ elog " tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
+ elog " cd ${P}"
+ elog " find examples -name 'Makefile.*' -exec sed -i -e 's/-lm/-lm -lpthread/' '{}' \;"
+ elog " ./configure"
+ elog " cd examples"
+ elog " make check"
+}