summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-13 13:14:45 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-13 13:14:45 +0000
commitbe0cc0b61b45ac8fe87722750b1f75c659603119 (patch)
tree82c91e3151a78316009c0ac795b015b3279b9a63 /sci-electronics/xcircuit
parentVersion bump (thanks euscan) (diff)
downloadgentoo-2-be0cc0b61b45ac8fe87722750b1f75c659603119.tar.gz
gentoo-2-be0cc0b61b45ac8fe87722750b1f75c659603119.tar.bz2
gentoo-2-be0cc0b61b45ac8fe87722750b1f75c659603119.zip
Version bump (thanks euscan), force automake-1.11
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/xcircuit')
-rw-r--r--sci-electronics/xcircuit/ChangeLog7
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.8.24.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/sci-electronics/xcircuit/ChangeLog b/sci-electronics/xcircuit/ChangeLog
index aa0ef79af2c8..4f03a31b5fbb 100644
--- a/sci-electronics/xcircuit/ChangeLog
+++ b/sci-electronics/xcircuit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/xcircuit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.51 2012/06/13 13:10:02 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.52 2012/06/13 13:14:45 xmw Exp $
+
+*xcircuit-3.8.24 (13 Jun 2012)
+
+ 13 Jun 2012; Michael Weber <xmw@gentoo.org> +xcircuit-3.8.24.ebuild:
+ Version bump (thanks euscan), force automake-1.11
*xcircuit-3.7.40 (13 Jun 2012)
diff --git a/sci-electronics/xcircuit/xcircuit-3.8.24.ebuild b/sci-electronics/xcircuit/xcircuit-3.8.24.ebuild
new file mode 100644
index 000000000000..33c6dd36434b
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.8.24.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.8.24.ebuild,v 1.1 2012/06/13 13:14:45 xmw Exp $
+
+EAPI=2
+WANT_AUTOMAKE="1.11"
+inherit autotools eutils multilib
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libSM
+ x11-libs/libICE
+ sys-libs/zlib
+ app-text/ghostscript-gpl
+ dev-lang/tcl
+ dev-lang/tk"
+RDEPEND=${DEPEND}
+
+RESTRICT="test" #131024
+
+src_prepare() {
+ eautoreconf # avoid QA-warning wrt automaintainer mode
+}
+
+src_configure() {
+ export loader_run_path="/usr/$(get_libdir)"
+ econf \
+ --disable-dependency-tracking \
+ --with-tcl \
+ --with-ngspice
+}
+
+src_compile() {
+ emake appdefaultsdir="/usr/share/X11/app-defaults" || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" appdefaultsdir="/usr/share/X11/app-defaults" \
+ appmandir="/usr/share/man/man1" install || die
+ dodoc CHANGES README* TODO
+}