summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-10 06:36:15 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-10 06:36:15 +0000
commitd70995479046fc5d79092b4b46cb2c09b61736eb (patch)
tree4036b7794a4ff169f763bc16a65c64cafbef5386 /sci-electronics/xcircuit
parentversion bump (bug #472726) (diff)
downloadgentoo-2-d70995479046fc5d79092b4b46cb2c09b61736eb.tar.gz
gentoo-2-d70995479046fc5d79092b4b46cb2c09b61736eb.tar.bz2
gentoo-2-d70995479046fc5d79092b4b46cb2c09b61736eb.zip
Version bumps
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sci-electronics/xcircuit')
-rw-r--r--sci-electronics/xcircuit/ChangeLog9
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.7.50.ebuild (renamed from sci-electronics/xcircuit/xcircuit-3.8.38.ebuild)2
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.8.40.ebuild63
3 files changed, 72 insertions, 2 deletions
diff --git a/sci-electronics/xcircuit/ChangeLog b/sci-electronics/xcircuit/ChangeLog
index 342792bd949a..6d9736063f09 100644
--- a/sci-electronics/xcircuit/ChangeLog
+++ b/sci-electronics/xcircuit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-electronics/xcircuit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.64 2013/05/24 06:23:57 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.65 2013/06/10 06:36:15 xmw Exp $
+
+*xcircuit-3.7.50 (10 Jun 2013)
+*xcircuit-3.8.40 (10 Jun 2013)
+
+ 10 Jun 2013; Michael Weber <xmw@gentoo.org> +xcircuit-3.7.50.ebuild,
+ +xcircuit-3.8.40.ebuild, -xcircuit-3.8.38.ebuild:
+ Version bumps
*xcircuit-3.7.49 (24 May 2013)
*xcircuit-3.8.39 (24 May 2013)
diff --git a/sci-electronics/xcircuit/xcircuit-3.8.38.ebuild b/sci-electronics/xcircuit/xcircuit-3.7.50.ebuild
index b94654e06ccc..85c2937a7772 100644
--- a/sci-electronics/xcircuit/xcircuit-3.8.38.ebuild
+++ b/sci-electronics/xcircuit/xcircuit-3.7.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.8.38.ebuild,v 1.1 2013/05/06 17:02:28 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.7.50.ebuild,v 1.1 2013/06/10 06:36:15 xmw Exp $
EAPI=4
diff --git a/sci-electronics/xcircuit/xcircuit-3.8.40.ebuild b/sci-electronics/xcircuit/xcircuit-3.8.40.ebuild
new file mode 100644
index 000000000000..5a1d5504fbef
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.8.40.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.8.40.ebuild,v 1.1 2013/06/10 06:36:15 xmw Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ app-text/ghostscript-gpl
+ dev-lang/tk
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libSM
+ x11-libs/libICE"
+RDEPEND=${DEPEND}
+
+RESTRICT="test" #131024
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # automake-1.12
+ sed \
+ -e '/AM_C_PROTOTYPES/d' \
+ -i configure.in || die
+ # automake-1.13
+ mv configure.{in,ac} || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ export loader_run_path="/usr/$(get_libdir)"
+ local myeconfargs=(
+ --disable-dependency-tracking
+ --with-tcl
+ --with-ngspice
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile appdefaultsdir="/usr/share/X11/app-defaults"
+}
+
+src_install () {
+ autotools-utils_src_install \
+ appdefaultsdir="/usr/share/X11/app-defaults" \
+ appmandir="/usr/share/man/man1"
+}