summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2014-12-14 10:28:35 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2014-12-14 10:28:35 +0000
commitf58e07ed0e10857be98b65aa741b73252f2a6c0f (patch)
tree7047674fa081bc81c537eb1f47d805711d2abb61 /sci-electronics/xcircuit
parentBump agda to 2.4.2.2-r1 (diff)
downloadgentoo-2-f58e07ed0e10857be98b65aa741b73252f2a6c0f.tar.gz
gentoo-2-f58e07ed0e10857be98b65aa741b73252f2a6c0f.tar.bz2
gentoo-2-f58e07ed0e10857be98b65aa741b73252f2a6c0f.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'sci-electronics/xcircuit')
-rw-r--r--sci-electronics/xcircuit/ChangeLog7
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.8.77.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/sci-electronics/xcircuit/ChangeLog b/sci-electronics/xcircuit/ChangeLog
index f0ac15b70187..5e458b79bd73 100644
--- a/sci-electronics/xcircuit/ChangeLog
+++ b/sci-electronics/xcircuit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/xcircuit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.66 2014/08/10 20:28:53 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.67 2014/12/14 10:28:35 tomjbe Exp $
+
+*xcircuit-3.8.77 (14 Dec 2014)
+
+ 14 Dec 2014; Thomas Beierlein <tomjbe@gentoo.org> +xcircuit-3.8.77.ebuild:
+ Version bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> xcircuit-3.4.30.ebuild,
xcircuit-3.6.165.ebuild, xcircuit-3.7.48.ebuild, xcircuit-3.7.49.ebuild,
diff --git a/sci-electronics/xcircuit/xcircuit-3.8.77.ebuild b/sci-electronics/xcircuit/xcircuit-3.8.77.ebuild
new file mode 100644
index 000000000000..9c592569a31a
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.8.77.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.8.77.ebuild,v 1.1 2014/12/14 10:28:35 tomjbe Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Circuit drawing and schematic capture program"
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ app-text/ghostscript-gpl
+ dev-lang/tk
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libSM
+ x11-libs/libICE"
+RDEPEND=${DEPEND}
+
+RESTRICT="test" #131024
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # automake-1.12
+ sed \
+ -e '/AM_C_PROTOTYPES/d' \
+ -i configure.in || die
+ # automake-1.13
+ mv configure.{in,ac} || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ export loader_run_path="/usr/$(get_libdir)"
+ local myeconfargs=(
+ --disable-dependency-tracking
+ --with-tcl
+ --with-ngspice
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile appdefaultsdir="/usr/share/X11/app-defaults"
+}
+
+src_install () {
+ autotools-utils_src_install \
+ appdefaultsdir="/usr/share/X11/app-defaults" \
+ appmandir="/usr/share/man/man1"
+}