summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-26 15:40:20 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-26 15:40:20 +0000
commit6b6aa27bf86461218fe9a095cf4aa6b5dd7b7db6 (patch)
tree697df74cae10764aff07f0f130357af7f3fff44a /sci-electronics
parentsci-libs/beagle: Move to EAPI=4, handle static-libs, use autotools-utils.eclass (diff)
downloadgentoo-2-6b6aa27bf86461218fe9a095cf4aa6b5dd7b7db6.tar.gz
gentoo-2-6b6aa27bf86461218fe9a095cf4aa6b5dd7b7db6.tar.bz2
gentoo-2-6b6aa27bf86461218fe9a095cf4aa6b5dd7b7db6.zip
sci-electronics/systemc: Drop old, move to EAPI=4
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/systemc/ChangeLog10
-rw-r--r--sci-electronics/systemc/metadata.xml4
-rw-r--r--sci-electronics/systemc/systemc-2.2.0-r2.ebuild (renamed from sci-electronics/systemc/systemc-2.2.0-r1.ebuild)31
-rw-r--r--sci-electronics/systemc/systemc-2.2.0.ebuild54
4 files changed, 25 insertions, 74 deletions
diff --git a/sci-electronics/systemc/ChangeLog b/sci-electronics/systemc/ChangeLog
index f3ad2bae48be..b3f4980c75f7 100644
--- a/sci-electronics/systemc/ChangeLog
+++ b/sci-electronics/systemc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/systemc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.14 2009/07/11 17:59:04 calchan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.15 2012/04/26 15:40:20 jlec Exp $
+
+*systemc-2.2.0-r2 (26 Apr 2012)
+
+ 26 Apr 2012; Justin Lecher <jlec@gentoo.org> -systemc-2.2.0.ebuild,
+ -systemc-2.2.0-r1.ebuild, +systemc-2.2.0-r2.ebuild, metadata.xml:
+ Drop old, move to EAPI=4
*systemc-2.2.0-r1 (11 Jul 2009)
diff --git a/sci-electronics/systemc/metadata.xml b/sci-electronics/systemc/metadata.xml
index 103709ea59d9..b2e59d373fab 100644
--- a/sci-electronics/systemc/metadata.xml
+++ b/sci-electronics/systemc/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-electronics</herd>
- <longdescription>
+ <herd>sci-electronics</herd>
+ <longdescription>
SystemC provides hardware-oriented constructs within the context of C++
as a class library implemented in standard C++. Its use spans design and
verification from concept to implementation in hardware and software.
diff --git a/sci-electronics/systemc/systemc-2.2.0-r1.ebuild b/sci-electronics/systemc/systemc-2.2.0-r2.ebuild
index a969548ae13b..0049555e981c 100644
--- a/sci-electronics/systemc/systemc-2.2.0-r1.ebuild
+++ b/sci-electronics/systemc/systemc-2.2.0-r2.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/systemc-2.2.0-r1.ebuild,v 1.1 2009/07/11 17:59:04 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/systemc-2.2.0-r2.ebuild,v 1.1 2012/04/26 15:40:20 jlec Exp $
-inherit versionator multilib
+EAPI=4
+
+inherit versionator multilib toolchain-funcs
DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
-LICENSE="SOPLA-2.3"
HOMEPAGE="http://www.systemc.org/"
SRC_URI="${P}.tgz"
SLOT="0"
+LICENSE="SOPLA-2.3"
IUSE=""
KEYWORDS="~amd64 ~x86"
-RESTRICT="fetch test"
-DEPEND=""
-RDEPEND=""
+RESTRICT="fetch test"
pkg_nofetch() {
elog "${PN} developers require end-users to accept their license agreement"
@@ -23,10 +23,7 @@ pkg_nofetch() {
elog "Please download ${A} manually and place it in ${DISTDIR}."
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
sed -i -e "s:lib-\$(TARGET_ARCH):$(get_libdir):g" $(find . -name Makefile.in) || die "Patching Makefile.in failed"
sed -i -e "s:OPT_CXXFLAGS=\"-O3\":OPT_CXXFLAGS=\"${CXXFLAGS}\":g" configure || die "Patching configure failed"
@@ -43,18 +40,20 @@ src_unpack() {
done
}
+src_configure() {
+ econf --disable-dependency-tracking CXX=$(tc-getCXX)
+}
+
src_compile() {
- econf --disable-dependency-tracking CXX="g++" || die "Configuration failed"
cd src
- emake || die "Compilation failed"
+ default
}
src_install() {
dodoc AUTHORS ChangeLog INSTALL NEWS README RELEASENOTES
- insinto /usr/share/doc/${PF}/docs
- doins docs/*
+ doins -r docs
cd src
- einstall
+ default
}
pkg_postinst() {
diff --git a/sci-electronics/systemc/systemc-2.2.0.ebuild b/sci-electronics/systemc/systemc-2.2.0.ebuild
deleted file mode 100644
index eea0a10ef595..000000000000
--- a/sci-electronics/systemc/systemc-2.2.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/systemc-2.2.0.ebuild,v 1.1 2007/04/22 15:38:02 calchan Exp $
-
-inherit versionator multilib
-
-DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
-LICENSE="SOPLA-2.3"
-HOMEPAGE="http://www.systemc.org/"
-SRC_URI="${P}.tgz"
-
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-RESTRICT="fetch test"
-
-DEPEND=""
-
-pkg_nofetch() {
- elog "${PN} developers require end-users to accept their license agreement"
- elog "by registering on their Web site (${HOMEPAGE})."
- elog "Please download ${A} manually and place it in ${DISTDIR}."
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e "s:lib-\$(TARGET_ARCH):$(get_libdir):g" $(find . -name Makefile.in) || die "Patching failed"
- sed -i -e "s:OPT_CXXFLAGS=\"-O3\":OPT_CXXFLAGS=\"${CXXFLAGS}\":g" configure || die "Patching failed"
-}
-
-src_compile() {
- econf --disable-dependency-tracking CXX="g++" || die "Configuration failed"
- cd src
- emake || die "Compilation failed"
-}
-
-src_install() {
- dodoc AUTHORS ChangeLog INSTALL NEWS README RELEASENOTES
- insinto /usr/share/doc/${PF}/docs
- doins doc/*
- cd src
- einstall
-}
-
-pkg_postinst() {
- elog "If you want to run the examples, you need to :"
- elog " tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
- elog " cd ${P}"
- elog " find examples -name 'Makefile.*' -exec sed -i -e 's/-lm/-lm -lpthread/' '{}' \;"
- elog " ./configure"
- elog " cd examples"
- elog " make check"
-}