summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-07 22:46:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-07 22:46:28 +0000
commit9a0b70398a3159d04139597d4eeaf784a70049cb (patch)
tree55e84049d6696189734a440d0107560259ea86ad /sci-electronics
parentMigration to EAPI 2 (diff)
downloadgentoo-2-9a0b70398a3159d04139597d4eeaf784a70049cb.tar.gz
gentoo-2-9a0b70398a3159d04139597d4eeaf784a70049cb.tar.bz2
gentoo-2-9a0b70398a3159d04139597d4eeaf784a70049cb.zip
Bump to 0.69.0, fixes #233785
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/oregano/ChangeLog9
-rw-r--r--sci-electronics/oregano/oregano-0.69.0.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/sci-electronics/oregano/ChangeLog b/sci-electronics/oregano/ChangeLog
index e6eb0400da7f..b07eac003471 100644
--- a/sci-electronics/oregano/ChangeLog
+++ b/sci-electronics/oregano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/oregano
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/oregano/ChangeLog,v 1.30 2008/10/26 23:55:22 jer Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/oregano/ChangeLog,v 1.31 2009/03/07 22:46:28 patrick Exp $
+
+*oregano-0.69.0 (07 Mar 2009)
+
+ 07 Mar 2009; Patrick Lauer <patrick@gentoo.org> +oregano-0.69.0.ebuild:
+ Bump to 0.69.0, fixes #233785
26 Oct 2008; Jeroen Roovers <jer@gentoo.org> oregano-0.60.0.ebuild:
Marked ~hppa too.
diff --git a/sci-electronics/oregano/oregano-0.69.0.ebuild b/sci-electronics/oregano/oregano-0.69.0.ebuild
new file mode 100644
index 000000000000..c4ae2d7d3617
--- /dev/null
+++ b/sci-electronics/oregano/oregano-0.69.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/oregano/oregano-0.69.0.ebuild,v 1.1 2009/03/07 22:46:28 patrick Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="Oregano is an application for schematic capture and simulation of electrical circuits."
+SRC_URI="http://gforge.lug.fi.uba.ar/frs/download.php/86/${P}.tar.gz"
+HOMEPAGE="http://oregano.gforge.lug.fi.uba.ar/"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.6
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2.5
+ >=gnome-base/libgnome-2.12
+ >=gnome-base/libgnomeui-2.12
+ >=gnome-base/libgnomecanvas-2.12
+ >=gnome-base/libgnomeprint-2.12
+ >=x11-libs/cairo-1.2
+ =x11-libs/gtksourceview-1*"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.96.1
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.60.0-dont-run-update-mime-database.patch
+}
+
+src_compile() {
+ scons --cache-disable \
+ PREFIX=/usr \
+ || die "scons make failed"
+}
+
+src_install() {
+ scons --cache-disable DESTDIR="${D}" PREFIX=/usr install \
+ || die "scons install failed"
+ dodoc AUTHORS INSTALL NEWS README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ elog "You'll need to emerge your prefered simulation backend"
+ elog "such as spice, ng-spice-rework or gnucap for simulation"
+ elog "to work."
+}