summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-07-25 02:04:45 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-07-25 02:04:45 +0000
commit6e6a4bc0850a3ac8f8742e95c6e8cbf370cff16b (patch)
tree607730b1a8a6e94ae38719c035a3e9a9e3d588b9 /sci-geosciences/gmapcatcher
parentFix LICENSE wrt bug 425914. (diff)
downloadgentoo-2-6e6a4bc0850a3ac8f8742e95c6e8cbf370cff16b.tar.gz
gentoo-2-6e6a4bc0850a3ac8f8742e95c6e8cbf370cff16b.tar.bz2
gentoo-2-6e6a4bc0850a3ac8f8742e95c6e8cbf370cff16b.zip
Initial version. Ebuild and future maintenance by Denis M. (Phr33d0m) <god@politeia.in>. On behalf of proxy-maint. Fixes bug #311705.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'sci-geosciences/gmapcatcher')
-rw-r--r--sci-geosciences/gmapcatcher/ChangeLog11
-rw-r--r--sci-geosciences/gmapcatcher/files/gmapcatcher-0.8.0.4-setuppy-docs.patch14
-rw-r--r--sci-geosciences/gmapcatcher/gmapcatcher-0.8.0.4.ebuild32
-rw-r--r--sci-geosciences/gmapcatcher/metadata.xml16
4 files changed, 73 insertions, 0 deletions
diff --git a/sci-geosciences/gmapcatcher/ChangeLog b/sci-geosciences/gmapcatcher/ChangeLog
new file mode 100644
index 000000000000..5919f18325a7
--- /dev/null
+++ b/sci-geosciences/gmapcatcher/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-geosciences/gmapcatcher
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmapcatcher/ChangeLog,v 1.1 2013/07/25 02:04:45 mrueg Exp $
+
+*gmapcatcher-0.8.0.4 (25 Jul 2013)
+
+ 25 Jul 2013; Manuel Rüger <mrueg@gentoo.org>
+ +files/gmapcatcher-0.8.0.4-setuppy-docs.patch, +gmapcatcher-0.8.0.4.ebuild,
+ +metadata.xml:
+ Initial version. Ebuild and future maintenance by Denis M. (Phr33d0m)
+ <god@politeia.in>. On behalf of proxy-maint. Fixes bug #311705.
diff --git a/sci-geosciences/gmapcatcher/files/gmapcatcher-0.8.0.4-setuppy-docs.patch b/sci-geosciences/gmapcatcher/files/gmapcatcher-0.8.0.4-setuppy-docs.patch
new file mode 100644
index 000000000000..35efed02a322
--- /dev/null
+++ b/sci-geosciences/gmapcatcher/files/gmapcatcher-0.8.0.4-setuppy-docs.patch
@@ -0,0 +1,14 @@
+Drop docs from setup.py, distutils-r1 takes care of it.
+
+--- setup.py.orig 2013-07-25 03:24:35.987668173 +0200
++++ setup.py 2013-07-25 03:24:51.770668448 +0200
+@@ -13,8 +13,7 @@
+ description = 'Offline Map Viewer',
+ version = VERSION,
+ url = WEB_ADDRESS,
+- data_files = [('share/doc/mapcatcher', ['README', 'changelog']),
+- ('share/applications', ['gmapcatcher.desktop']),
++ data_files = [('share/applications', ['gmapcatcher.desktop']),
+ ('share/man/man1',
+ ['man/mapcatcher.1.gz', 'man/mapdownloader.1.gz']),
+ ('share/pixmaps', ['images/mapcatcher.png']),
diff --git a/sci-geosciences/gmapcatcher/gmapcatcher-0.8.0.4.ebuild b/sci-geosciences/gmapcatcher/gmapcatcher-0.8.0.4.ebuild
new file mode 100644
index 000000000000..eb1c52a6bf0f
--- /dev/null
+++ b/sci-geosciences/gmapcatcher/gmapcatcher-0.8.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmapcatcher/gmapcatcher-0.8.0.4.ebuild,v 1.1 2013/07/25 02:04:45 mrueg Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit distutils-r1
+
+DESCRIPTION="An offline viewer for different map providers"
+HOMEPAGE="http://code.google.com/p/gmapcatcher/"
+SRC_URI="http://gmapcatcher.googlecode.com/files/mapcatcher_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/imaging[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/mapcatcher-${PV}
+PATCHES=("${FILESDIR}"/${P}-setuppy-docs.patch)
+
+src_prepare() {
+ sed -i -e "/Version=/d" -e "s/Application;//" gmapcatcher.desktop || die
+ distutils-r1_src_prepare
+}
diff --git a/sci-geosciences/gmapcatcher/metadata.xml b/sci-geosciences/gmapcatcher/metadata.xml
new file mode 100644
index 000000000000..1168f85ccde5
--- /dev/null
+++ b/sci-geosciences/gmapcatcher/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>god@politeia.in</email>
+ <name>Denis M.</name>
+ <description>Maintainer, assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ <description>Proxy-Maintainer, CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>
+