summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-24 16:19:41 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-24 16:19:41 +0000
commit16cb9d4b1d301907c5be27f1cc372e0e69c36eb8 (patch)
tree4135d4726d8a82e8e7a19b5040a84511e891a905 /sci-geosciences/gpsd
parentFix dependencies (#417297). Adjust LICENSE (diff)
downloadgentoo-2-16cb9d4b1d301907c5be27f1cc372e0e69c36eb8.tar.gz
gentoo-2-16cb9d4b1d301907c5be27f1cc372e0e69c36eb8.tar.bz2
gentoo-2-16cb9d4b1d301907c5be27f1cc372e0e69c36eb8.zip
Seems to build also with chrony. Fixes bug#406339. Do not keep so much ebuilds around for no reason.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/ChangeLog8
-rw-r--r--sci-geosciences/gpsd/gpsd-3.3-r1.ebuild154
-rw-r--r--sci-geosciences/gpsd/gpsd-3.3.ebuild151
-rw-r--r--sci-geosciences/gpsd/gpsd-3.4.ebuild165
-rw-r--r--sci-geosciences/gpsd/gpsd-3.5.ebuild163
-rw-r--r--sci-geosciences/gpsd/gpsd-3.6.ebuild4
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild4
7 files changed, 11 insertions, 638 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index c4a8cb6bb299..fde3b6a8fea3 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.86 2012/05/23 14:20:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.87 2012/05/24 16:19:41 scarabeus Exp $
+
+ 24 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> -gpsd-3.3-r1.ebuild,
+ -gpsd-3.3.ebuild, -gpsd-3.4.ebuild, -gpsd-3.5.ebuild, gpsd-3.6.ebuild,
+ gpsd-9999.ebuild:
+ Seems to build also with chrony. Fixes bug#406339. Do not keep so much ebuilds
+ around for no reason.
*gpsd-3.6 (23 May 2012)
diff --git a/sci-geosciences/gpsd/gpsd-3.3-r1.ebuild b/sci-geosciences/gpsd/gpsd-3.3-r1.ebuild
deleted file mode 100644
index 66882ebccdae..000000000000
--- a/sci-geosciences/gpsd/gpsd-3.3-r1.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.3-r1.ebuild,v 1.3 2011/12/07 16:17:42 vapier Exp $
-
-EAPI="4"
-
-PYTHON_DEPEND="python? 2:2.6"
-RESTRICT_PYTHON_ABIS="3.*"
-SUPPORT_PYTHON_ABIS="1"
-SCONS_MIN_VERSION="1.2.1"
-
-inherit eutils user multilib distutils scons-utils toolchain-funcs
-
-DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
-HOMEPAGE="http://catb.org/gpsd/"
-SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-
-GPSD_PROTOCOLS=(
- ashtech aivdm clientdebug earthmate evermore fv18 garmin
- garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
- oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
- tripmate tnt ubx
-)
-IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
-IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 ncurses ntp python qt4 +shm +sockets test udev usb X"
-REQUIRED_USE="X? ( python )"
-
-RDEPEND="X? ( dev-python/pygtk:2 )
- ncurses? ( sys-libs/ncurses )
- bluetooth? ( net-wireless/bluez )
- usb? ( virtual/libusb:1 )
- dbus? (
- sys-apps/dbus
- dev-libs/dbus-glib
- )
- ntp? ( net-misc/ntp )
- qt4? ( x11-libs/qt-gui )"
-# xml packages are for man page generation
-DEPEND="${RDEPEND}
- app-text/xmlto
- =app-text/docbook-xml-dtd-4.1*
- test? ( sys-devel/bc )"
-
-pkg_setup() {
- use python && python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-release-rev.patch
- epatch "${FILESDIR}"/${P}-udev-install.patch
- epatch "${FILESDIR}"/${P}-pkg-config.patch
- epatch "${FILESDIR}"/${P}-ldflags.patch
- epatch "${FILESDIR}"/${P}-msocks-init.patch
-
- # Avoid useless -L paths to the install dir
- sed -i \
- -e '/env.Prepend.*LIBPATH=.*installdir/s:env.*:pass:' \
- -e '/env.Prepend.*RPATH=/s:env.*:pass:' \
- -e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
- SConstruct || die
-
- # Extract python info out of SConstruct so we can use saner distribute
- if use python ; then
- pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
- local pybins=$(pyvar python_progs)
- local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
- local packet=$(python -c "${pysrcs}; print(python_extensions['gps/packet'])")
- local client=$(python -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
- sed \
- -e "s|@VERSION@|$(pyvar gpsd_version)|" \
- -e "s|@URL@|$(pyvar website)|" \
- -e "s|@EMAIL@|$(pyvar devmail)|" \
- -e "s|@SCRIPTS@|${pybins}|" \
- -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
- -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
- -e "s|@SCRIPTS@|$(pyvar python_progs)|" \
- "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
- distutils_src_prepare
- fi
-}
-
-src_configure() {
- myesconsargs=(
- prefix=/usr
- libdir="/$(get_libdir)"
- gpsd_user=gpsd
- gpsd_group=uucp
- strip=False
- python=False
- $(use_scons bluetooth bluez)
- $(use_scons cxx libgpsmm)
- $(use_scons debug)
- $(use_scons dbus dbus_export)
- $(use_scons ipv6)
- $(use_scons ncurses)
- $(use_scons ntp ntpshm)
- $(use_scons ntp pps)
- $(use_scons shm shm_export)
- $(use_scons sockets socket_export)
- $(use_scons qt4 libQgpsmm)
- $(use_scons usb)
- )
-
- # enable specified protocols
- local protocol
- for protocol in ${GPSD_PROTOCOLS[@]} ; do
- myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
- done
-}
-
-src_compile() {
- export CHRPATH=true
- tc-export CC CXX PKG_CONFIG
- export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
- escons
-
- use python && distutils_src_compile
-}
-
-src_install() {
- DESTDIR="${D}" escons install $(usex udev udev-install "")
-
- newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
- newinitd "${FILESDIR}"/gpsd.init-2 gpsd
-
- if use python ; then
- distutils_src_install
- # Delete all X related packages if user doesn't want them
- if ! use X ; then
- local p
- for p in $(grep -Il 'import .*pygtk' *) ; do
- find "${D}"/usr/bin -name "${p}*" -delete
- done
- fi
- fi
-}
-
-pkg_preinst() {
- # Run the gpsd daemon as gpsd and group uucp; create it here
- # as it doesn't seem to be needed during compile/install ...
- enewuser gpsd -1 -1 -1 "uucp"
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/sci-geosciences/gpsd/gpsd-3.3.ebuild b/sci-geosciences/gpsd/gpsd-3.3.ebuild
deleted file mode 100644
index 9cb9965f5fe7..000000000000
--- a/sci-geosciences/gpsd/gpsd-3.3.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.3.ebuild,v 1.4 2011/11/22 18:52:30 flameeyes Exp $
-
-EAPI="4"
-
-PYTHON_DEPEND="python? 2:2.6"
-RESTRICT_PYTHON_ABIS="3.*"
-SUPPORT_PYTHON_ABIS="1"
-SCONS_MIN_VERSION="1.2.1"
-
-inherit eutils user multilib distutils scons-utils toolchain-funcs
-
-DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
-HOMEPAGE="http://catb.org/gpsd/"
-SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-
-GPSD_PROTOCOLS=(
- ashtech aivdm clientdebug earthmate evermore fv18 garmin
- garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
- oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
- tripmate tnt ubx
-)
-IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
-IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 ncurses ntp python qt4 test udev usb X"
-REQUIRED_USE="X? ( python )"
-
-RDEPEND="X? ( dev-python/pygtk:2 )
- ncurses? ( sys-libs/ncurses )
- bluetooth? ( net-wireless/bluez )
- usb? ( virtual/libusb:1 )
- dbus? (
- sys-apps/dbus
- dev-libs/dbus-glib
- )
- ntp? ( net-misc/ntp )
- qt4? ( x11-libs/qt-gui )"
-# xml packages are for man page generation
-DEPEND="${RDEPEND}
- app-text/xmlto
- =app-text/docbook-xml-dtd-4.1*
- test? ( sys-devel/bc )"
-
-pkg_setup() {
- use python && python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-release-rev.patch
- epatch "${FILESDIR}"/${P}-udev-install.patch
- epatch "${FILESDIR}"/${P}-pkg-config.patch
- epatch "${FILESDIR}"/${P}-ldflags.patch
-
- # Avoid useless -L paths to the install dir
- sed -i \
- -e '/env.Prepend.*LIBPATH=.*installdir/s:env.*:pass:' \
- -e '/env.Prepend.*RPATH=/s:env.*:pass:' \
- -e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
- SConstruct || die
-
- # Extract python info out of SConstruct so we can use saner distribute
- if use python ; then
- pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
- local pybins=$(pyvar python_progs)
- local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
- local packet=$(python -c "${pysrcs}; print(python_extensions['gps/packet'])")
- local client=$(python -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
- sed \
- -e "s|@VERSION@|$(pyvar gpsd_version)|" \
- -e "s|@URL@|$(pyvar website)|" \
- -e "s|@EMAIL@|$(pyvar devmail)|" \
- -e "s|@SCRIPTS@|${pybins}|" \
- -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
- -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
- -e "s|@SCRIPTS@|$(pyvar python_progs)|" \
- "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
- distutils_src_prepare
- fi
-}
-
-src_configure() {
- myesconsargs=(
- prefix=/usr
- libdir="/$(get_libdir)"
- gpsd_user=gpsd
- gpsd_group=uucp
- strip=False
- python=False
- $(use_scons bluetooth bluez)
- $(use_scons cxx libgpsmm)
- $(use_scons debug)
- $(use_scons dbus dbus-export)
- $(use_scons ipv6)
- $(use_scons ncurses)
- $(use_scons ntp ntpshm)
- $(use_scons ntp pps)
- $(use_scons qt4 libQgpsmm)
- $(use_scons usb)
- )
-
- # enable specified protocols
- local protocol
- for protocol in ${GPSD_PROTOCOLS[@]} ; do
- myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
- done
-}
-
-src_compile() {
- export CHRPATH=true
- tc-export CC CXX PKG_CONFIG
- export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
- escons
-
- use python && distutils_src_compile
-}
-
-src_install() {
- DESTDIR="${D}" escons install $(usex udev udev-install "")
-
- newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
- newinitd "${FILESDIR}"/gpsd.init-2 gpsd
-
- if use python ; then
- distutils_src_install
- # Delete all X related packages if user doesn't want them
- if ! use X ; then
- local p
- for p in $(grep -Il 'import .*pygtk' *) ; do
- find "${D}"/usr/bin -name "${p}*" -delete
- done
- fi
- fi
-}
-
-pkg_preinst() {
- # Run the gpsd daemon as gpsd and group uucp; create it here
- # as it doesn't seem to be needed during compile/install ...
- enewuser gpsd -1 -1 -1 "uucp"
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/sci-geosciences/gpsd/gpsd-3.4.ebuild b/sci-geosciences/gpsd/gpsd-3.4.ebuild
deleted file mode 100644
index 5e719e92baf4..000000000000
--- a/sci-geosciences/gpsd/gpsd-3.4.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.4.ebuild,v 1.3 2012/05/21 22:36:22 vapier Exp $
-
-EAPI="4"
-
-PYTHON_DEPEND="python? 2:2.6"
-RESTRICT_PYTHON_ABIS="3.*"
-SUPPORT_PYTHON_ABIS="1"
-SCONS_MIN_VERSION="1.2.1"
-
-inherit eutils user multilib distutils scons-utils toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.savannah.nongnu.org/gpsd.git"
- inherit git-2
-else
- SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-fi
-
-DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
-HOMEPAGE="http://catb.org/gpsd/"
-
-LICENSE="BSD"
-SLOT="0"
-
-GPSD_PROTOCOLS=(
- ashtech aivdm clientdebug earthmate evermore fv18 garmin
- garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
- oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
- tripmate tnt ubx
-)
-IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
-IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 ncurses ntp python qt4 +shm +sockets test udev usb X"
-REQUIRED_USE="X? ( python )"
-
-RDEPEND="X? ( dev-python/pygtk:2 )
- ncurses? ( sys-libs/ncurses )
- bluetooth? ( net-wireless/bluez )
- usb? ( virtual/libusb:1 )
- dbus? (
- sys-apps/dbus
- dev-libs/dbus-glib
- )
- ntp? ( net-misc/ntp )
- qt4? ( x11-libs/qt-gui )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/bc )"
-
-# xml packages are for man page generation
-if [[ ${PV} == "9999" ]] ; then
- DEPEND+="
- app-text/xmlto
- =app-text/docbook-xml-dtd-4.1*"
-fi
-
-pkg_setup() {
- use python && python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.3-ldflags.patch
- epatch "${FILESDIR}"/${PN}-3.4-cfgetispeed.patch #393515
- epatch "${FILESDIR}"/${PN}-3.4-gpsmon-lm.patch
- epatch "${FILESDIR}"/${PN}-3.4-strptime.patch
- epatch "${FILESDIR}"/${PN}-3.4-chrpath.patch
- epatch "${FILESDIR}"/${PN}-3.4-always-install-man-pages.patch
- epatch "${FILESDIR}"/${PN}-3.4-no-man-gen.patch
-
- # Avoid useless -L paths to the install dir
- sed -i \
- -e '/^env.Prepend(LIBPATH=.installdir(.libdir.).)$/d' \
- -e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
- SConstruct || die
-
- # Extract python info out of SConstruct so we can use saner distribute
- if use python ; then
- pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
- local pybins=$(pyvar python_progs)
- local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
- local packet=$(python -c "${pysrcs}; print(python_extensions['gps/packet'])")
- local client=$(python -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
- sed \
- -e "s|@VERSION@|$(pyvar gpsd_version)|" \
- -e "s|@URL@|$(pyvar website)|" \
- -e "s|@EMAIL@|$(pyvar devmail)|" \
- -e "s|@SCRIPTS@|${pybins}|" \
- -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
- -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
- -e "s|@SCRIPTS@|$(pyvar python_progs)|" \
- "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
- distutils_src_prepare
- fi
-}
-
-src_configure() {
- myesconsargs=(
- prefix=/usr
- libdir="/$(get_libdir)"
- gpsd_user=gpsd
- gpsd_group=uucp
- strip=False
- python=False
- $(use_scons bluetooth bluez)
- $(use_scons cxx libgpsmm)
- $(use_scons debug)
- $(use_scons dbus dbus_export)
- $(use_scons ipv6)
- $(use_scons ncurses)
- $(use_scons ntp ntpshm)
- $(use_scons ntp pps)
- $(use_scons shm shm_export)
- $(use_scons sockets socket_export)
- $(use_scons qt4 libQgpsmm)
- $(use_scons usb)
- )
-
- # enable specified protocols
- local protocol
- for protocol in ${GPSD_PROTOCOLS[@]} ; do
- myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
- done
-}
-
-src_compile() {
- export CHRPATH=
- tc-export CC CXX PKG_CONFIG
- export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
- escons
-
- use python && distutils_src_compile
-}
-
-src_install() {
- DESTDIR="${D}" escons install $(usex udev udev-install "")
-
- newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
- newinitd "${FILESDIR}"/gpsd.init-2 gpsd
-
- if use python ; then
- distutils_src_install
- # Delete all X related packages if user doesn't want them
- if ! use X ; then
- local p
- for p in $(grep -Il 'import .*pygtk' *) ; do
- find "${D}"/usr/bin -name "${p}*" -delete
- done
- fi
- fi
-}
-
-pkg_preinst() {
- # Run the gpsd daemon as gpsd and group uucp; create it here
- # as it doesn't seem to be needed during compile/install ...
- enewuser gpsd -1 -1 -1 "uucp"
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/sci-geosciences/gpsd/gpsd-3.5.ebuild b/sci-geosciences/gpsd/gpsd-3.5.ebuild
deleted file mode 100644
index 66dd7e2984a7..000000000000
--- a/sci-geosciences/gpsd/gpsd-3.5.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.5.ebuild,v 1.1 2012/05/21 22:37:12 vapier Exp $
-
-EAPI="4"
-
-PYTHON_DEPEND="python? 2:2.6"
-RESTRICT_PYTHON_ABIS="3.*"
-SUPPORT_PYTHON_ABIS="1"
-SCONS_MIN_VERSION="1.2.1"
-
-inherit eutils user multilib distutils scons-utils toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.savannah.nongnu.org/gpsd.git"
- inherit git-2
-else
- SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-fi
-
-DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
-HOMEPAGE="http://catb.org/gpsd/"
-
-LICENSE="BSD"
-SLOT="0"
-
-GPSD_PROTOCOLS=(
- ashtech aivdm clientdebug earthmate evermore fv18 garmin
- garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
- oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
- tripmate tnt ubx
-)
-IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
-IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 ncurses ntp python qt4 +shm +sockets test udev usb X"
-REQUIRED_USE="X? ( python )"
-
-RDEPEND="X? ( dev-python/pygtk:2 )
- ncurses? ( sys-libs/ncurses )
- bluetooth? ( net-wireless/bluez )
- usb? ( virtual/libusb:1 )
- dbus? (
- sys-apps/dbus
- dev-libs/dbus-glib
- )
- ntp? ( net-misc/ntp )
- qt4? ( x11-libs/qt-gui )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/bc )"
-
-# xml packages are for man page generation
-if [[ ${PV} == "9999" ]] ; then
- DEPEND+="
- app-text/xmlto
- =app-text/docbook-xml-dtd-4.1*"
-fi
-
-pkg_setup() {
- use python && python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.3-ldflags.patch
- epatch "${FILESDIR}"/${PN}-3.4-chrpath.patch
- epatch "${FILESDIR}"/${PN}-3.4-always-install-man-pages.patch
- epatch "${FILESDIR}"/${PN}-3.5-clock.patch
- epatch "${FILESDIR}"/${PN}-3.4-no-man-gen.patch
-
- # Avoid useless -L paths to the install dir
- sed -i \
- -e '/^env.Prepend(LIBPATH=.installdir(.libdir.).)$/d' \
- -e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
- SConstruct || die
-
- # Extract python info out of SConstruct so we can use saner distribute
- if use python ; then
- pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
- local pybins=$(pyvar python_progs)
- local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
- local packet=$(python -c "${pysrcs}; print(python_extensions['gps/packet'])")
- local client=$(python -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
- sed \
- -e "s|@VERSION@|$(pyvar gpsd_version)|" \
- -e "s|@URL@|$(pyvar website)|" \
- -e "s|@EMAIL@|$(pyvar devmail)|" \
- -e "s|@SCRIPTS@|${pybins}|" \
- -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
- -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
- -e "s|@SCRIPTS@|$(pyvar python_progs)|" \
- "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
- distutils_src_prepare
- fi
-}
-
-src_configure() {
- myesconsargs=(
- prefix="${EPREFIX}/usr"
- libdir="\$prefix/$(get_libdir)"
- gpsd_user=gpsd
- gpsd_group=uucp
- strip=False
- python=False
- $(use_scons bluetooth bluez)
- $(use_scons cxx libgpsmm)
- $(use_scons debug)
- $(use_scons dbus dbus_export)
- $(use_scons ipv6)
- $(use_scons ncurses)
- $(use_scons ntp ntpshm)
- $(use_scons ntp pps)
- $(use_scons shm shm_export)
- $(use_scons sockets socket_export)
- $(use_scons qt4 libQgpsmm)
- $(use_scons usb)
- )
-
- # enable specified protocols
- local protocol
- for protocol in ${GPSD_PROTOCOLS[@]} ; do
- myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
- done
-}
-
-src_compile() {
- export CHRPATH=
- tc-export CC CXX PKG_CONFIG
- export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
- escons
-
- use python && distutils_src_compile
-}
-
-src_install() {
- DESTDIR="${D}" escons install $(usex udev udev-install "")
-
- newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
- newinitd "${FILESDIR}"/gpsd.init-2 gpsd
-
- if use python ; then
- distutils_src_install
- # Delete all X related packages if user doesn't want them
- if ! use X ; then
- local p
- for p in $(grep -Il 'import .*pygtk' *) ; do
- find "${D}"/usr/bin -name "${p}*" -delete
- done
- fi
- fi
-}
-
-pkg_preinst() {
- # Run the gpsd daemon as gpsd and group uucp; create it here
- # as it doesn't seem to be needed during compile/install ...
- enewuser gpsd -1 -1 -1 "uucp"
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/sci-geosciences/gpsd/gpsd-3.6.ebuild b/sci-geosciences/gpsd/gpsd-3.6.ebuild
index 89841abb45d1..0892ff798161 100644
--- a/sci-geosciences/gpsd/gpsd-3.6.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.6.ebuild,v 1.1 2012/05/23 14:20:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.6.ebuild,v 1.2 2012/05/24 16:19:41 scarabeus Exp $
EAPI="4"
@@ -43,7 +43,7 @@ RDEPEND="X? ( dev-python/pygtk:2 )
sys-apps/dbus
dev-libs/dbus-glib
)
- ntp? ( net-misc/ntp )
+ ntp? ( || ( net-misc/ntp net-misc/chrony ) )
qt4? ( x11-libs/qt-gui )"
DEPEND="${RDEPEND}
test? ( sys-devel/bc )"
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 64b570cd867e..375357d28465 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-9999.ebuild,v 1.2 2012/05/21 22:37:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-9999.ebuild,v 1.3 2012/05/24 16:19:41 scarabeus Exp $
EAPI="4"
@@ -43,7 +43,7 @@ RDEPEND="X? ( dev-python/pygtk:2 )
sys-apps/dbus
dev-libs/dbus-glib
)
- ntp? ( net-misc/ntp )
+ ntp? ( || ( net-misc/ntp net-misc/chrony ) )
qt4? ( x11-libs/qt-gui )"
DEPEND="${RDEPEND}
test? ( sys-devel/bc )"