summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-10 19:14:03 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-10 19:14:03 +0000
commit9dd67c4fbe3c3eecaedfc20d2395d1a66878f163 (patch)
tree6745a1944993d1c7ce97a008457bb67a1de6560c /sci-geosciences/grass
parentRemove largefile USE support and default to it (diff)
downloadgentoo-2-9dd67c4fbe3c3eecaedfc20d2395d1a66878f163.tar.gz
gentoo-2-9dd67c4fbe3c3eecaedfc20d2395d1a66878f163.tar.bz2
gentoo-2-9dd67c4fbe3c3eecaedfc20d2395d1a66878f163.zip
Remove largefile USE support and default to it
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/ChangeLog6
-rw-r--r--sci-geosciences/grass/grass-6.3.0.ebuild8
-rw-r--r--sci-geosciences/grass/grass-6.4.0.ebuild10
-rw-r--r--sci-geosciences/grass/metadata.xml1
4 files changed, 13 insertions, 12 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 10862d4a0751..e28559bc3913 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/grass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.94 2011/02/26 21:03:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.95 2011/03/10 19:14:03 jlec Exp $
+
+ 10 Mar 2011; Justin Lecher <jlec@gentoo.org> grass-6.3.0.ebuild,
+ grass-6.4.0.ebuild, metadata.xml:
+ Remove largefile USE support and default to it
26 Feb 2011; Raúl Porcel <armin76@gentoo.org> grass-6.3.0.ebuild,
grass-6.4.0.ebuild:
diff --git a/sci-geosciences/grass/grass-6.3.0.ebuild b/sci-geosciences/grass/grass-6.3.0.ebuild
index 7bceae0af171..8c34e9d156c1 100644
--- a/sci-geosciences/grass/grass-6.3.0.ebuild
+++ b/sci-geosciences/grass/grass-6.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.20 2011/02/26 21:03:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.21 2011/03/10 19:14:03 jlec Exp $
EAPI=1
@@ -18,7 +18,7 @@ LICENSE="GPL-2"
SLOT="6"
KEYWORDS="amd64 ppc ~ppc64 x86"
-IUSE="ffmpeg fftw gmath jpeg largefile motif mysql nls odbc opengl png \
+IUSE="ffmpeg fftw gmath jpeg motif mysql nls odbc opengl png \
postgres python readline sqlite tiff truetype wxwidgets X"
RESTRICT="strip"
@@ -214,14 +214,14 @@ src_compile() {
$(use_with gmath blas) \
$(use_with gmath lapack) \
$(use_with jpeg) \
- $(use_enable largefile) \
$(use_with motif) \
$(use_with nls) \
$(use_with odbc) \
$(use_with png) \
$(use_with postgres) \
$(use_with readline) \
- $(use_with tiff) || die "configure failed!"
+ $(use_with tiff) \
+ --enable-largefile \
if use wxwidgets; then
# can't use die here since we need to hack the vdigit build
diff --git a/sci-geosciences/grass/grass-6.4.0.ebuild b/sci-geosciences/grass/grass-6.4.0.ebuild
index 855576efbf26..b89437444a33 100644
--- a/sci-geosciences/grass/grass-6.4.0.ebuild
+++ b/sci-geosciences/grass/grass-6.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.0.ebuild,v 1.5 2011/02/26 21:03:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.0.ebuild,v 1.6 2011/03/10 19:14:03 jlec Exp $
EAPI="3"
@@ -19,7 +19,7 @@ LICENSE="GPL-2"
SLOT="6"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="X cairo cxx ffmpeg fftw gmath jpeg largefile motif mysql nls odbc opengl png postgres python readline sqlite tiff truetype wxwidgets"
+IUSE="X cairo cxx ffmpeg fftw gmath jpeg motif mysql nls odbc opengl png postgres python readline sqlite tiff truetype wxwidgets"
TCL_DEPS="
>=dev-lang/tcl-8.5
@@ -51,9 +51,7 @@ RDEPEND="
)
readline? ( sys-libs/readline )
sqlite? ( dev-db/sqlite:3 )
- tiff? ( media-libs/tiff
- largefile? ( >=media-libs/tiff-4 )
- )
+ tiff? ( >=media-libs/tiff-4 )
truetype? ( media-libs/freetype:2 )
X? (
x11-libs/libICE
@@ -210,7 +208,6 @@ src_configure() {
$(use_with gmath blas) \
$(use_with gmath lapack) \
$(use_with jpeg) \
- $(use_enable largefile) \
$(use_with mysql) \
--with-mysql-includes=/usr/include/mysql \
--with-mysql-libs=/usr/$(get_libdir)/mysql \
@@ -224,6 +221,7 @@ src_configure() {
$(use_with tiff) \
$(use_with truetype freetype) \
--with-freetype-includes="/usr/include/freetype2/" \
+ --enable-largefile \
${myconf}
}
diff --git a/sci-geosciences/grass/metadata.xml b/sci-geosciences/grass/metadata.xml
index a4ef59093109..e0cbe3e38441 100644
--- a/sci-geosciences/grass/metadata.xml
+++ b/sci-geosciences/grass/metadata.xml
@@ -11,6 +11,5 @@ See the GRASS Documentation Project for more info http://grass.itc.it/gdp/index.
</longdescription>
<use>
<flag name='gmath'>Enable gmath wrapper for BLAS/Lapack (<pkg>virtual/blas</pkg>, <pkg>virtual/lapack</pkg>)</flag>
- <flag name='largefile'>Enable LFS support for huge files</flag>
</use>
</pkgmetadata>