summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2010-03-29 04:16:46 +0000
committerSteve Arnold <nerdboy@gentoo.org>2010-03-29 04:16:46 +0000
commit0a78232d08ab8eff0b68060a946b35414f025fbd (patch)
treea047655afe66baa9ec636f7a13bcbeae9e8e43d5 /sci-geosciences
parentVersion bump. Dropping old testing version. (diff)
downloadgentoo-2-0a78232d08ab8eff0b68060a946b35414f025fbd.tar.gz
gentoo-2-0a78232d08ab8eff0b68060a946b35414f025fbd.tar.bz2
gentoo-2-0a78232d08ab8eff0b68060a946b35414f025fbd.zip
Updated to force the specified version of Boost (fixes bug 308487).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/mapnik/ChangeLog10
-rw-r--r--sci-geosciences/mapnik/mapnik-0.6.1-r3.ebuild (renamed from sci-geosciences/mapnik/mapnik-0.6.1-r2.ebuild)62
2 files changed, 44 insertions, 28 deletions
diff --git a/sci-geosciences/mapnik/ChangeLog b/sci-geosciences/mapnik/ChangeLog
index 7a57cc151666..88343b80c3cd 100644
--- a/sci-geosciences/mapnik/ChangeLog
+++ b/sci-geosciences/mapnik/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-geosciences/mapnik
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.15 2010/03/07 21:15:50 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.16 2010/03/29 04:16:46 nerdboy Exp $
+
+*mapnik-0.6.1-r3 (29 Mar 2010)
+
+ 29 Mar 2010; Steve Arnold <nerdboy@gentoo.org> -mapnik-0.6.1-r2.ebuild,
+ +mapnik-0.6.1-r3.ebuild:
+ Updated to force the specified version of Boost (really fixes bug 308487).
+ Ensures that it configures, builds, and links against one and only one
+ version, no matter which other versions are installed. So there...
*mapnik-0.6.1-r2 (07 Mar 2010)
diff --git a/sci-geosciences/mapnik/mapnik-0.6.1-r2.ebuild b/sci-geosciences/mapnik/mapnik-0.6.1-r3.ebuild
index 160dfb78cff0..f1c674f9f948 100644
--- a/sci-geosciences/mapnik/mapnik-0.6.1-r2.ebuild
+++ b/sci-geosciences/mapnik/mapnik-0.6.1-r3.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.6.1-r2.ebuild,v 1.1 2010/03/07 21:15:50 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.6.1-r3.ebuild,v 1.1 2010/03/29 04:16:46 nerdboy Exp $
EAPI=2
+PYTHON_DEPEND="2:2.6"
inherit eutils python distutils toolchain-funcs versionator
@@ -15,7 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="cairo curl debug doc +gdal postgres python sqlite"
-RDEPEND="<dev-libs/boost-1.41.0
+RDEPEND="=dev-libs/boost-1.39*
dev-libs/libxml2
dev-libs/icu
media-libs/libpng
@@ -25,7 +26,7 @@ RDEPEND="<dev-libs/boost-1.41.0
sci-libs/proj
x11-libs/agg[gpc,truetype]
media-fonts/dejavu
- python? ( <dev-libs/boost-1.41.0[python] )
+ python? ( =dev-libs/boost-1.39*[python] )
cairo? ( x11-libs/cairo
dev-cpp/cairomm )
postgres? (
@@ -48,6 +49,30 @@ src_prepare() {
bindings/python/SConscript || die "sed 1 failed"
rm -rf agg
epatch "${FILESDIR}"/${P}-libagg.patch
+
+ BOOST_PKG="$(best_version "<dev-libs/boost-1.40.0")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ export BOOST_VERSION="$(replace_all_version_separators _ "${BOOST_VER}")"
+ elog "${P} BOOST_VERSION is ${BOOST_VERSION}"
+ export BOOST_INC="/usr/include/boost-${BOOST_VERSION}"
+ elog "${P} BOOST_INC is ${BOOST_INC}"
+ BOOST_LIBDIR_SCHEMA="$(get_libdir)/boost-${BOOST_VERSION}"
+ export BOOST_LIB="/usr/${BOOST_LIBDIR_SCHEMA}"
+ elog "${P} BOOST_LIB is ${BOOST_LIB}"
+
+ # Passing things doesn't seem to hit all the right paths; another
+ # poster-child for just a bit too much complexity for its own good.
+ # See bug #301674 for more info.
+ sed -i -e "s|searchDir, LIBDIR_SCHEMA|searchDir, \'${BOOST_LIBDIR_SCHEMA}\'|" \
+ -i -e "s|include/boost*|include/boost-${BOOST_VERSION}|" \
+ "${S}"/SConstruct || die "sed boost paths failed..."
+
+ # this is only for 1.37
+# sed -i -e "s|libboost_filesystem-|libboost_filesystem-mt|" \
+# "${S}"/SConstruct || die "sed boost 1.37 failed..."
+ # this is only for boost greater than 1.39
+# sed -i -e "s|boost/property|boost/property_map/property|" \
+# "${S}"/include/mapnik/feature.hpp
}
src_configure() {
@@ -66,27 +91,9 @@ src_configure() {
use postgres && use sqlite && MAKEOPTS="${MAKEOPTS} PGSQL2SQLITE=yes"
- BOOST_PKG="$(best_version "<dev-libs/boost-1.41.0")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- export BOOST_VERSION="$(replace_all_version_separators _ "${BOOST_VER}")"
- elog "${P} BOOST_VERSION is ${BOOST_VERSION}"
- export BOOST_INC="/usr/include/boost-${BOOST_VERSION}"
- elog "${P} BOOST_INC is ${BOOST_INC}"
- BOOST_LIBDIR_SCHEMA="$(get_libdir)/boost-${BOOST_VERSION}"
- export BOOST_LIB="/usr/${BOOST_LIBDIR_SCHEMA}"
- elog "${P} BOOST_LIB is ${BOOST_LIB}"
-
- # Passing things doesn't seem to hit all the right paths; another
- # poster-child for just a bit too much complexity for its own good.
- # See bug #301674 for more info.
-# sed -i -e "s|BOOST_INCLUDE_DIR = None|BOOST_INCLUDE_DIR = \'${BOOST_INC}\'|" \
-# -i -e "s|BOOST_LIB_DIR = None|BOOST_LIB_DIR = \'${BOOST_LIB}\'|" \
- sed -i -e "s|searchDir, LIBDIR_SCHEMA|searchDir, \'${BOOST_LIBDIR_SCHEMA}\'|" \
- -i -e "s|include/boost*|include/boost-${BOOST_VERSION}|" \
- "${S}"/SConstruct || die "sed boost paths failed..."
-
- scons CXX="$(tc-getCXX)" ${MAKEOPTS} DESTDIR="${D}" configure \
- || die "scons configure failed"
+ scons CXX="$(tc-getCXX)" ${MAKEOPTS} DESTDIR="${D}" \
+ BOOST_INCLUDES=${BOOST_INC} BOOST_LIBS=${BOOST_LIB} \
+ configure || die "scons configure failed"
}
src_compile() {
@@ -95,11 +102,12 @@ src_compile() {
}
src_install() {
- scons install || die "scons install failed"
+ scons BOOST_INCLUDES=${BOOST_INC} BOOST_LIBS=${BOOST_LIB} \
+ BOOST_VERSION=${BOOST_VERSION} install \
+ || die "scons install failed"
if use python ; then
- distutils_python_version
- fperms 0755 /usr/$(get_libdir)/python${PYVER}/site-packages/mapnik/paths.py
+ fperms 0755 $(python_get_sitedir)/mapnik/paths.py
dobin utils/stats/mapdef_stats.py
insinto /usr/share/doc/${P}/examples
doins utils/ogcserver/*