summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2014-12-26 22:08:14 +0000
committerDavide Pesavento <pesa@gentoo.org>2014-12-26 22:08:14 +0000
commit16670b51800caf59cbaccb905bb67ab790ddbd56 (patch)
treeb596780232cc194ed2f9f0c66f4b2d7bd98dd5fd /sci-geosciences
parentConvert to distutils-r1. (diff)
downloadgentoo-2-16670b51800caf59cbaccb905bb67ab790ddbd56.tar.gz
gentoo-2-16670b51800caf59cbaccb905bb67ab790ddbd56.tar.bz2
gentoo-2-16670b51800caf59cbaccb905bb67ab790ddbd56.zip
Add := to dev-python/sip dependency wrt bug 462712. Drop obsolete python2_6 target.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/ChangeLog6
-rw-r--r--sci-geosciences/qgis/qgis-1.8.0.ebuild23
2 files changed, 15 insertions, 14 deletions
diff --git a/sci-geosciences/qgis/ChangeLog b/sci-geosciences/qgis/ChangeLog
index f35959417c7a..61c1c0083e3e 100644
--- a/sci-geosciences/qgis/ChangeLog
+++ b/sci-geosciences/qgis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/qgis
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.34 2014/11/10 15:21:40 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.35 2014/12/26 22:08:14 pesa Exp $
+
+ 26 Dec 2014; Davide Pesavento <pesa@gentoo.org> qgis-1.8.0.ebuild:
+ Add := to dev-python/sip dependency wrt bug 462712. Drop obsolete python2_6
+ target.
10 Nov 2014; Davide Pesavento <pesa@gentoo.org>
+files/qgis-1.7.0-avoid-deprecated-pyqtconfig.patch, qgis-1.7.0.ebuild,
diff --git a/sci-geosciences/qgis/qgis-1.8.0.ebuild b/sci-geosciences/qgis/qgis-1.8.0.ebuild
index c123ea1bc970..f6b7b327070d 100644
--- a/sci-geosciences/qgis/qgis-1.8.0.ebuild
+++ b/sci-geosciences/qgis/qgis-1.8.0.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/qgis-1.8.0.ebuild,v 1.6 2014/11/10 15:21:40 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/qgis-1.8.0.ebuild,v 1.7 2014/12/26 22:08:14 pesa Exp $
EAPI=5
-PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"
-inherit eutils multilib gnome2-utils cmake-utils python-single-r1
+inherit eutils gnome2-utils multilib cmake-utils python-single-r1
DESCRIPTION="User friendly Geographic Information System"
HOMEPAGE="http://www.qgis.org/"
-SRC_URI="
- http://qgis.org/downloads/qgis-${PV}.tar.bz2
+SRC_URI="http://qgis.org/downloads/${P}.tar.bz2
examples? ( http://download.osgeo.org/qgis/data/qgis_sample_data.tar.gz )"
LICENSE="GPL-2"
@@ -25,25 +24,24 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
${PYTHON_DEPS}
dev-libs/expat
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ dev-qt/qtsql:4
+ dev-qt/qtwebkit:4
sci-geosciences/gpsbabel
>=sci-libs/gdal-1.6.1[geos,python?]
sci-libs/geos
sci-libs/gsl
sci-libs/libspatialindex
sci-libs/proj
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtsvg:4
- dev-qt/qtsql:4
- dev-qt/qtwebkit:4
x11-libs/qwt:5[svg]
!bundled-libs? ( <x11-libs/qwtpolar-1 )
grass? ( >=sci-geosciences/grass-6.4.0_rc6[python?] )
postgres? ( >=virtual/postgresql-8.4 )
python? (
dev-python/PyQt4[X,sql,svg,${PYTHON_USEDEP}]
- dev-python/sip[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
+ dev-python/sip:=[${PYTHON_USEDEP}]
)
spatialite? (
dev-db/sqlite:3
@@ -80,7 +78,6 @@ src_configure() {
$(cmake-utils_use_enable test TESTS)
$(usex grass "-DGRASS_PREFIX=/usr/" "")
)
-
cmake-utils_src_configure
}