summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGérald Fenoy <djay@gentoo.org>2007-09-21 08:21:50 +0000
committerGérald Fenoy <djay@gentoo.org>2007-09-21 08:21:50 +0000
commit3cc12820ed8acaf6cb13e164c8c82968f449b9e0 (patch)
treeb85eead75735e570847d14311ccbd7a9179f6b45 /sci-geosciences
parentstable x86, security bug 193179 (diff)
downloadgentoo-2-3cc12820ed8acaf6cb13e164c8c82968f449b9e0.tar.gz
gentoo-2-3cc12820ed8acaf6cb13e164c8c82968f449b9e0.tar.bz2
gentoo-2-3cc12820ed8acaf6cb13e164c8c82968f449b9e0.zip
Adding the mapserver-5.0.0 ebuild for the foss4g 2007.
(Portage version: 2.1.2.12)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/mapserver/ChangeLog8
-rw-r--r--sci-geosciences/mapserver/files/digest-mapserver-5.0.03
-rw-r--r--sci-geosciences/mapserver/files/mapserver-5.0.0_php.patch246
-rw-r--r--sci-geosciences/mapserver/mapserver-5.0.0.ebuild349
4 files changed, 605 insertions, 1 deletions
diff --git a/sci-geosciences/mapserver/ChangeLog b/sci-geosciences/mapserver/ChangeLog
index cb5bad448ff4..864d58e7f553 100644
--- a/sci-geosciences/mapserver/ChangeLog
+++ b/sci-geosciences/mapserver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/mapserver
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.6 2007/09/01 16:58:36 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.7 2007/09/21 08:21:49 djay Exp $
+
+*mapserver-5.0.0 (22 Nov 2007)
+
+ 22 Nov 2007; <djay@gentoo.org> +files/mapserver-5.0.0_php.patch,
+ +mapserver-5.0.0.ebuild:
+ Version Bump to 5.0.0 : thx to fordfrog for his work
*mapserver-4.10.3 (01 Sep 2007)
diff --git a/sci-geosciences/mapserver/files/digest-mapserver-5.0.0 b/sci-geosciences/mapserver/files/digest-mapserver-5.0.0
new file mode 100644
index 000000000000..baf16a1fbe9f
--- /dev/null
+++ b/sci-geosciences/mapserver/files/digest-mapserver-5.0.0
@@ -0,0 +1,3 @@
+MD5 1980962821e18e3f3535d6f3491e3f63 mapserver-5.0.0.tar.gz 1803416
+RMD160 82b505bf59139afc4a581543c6b4789a52ac1b2c mapserver-5.0.0.tar.gz 1803416
+SHA256 c754b87a62776d7cd9e781df7523a0560f0773ece5faefb8acc6c030f776b5b7 mapserver-5.0.0.tar.gz 1803416
diff --git a/sci-geosciences/mapserver/files/mapserver-5.0.0_php.patch b/sci-geosciences/mapserver/files/mapserver-5.0.0_php.patch
new file mode 100644
index 000000000000..2dd97e475192
--- /dev/null
+++ b/sci-geosciences/mapserver/files/mapserver-5.0.0_php.patch
@@ -0,0 +1,246 @@
+--- ./mapserver-5.0.0/configure.in 2007-09-06 15:02:32.000000000 +0200
++++ ./configure.in 2007-11-21 23:37:44.000000000 +0100
+@@ -2020,14 +2020,20 @@
+ [CFLAGS="$CFLAGS -fprofile-arcs -ftest-coverage"
+ PHP_LD_XTRAFLAGS="$PHP_LD_XTRAFLAGS -fprofile-arcs -ftest-coverage"])
+
+-
+ dnl ---------------------------------------------------------------------
+ dnl PHP/MapScript module options
+ dnl ---------------------------------------------------------------------
+
+-AC_CHECKING(for PHP/MapScript module options)
+-AC_ARG_WITH(php,
+-[ --with-php=DIR Specify directory where PHP4's include files are
++AC_CHECKING(for PHP4/MapScript module options)
++AC_ARG_WITH(php4,
++[ --with-php4=DIR Specify directory where PHP4's include files are
++ installed (or a pointer to the full source tree)
++ Required in order to compile the PHP/MapScript
++ module.],,)
++
++AC_CHECKING(for PHP5/MapScript module options)
++AC_ARG_WITH(php5,
++[ --with-php5=DIR Specify directory where PHP5's include files are
+ installed (or a pointer to the full source tree)
+ Required in order to compile the PHP/MapScript
+ module.],,)
+@@ -2038,8 +2044,11 @@
+ link php_mapscript.so. Try this only if the default
+ internal macro didn't work.],,)
+
+-if test -n "$with_php" -a -d "$with_php" ; then
+- AC_EXPAND_PATH($with_php, PHP_SRC_DIR)
++dnl --------------------------------------------------------------------------
++dnl No php version specific
++dnl --------------------------------------------------------------------------
++
++if test -n "$with_php4" -o -n "$with_php5" ; then
+ dnl
+ dnl Checks for shared library linking.
+ dnl
+@@ -2072,6 +2081,102 @@
+ PHP_LD="$PHP_LD_SHARED $PHP_LD_XTRAFLAGS"
+ fi
+
++fi
++
++if test -n "$with_php5" -a -d "$with_php5" ; then
++ AC_EXPAND_PATH($with_php5, PHP5_SRC_DIR)
++
++ dnl
++ dnl Look for PHP4's config.h or PHP5's php_config.h.
++ dnl We'll need the config file to find info about the PHP configuration
++ dnl
++ AC_MSG_CHECKING([for location of config.h or php_config.h])
++ dnl In PHP3, it was called config.h
++ test -f "$PHP5_SRC_DIR/config.h" && PHP5_CONFIG_H="$PHP5_SRC_DIR/config.h"
++
++ dnl In PHP 4.0.1 to 4.0.3, it was php-4.0.x/php_config.h
++ test -f "$PHP5_SRC_DIR/php_config.h" && PHP5_CONFIG_H="$PHP5_SRC_DIR/php_config.h"
++
++ dnl Starting with PHP 4.0.4, it's php-4.0.x/main/php_config.h
++ test -f "$PHP5_SRC_DIR/main/php_config.h" && PHP5_CONFIG_H="$PHP5_SRC_DIR/main/php_config.h"
++
++ dnl If php was installed, then the headers are under $prefix/include/php/*
++ test -f "$PHP5_SRC_DIR/include/php/main/php_config.h" && PHP5_SRC_DIR="$PHP5_SRC_DIR/include/php/" && PHP5_CONFIG_H="$PHP5_SRC_DIR/main/php_config.h"
++
++ if test -n "$PHP5_CONFIG_H" ; then
++ AC_MSG_RESULT([$PHP5_CONFIG_H])
++ else
++ AC_MSG_ERROR([
++!!! Could not find config.h or php_config.h in $PHP5_SRC_DIR. !!!
++!!! Has PHP5 been configured yet? !!!])
++ fi
++
++ dnl
++ dnl Check which PHP5 version we're using.
++ dnl Default is PHP3, and if ZEND_API is set then we assume that we have PHP4.
++ dnl
++ AC_MSG_CHECKING([whether we have PHP3 or PHP4])
++ if test -n "`grep 'ZEND_API' $PHP5_CONFIG_H`" ; then
++ PHP5_VERSION_FLAG="-DPHP4"
++ else
++ PHP5_VERSION_FLAG="-DPHP3"
++ AC_MSG_ERROR([
++!!! PHP MapScript now requires PHP 4.1.2 or more recent. !!!
++!!! Support for PHP3 has been dropped after MapServer version 3.5. !!!])
++ fi
++ AC_MSG_RESULT([$PHP5_VERSION_FLAG])
++
++ dnl
++ dnl Check if PHP was compiled with the bundled regex, and if so then
++ dnl use the same version to compile MapServer.
++ dnl
++ AC_MSG_CHECKING([whether we should use PHP5's regex])
++ if test -n "`grep 'define REGEX 1' $PHP5_CONFIG_H`" ; then
++ AC_MSG_RESULT(yes)
++
++ dnl We'll check for regex_extra.h - that might let use build
++ dnl without the source using libphp_common.so
++ test -f "$PHP5_SRC_DIR/regex/regex_extra.h" && PHP5_NO_SOURCE="1"
++ if test -n "$PHP5_NO_SOURCE" ; then
++ dnl Found regex_extra.h
++ USE_PHP5_REGEX="-DUSE_PHP_REGEX"
++ PHP5_REGEX_OBJ=php_regex.o
++ AC_MSG_RESULT([ found regex_extra.h - building PHP5 MapScript with PHP's bundled regex ])
++ else
++ AC_MSG_ERROR([
++!!! PHP uses its bundled regex library but regex/regex_extra.h cannot be !!!
++!!! found. !!!])
++ fi
++
++ else
++ AC_MSG_RESULT(no)
++ fi
++
++ PHP5MS_MAKEFILE=mapscript/php5/Makefile
++ MAKE_PHP5MS=php5_mapscript
++ MAKE_PHP5MS_CLEAN=php_mapscript_clean
++
++ AC_SUBST(PHP5_VERSION_FLAG, $PHP5_VERSION_FLAG)
++ AC_SUBST(PHP5_SRC_DIR, $PHP5_SRC_DIR)
++ AC_SUBST(PHP_CC, $PHP_CC)
++ AC_SUBST(PHP_LD, $PHP_LD)
++ AC_SUBST(PHP5_REGEX_INC, $PHP5_REGEX_INC)
++ AC_SUBST(PHP5_REGEX_OBJ, $PHP5_REGEX_OBJ)
++ AC_SUBST(USE_PHP5_REGEX, $USE_PHP5_REGEX)
++
++ AC_MSG_RESULT([ PHP5/MapScript module configured.])
++elif test -n "$with_php5" -a "$with_php5" != "no" ; then
++ AC_MSG_ERROR([Missing or invalid PHP5 source directory in --with-php5=DIR.])
++else
++ AC_MSG_RESULT([ PHP5/MapScript module not configured.])
++fi
++
++AC_SUBST(MAKE_PHP5MS, $MAKE_PHP5MS)
++AC_SUBST(MAKE_PHP5MS_CLEAN, $MAKE_PHP5MS_CLEAN)
++
++if test -n "$with_php4" -a -d "$with_php4" ; then
++ AC_EXPAND_PATH($with_php4, PHP_SRC_DIR)
++
+ dnl
+ dnl Look for PHP3's config.h or PHP4's php_config.h.
+ dnl We'll need the config file to find info about the PHP configuration
+@@ -2318,7 +2423,7 @@
+ AC_SUBST(ALL_STATIC_LIB, $ALL_STATIC_LIB)
+ AC_SUBST(RPATHS, [$RPATHS])
+
+-AC_OUTPUT(Makefile $PHPMS_MAKEFILE mapscript/java/Makefile mapscript/csharp/Makefile)
++AC_OUTPUT(Makefile $PHPMS_MAKEFILE $PHP5MS_MAKEFILE mapscript/java/Makefile mapscript/csharp/Makefile)
+
+ dnl ---------------------------------------------------------------------------
+ dnl Display configuration status
+--- ./mapserver-5.0.0/Makefile.in 2007-08-22 18:27:43.000000000 +0200
++++ ./Makefile.in 2007-11-21 23:37:44.000000000 +0100
+@@ -185,6 +185,8 @@
+ #
+ PHP_REGEX_OBJ=@PHP_REGEX_OBJ@
+ PHP_REGEX_INC=@PHP_REGEX_INC@
++PHP5_REGEX_OBJ=@PHP5_REGEX_OBJ@
++PHP5_REGEX_INC=@PHP5_REGEX_INC@
+
+ #
+ # Multithreading support.
+@@ -259,7 +261,7 @@
+ #
+ # --- You shouldn't have to edit anything else. ---
+ #
+-all: $(MAKE_GD) libmapserver.a $(EXTRA_DEFAULT) $(EXE_LIST) @MAKE_PHPMS@
++all: $(MAKE_GD) libmapserver.a $(EXTRA_DEFAULT) $(EXE_LIST) @MAKE_PHPMS@ @MAKE_PHP5MS@
+
+ #
+ # Non-gnumake's don't seem to use this pattern rule,
+@@ -277,6 +279,9 @@
+
+ php3_mapscript:: $(LIBMAP_STATIC)
+ cd mapscript/php3; $(MAKE); cd ../..
++php5_mapscript:: $(LIBMAP_STATIC)
++ cd mapscript/php5; $(MAKE); cd ../..
++
+
+ maplexer.o: maplexer.c mapserver.h mapfile.h
+
+--- ./mapserver-5.0.0/mapscript/php3/Makefile.in 2007-06-11 17:38:12.000000000 +0200
++++ ./mapscript/php3/Makefile.in 2007-11-21 23:37:37.000000000 +0100
+@@ -77,7 +77,7 @@
+
+ CFLAGS112 = $(CFLAGS) $(MS_DEFINE) $(MS_INC) $(PHP_INC) $(PHP_REGEX_INC)
+
+-all: php_mapscript.so
++all: php_mapscript.so php_proj.so
+
+ PHPMS_OBJS = php_mapscript_util.o php_mapscript.o mapscript_i.o $(PHP_REGEX_OBJ)
+
+--- ./mapserver-5.0.0/mapscript/php5/Makefile.in 2007-11-22 10:19:13.000000000 +0100
++++ ./mapscript/php5/Makefile.in 2007-11-22 21:48:54.000000000 +0100
+@@ -35,13 +35,13 @@
+
+ CC = @PHP_CC@
+ LD = @PHP_LD@
+-CFLAGS = @CFLAGS@ @USE_PHP_REGEX@ -DCOMPILE_DL=1 @PHP_VERSION_FLAG@
++CFLAGS = @CFLAGS@ @USE_PHP5_REGEX@ -DCOMPILE_DL=1 @PHP5_VERSION_FLAG@
+ RUNPATHS= @RPATHS@
+
+ #
+ # Set PHP_SRC_DIR to point to the root of the PHP source tree
+ #
+-PHP_SRC_DIR = @PHP_SRC_DIR@
++PHP_SRC_DIR = @PHP5_SRC_DIR@
+
+ PHP_INC = -I$(PHP_SRC_DIR) -I$(PHP_SRC_DIR)/dl -I$(PHP_SRC_DIR)/main \
+ -I$(PHP_SRC_DIR)/Zend -I$(PHP_SRC_DIR)/include \
+@@ -53,8 +53,8 @@
+ # In order to compile the PHP_MAPSCRIPT module, we have to make MapServer
+ # uses the same version of the REGEX library that PHP was compiled with:
+ #
+-PHP_REGEX_OBJ=@PHP_REGEX_OBJ@
+-PHP_REGEX_INC=@PHP_REGEX_INC@
++PHP_REGEX_OBJ=@PHP5_REGEX_OBJ@
++PHP_REGEX_INC=@PHP5_REGEX_INC@
+
+
+ #
+@@ -77,17 +77,17 @@
+
+ CFLAGS112 = $(CFLAGS) $(MS_DEFINE) $(MS_INC) $(PHP_INC) $(PHP_REGEX_INC)
+
+-all: php_mapscript.so
++all: php_mapscript.so php_proj.so
+
+-PHPMS_OBJS = php_mapscript_util.o php_mapscript.o mapscript_i.o $(PHP_REGEX_OBJ)
++PHP5MS_OBJS = php_mapscript_util.o php_mapscript.o mapscript_i.o $(PHP_REGEX_OBJ)
+
+-PHPPROJ_OBJS = php_mapscript_util.o php_proj.o $(PHP_REGEX_OBJ)
++PHP5PROJ_OBJS = php_mapscript_util.o php_proj.o $(PHP_REGEX_OBJ)
+
+
+-php_mapscript.so: $(PHPMS_OBJS) ../../libmapserver.a
++php_mapscript.so: $(PHP5MS_OBJS) ../../libmapserver.a
+ $(LD) -o $@ $(PHPMS_OBJS) $(MS_LIBS)
+
+-php_proj.so: $(PHPPROJ_OBJS)
++php_proj.so: $(PHP5PROJ_OBJS)
+ $(LD) -o $@ $(PHPPROJ_OBJS) $(MS_LIBS)
+
+ %.o: %.c php_mapscript_util.h php_mapscript.h
diff --git a/sci-geosciences/mapserver/mapserver-5.0.0.ebuild b/sci-geosciences/mapserver/mapserver-5.0.0.ebuild
new file mode 100644
index 000000000000..ac2288ab4bfc
--- /dev/null
+++ b/sci-geosciences/mapserver/mapserver-5.0.0.ebuild
@@ -0,0 +1,349 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/mapserver-5.0.0.ebuild,v 1.1 2007/09/21 08:21:49 djay Exp $
+
+PHP_EXT_NAME="php_mapscript php_proj"
+RUBY_OPTIONAL="yes"
+
+inherit eutils autotools distutils depend.php depend.apache webapp ruby java-pkg-opt-2
+
+DESCRIPTION="OpenSource development environment for constructing spatially enabled Internet-web applications."
+HOMEPAGE="http://mapserver.gis.umn.edu/"
+SRC_URI="http://download.osgeo.org/mapserver/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+#I must check for mygis use flag availability
+#"mono"
+IUSE="agg xml pdf proj geos tiff gdal xpm postgis flash php python perl ruby tcl threads java doc"
+
+# compilation fails with jdk > 1.4 on some native part probably
+DEPEND="media-libs/libpng
+ media-libs/jpeg
+ media-libs/freetype
+ sys-libs/zlib
+ >=media-libs/gd-2.0.12
+ apache2? ( www-servers/apache )
+ unicode? ( virtual/libiconv )
+ agg? ( x11-libs/agg )
+ geos? ( sci-libs/geos )
+ proj? ( sci-libs/proj net-misc/curl )
+ xml? ( dev-libs/libxml2 )
+ gdal? ( >sci-libs/gdal-1.2.6 )
+ postgis? ( dev-db/postgis )
+ tiff? ( media-libs/tiff sci-libs/libgeotiff )
+ xpm? ( x11-libs/libXpm )
+ flash? ( media-libs/ming )
+ pdf? ( media-libs/pdflib )
+ php? ( dev-lang/php dev-lang/swig )
+ ruby? ( dev-lang/ruby dev-lang/swig )
+ perl? ( dev-perl/DBI dev-lang/swig )
+ python? ( dev-lang/python dev-lang/swig )
+ java? ( >=virtual/jdk-1.4 dev-lang/swig )
+ tcl? ( dev-lang/tcl dev-lang/swig )"
+RDEPEND="${DEPEND}"
+
+WEBAPP_MANUAL_SLOT=yes
+
+want_apache
+
+cd_script() {
+ einfo "$2 the mapserver $1-mapscript"
+ cd "${S}"/mapscript/$1 || die "Unable to go into $1 mapscript dir"
+}
+
+pkg_setup(){
+ webapp_pkg_setup
+ java-pkg-opt-2_pkg_setup
+ if use php; then
+ # check how many versions of php was installed
+ has_php
+ np=0
+ if has_version '=dev-lang/php-5*'; then
+ np="$(expr ${np} + 1)"
+ fi
+ if has_version '=dev-lang/php-4*' ; then
+ np="$(expr ${np} + 1)"
+ myphp4=true
+ fi
+ toD="$(if [ ${np} -gt 1 ]; then echo s; fi)"
+ einfo "Using ${np} PHP version${toD}"
+ fi
+
+ elog "Checking for gd compiled with truetype support..."
+ if built_with_use media-libs/gd truetype; then
+ elog "Found truetype support; continuing..."
+ else
+ ewarn "media-libs/gd must be compiled with truetype support,"
+ ewarn "and you probably want jpeg and png support also."
+ elog "Please re-emerge gd with the truetype USE flag."
+ die "gd not merged with truetype USE flag"
+ fi
+
+ if use gdal && use tiff; then
+ ewarn "The MapServer tiff support is not compatible"
+ ewarn "with gdal tiff support."
+ elog "Please disable tiff support for mapserver."
+ die "mapserver has tiff USE flag enabled"
+ fi
+
+ if use java && ! use threads; then
+ ewarn "The MapServer Java support needs threads."
+ elog "Please enable thread support for mapserver."
+ die "mapserver has threads USE flag disabled"
+ fi
+
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ if (use tcl); then
+ epatch "${FILESDIR}"/${PN}_tcl.patch
+ fi
+
+
+ if (use php); then
+ if [ ${np} -eq 2 ]; then
+ mkdir ./mapscript/php4
+ cp -r ./mapscript/php3 ./mapscript/php5 ||\
+ die "Unable to copy php mapscript directory"
+ epatch "${FILESDIR}"/${PF}_php.patch
+ fi
+ fi
+ if [ ! -z "${myphp4}" ]; then
+ epatch "${FILESDIR}"/${PN}_php4.patch
+ fi
+
+}
+
+src_compile() {
+ local step
+ step="Building"
+ cd "${S}"
+
+ AT_GNUCONF_UPDATE="no" eautoreconf
+
+ local myconf
+ myconf="--with-png --with-jpeg --with-zlib --with-freetype"
+ if use apache2 ; then
+ myconf="${myconf} --with-httpd=${APACHECTL/'ctl'/}"
+ fi
+
+ if use geos; then
+ myconf="${myconf} --with-geos=$(type -P geos-config)"
+ fi
+
+ local MYGPUSE="wfs wcs wfsclient"
+
+ if (use gdal && use proj); then
+ myconf="--with-ogr ${myconf}";
+ for i in ${MYGPUSE}; do
+ myconf="${myconf} --with-${i}"
+ done
+ if (use xml); then
+ myconf="${myconf} --with-sos"
+ fi
+ fi
+
+ if (use proj); then
+ myconf="${myconf} --with-wmsclient"
+ fi
+
+ if (use php); then
+ ewarn "You use ${np} version of php"
+ if [ ${np} -eq 2 ] ; then
+ for i in 4 5; do
+ uses_php${i}
+ myconf="${myconf} --with-php${i}=${PHPPREFIX}"
+ done
+ else
+ myconf="${myconf} --with-php=${PHPPREFIX}/include/php"
+ fi
+ fi
+
+ if (use perl || use python || use ruby || use tcl || use php) ; then
+ myconf="${myconf} --with-mapscript";
+ fi
+
+ cd "${S}"
+ econf $(use_with gdal)\
+ $(use_with agg)\
+ $(use_with perl)\
+ $(use_with python)\
+ $(use_with ruby)\
+ $(use_with tcl)\
+ $(use_with proj)\
+ $(use_with postgis)\
+ $(use_with tiff)\
+ $(use_with pdf)\
+ $(use_with flash ming)\
+ $(use_with java)\
+ $(use_with unicode iconv)\
+ $(use_with threads)\
+ ${myconf}\
+ || die "econf failed"
+
+ make || die "make failed"
+
+ if (use php && use proj); then
+ cd "${S}"/mapscript/php3/
+ if [ ${np} -eq 2 ]; then
+ cp *.so ../php4/ || die "Unable to copy php4 mapscript object files"
+ fi
+ fi
+
+ if use perl; then
+ cd_script perl ${step}
+ perl Makefile.PL || die "Unable to build perl mapscript"
+ emake || die "Unable to build perl mapscript"
+ fi
+
+ if use python; then
+ cd_script python ${step}
+ distutils_src_compile || die "Unable to build python mapscript"
+ fi
+
+ if use ruby; then
+ cd_script ruby ${step}
+ RUBY_ECONF="-I${D}"
+ ruby_econf
+ cp ../mapscript.i . || die "Unable to find mapscript.i"
+ sed -e "s:ruby.h defines.h::g" -i ./Makefile
+ ruby_emake
+ fi
+
+ if use tcl; then
+ cd_script tcl ${step}
+ sed "s:perlvars:mapscriptvars:" -i configure
+ sed -e "s:tail -:tail -n :g" -e "s:head -:head -n :g" -i configure ||\
+ die "Unable to modify the configure file"
+ econf --with-tcl=/usr || die "Unable to configure tcl mapscript"
+ touch tclmodule.i
+ #sed -e "s:-DTCL_WIDE_INT_TYPE=long long:-DTCL_WIDE_INT_TYPE=long\\\ long:g" \
+ # -i Makefile || die "Unable to modify Makefile"
+ emake || die "Unable to build tcl mapscript"
+ fi
+
+ if use java; then
+ cd_script java ${step}
+ emake interface || die "Unable to build java mapscript"
+ emake all || die "Unable to build java mapscript"
+ fi
+
+}
+
+src_test(){
+ if use java ; then
+ cd_script java test
+ emake test || die "Test failed"
+ # We need to fix the tests to make them pass
+ sed -i -e "s:setTransparency:setOpacity:g" \
+ ${S}/mapscript/java/tests/threadtest/MapThread.java \
+ || die "fixing of tests failed"
+ emake threadtests || die "Threadtests failed"
+ fi
+}
+
+mapscript_install_examples() {
+ einfo "$1-mapscript examples could be found in the following directory"
+ einfo "/usr/share/doc/${PF}/mapscript/examples/$1"
+ insinto /usr/share/doc/${PF}/mapscript/examples/$1/
+ doins examples/* || die "Unable to install specified sample data"
+}
+
+src_install() {
+ local step
+ step="Installing"
+ extra_dir="fonts tests tests/vera symbols"
+
+ dodir /usr /usr/bin
+
+ into /usr
+
+ if use php; then
+ if [ 2 -eq "${np}" ] ; then
+ for i in 4 5; do
+ cd_script php$i ${step}
+ uses_php$i
+ EXT_DIR="$(${PHPCONFIG} --extension-dir)"
+ dodir ${EXT_DIR}
+ cp *.so ${D}/${EXT_DIR} || \
+ die "Unable to setup php5 mapscript support"
+ done
+ else
+ cd_script php3 ${step}
+ EXT_DIR="$(${PHPCONFIG} --extension-dir)"
+ dodir ${EXT_DIR}
+ cp *.so ${D}/${EXT_DIR} || \
+ die "Unable to setup php4 mapscript support"
+ fi
+ mapscript_install_examples php
+ fi
+
+ if use ruby; then
+ cd_script ruby ${step}
+ ruby_einstall
+ mapscript_install_examples ruby
+ fi
+
+ if use perl; then
+ cd_script perl ${step}
+ make DESTDIR="${D}" install || \
+ die "Unable to setup perl mapscript support"
+ mapscript_install_examples perl
+ fi
+
+ if use tcl; then
+ cd_script tcl ${step}
+ sed "s:\$(TCL_EXEC_PREFIX):\$(DESTDIR)\$(TCL_EXEC_PREFIX):g" -i Makefile
+ make DESTDIR="${D}" install || \
+ die "Unable to setup tcl mapscript support"
+ mapscript_install_examples tcl
+ fi
+
+ if use python; then
+ cd_script python ${step}
+ distutils_src_install
+ mapscript_install_examples python
+ fi
+
+ if (use java); then
+ cd_script java ${step}
+ java-pkg_dojar mapscript.jar
+ java-pkg_doso libmapscript.so
+ mapscript_install_examples java
+ fi
+
+ cd "${S}"
+ into /usr
+
+ if use pdf; then
+ dobin shp2pdf || die "Unable to setup shp2pdf"
+ fi
+
+ dobin shp2img legend shptree shptreevis shp2img legend shptreetst scalebar\
+ sortshp tile4ms msencrypt mapserver-config \
+ || die "Unable to setup mapserver tools"
+
+ dodoc INSTALL README HISTORY.TXT || \
+ die "Unable to setup documentation"
+
+ for i in ${extra_dir}; do
+ insinto /usr/share/doc/${PF}/$i
+ doins $i/* || die "Unable to add extra_dir to document tree"
+ done
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/rfc
+ doins rfc/*
+
+ fi
+
+ webapp_src_preinst
+ chmod +x "${S}"/mapserv || die "Unable to find mapserv"
+ cp "${S}"/mapserv "${D}"/${MY_CGIBINDIR} || die "Unable to install mapserv"
+ webapp_src_install
+}