summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-02-23 20:03:59 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-02-23 20:03:59 +0000
commit526cb746c344f0db28fc5debe877057fdcf62f91 (patch)
treef3fd9163d614e3e6acbb3c4a30e4758a5226cffe /sci-geosciences
parentApply the patch for bug #208631 also in 3.5.9. (diff)
downloadgentoo-2-526cb746c344f0db28fc5debe877057fdcf62f91.tar.gz
gentoo-2-526cb746c344f0db28fc5debe877057fdcf62f91.tar.bz2
gentoo-2-526cb746c344f0db28fc5debe877057fdcf62f91.zip
updated to latest version and new udev rules (closes bug #210079)
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog13
-rw-r--r--sci-geosciences/gpsd/files/99-gpsd-usb.rules9
-rw-r--r--sci-geosciences/gpsd/files/gpsd.conf5
-rw-r--r--sci-geosciences/gpsd/gpsd-2.32.ebuild16
-rw-r--r--sci-geosciences/gpsd/gpsd-2.33-r1.ebuild20
-rw-r--r--sci-geosciences/gpsd/gpsd-2.34-r1.ebuild16
-rw-r--r--sci-geosciences/gpsd/gpsd-2.36.ebuild152
7 files changed, 202 insertions, 29 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index c96bf7493613..b73223546488 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-geosciences/gpsd
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.28 2007/07/22 07:10:12 dberkholz Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.29 2008/02/23 20:03:58 nerdboy Exp $
+
+*gpsd-2.36 (23 Feb 2008)
+
+ 23 Feb 2008; Steve Arnold <nerdboy@gentoo.org> +files/99-gpsd-usb.rules,
+ files/gpsd.conf, +gpsd-2.36.ebuild:
+ Updated to latest version and new udev rules (closes bug #210079). Note
+ the new rules supercede the older ones (but the older ones were not
+ installed by default anyway). The gpsd script is still installed
+ under /etc/hotplug but it only depends on udev now.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; gpsd-2.32.ebuild,
gpsd-2.33-r1.ebuild, gpsd-2.34-r1.ebuild:
diff --git a/sci-geosciences/gpsd/files/99-gpsd-usb.rules b/sci-geosciences/gpsd/files/99-gpsd-usb.rules
new file mode 100644
index 000000000000..592b509314b8
--- /dev/null
+++ b/sci-geosciences/gpsd/files/99-gpsd-usb.rules
@@ -0,0 +1,9 @@
+# udev rules for the gpsd USB hotplugging (without hotplug)
+
+SUBSYSTEM!="tty", GOTO="gpsd-usb_rules_end"
+ACTION!="add", GOTO="gpsd-usb_rules_end"
+
+KERNEL=="ttyUSB[0-9]*", SYMLINK="gps%n", RUN+="/etc/hotplug/usb/gpsd.hotplug add $root/%k"
+
+LABEL="gpsd-usb_rules_end"
+
diff --git a/sci-geosciences/gpsd/files/gpsd.conf b/sci-geosciences/gpsd/files/gpsd.conf
index b96b63aa10d8..f9c7c4a2d763 100644
--- a/sci-geosciences/gpsd/files/gpsd.conf
+++ b/sci-geosciences/gpsd/files/gpsd.conf
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/files/gpsd.conf,v 1.5 2007/01/14 23:01:11 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/files/gpsd.conf,v 1.6 2008/02/23 20:03:59 nerdboy Exp $
# Config file for gpsd server
@@ -21,5 +21,8 @@
#GPS_DEV="/dev/ttyS0
+# Use the following for gpsd with ntp instead of the older one below
+#GPSD_OPTS="-n ${GPS_DEV}"
+
GPSD_OPTS="-P /var/run/gpsd.pid -f GPS0 -F /var/run/gpsd.sock"
diff --git a/sci-geosciences/gpsd/gpsd-2.32.ebuild b/sci-geosciences/gpsd/gpsd-2.32.ebuild
index 052a06a8741c..4963d948e335 100644
--- a/sci-geosciences/gpsd/gpsd-2.32.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.32.ebuild,v 1.4 2007/08/25 14:28:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.32.ebuild,v 1.5 2008/02/23 20:03:58 nerdboy Exp $
inherit eutils libtool distutils
@@ -41,7 +41,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
elibtoolize
}
@@ -55,8 +55,8 @@ src_compile() {
}
src_install() {
- cd ${S}
- make DESTDIR=${D} install
+
+ make DESTDIR="${D}" install
if use usb ; then
sed -i -e "s/gpsd.hotplug/gpsd/g" gpsd.hotplug gpsd.usermap
@@ -65,8 +65,8 @@ src_install() {
exeinto /etc/hotplug/usb
newexe gpsd.hotplug gpsd
else
- newconfd ${FILESDIR}/gpsd.conf gpsd
- newinitd ${FILESDIR}/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X ; then
insinto /etc/X11/app-defaults
@@ -77,7 +77,7 @@ src_install() {
diropts "-m0644"
exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
doexe gps.py gpsfake.py
- dodoc AUTHORS HACKING INSTALL README TODO ${FILESDIR}/40-usb-serial.rules
+ dodoc AUTHORS HACKING INSTALL README TODO "${FILESDIR}"/40-usb-serial.rules
}
pkg_postinst() {
diff --git a/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild b/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild
index 32c451a115a2..a99041c90854 100644
--- a/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild,v 1.3 2007/07/22 07:10:12 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild,v 1.4 2008/02/23 20:03:58 nerdboy Exp $
inherit eutils libtool distutils
@@ -41,10 +41,11 @@ DEPEND="${RDEPEND}
RESTRICT="test"
src_unpack() {
+
unpack ${A}
- epatch ${FILESDIR}/${P}-duplicate-device-add-hang.patch
- epatch ${FILESDIR}/${P}-hotplug-background-fix.patch
- cd ${S}
+ epatch "${FILESDIR}"/${P}-duplicate-device-add-hang.patch
+ epatch "${FILESDIR}"/${P}-hotplug-background-fix.patch
+ cd "${S}"
elibtoolize
}
@@ -70,8 +71,7 @@ src_compile() {
}
src_install() {
- cd ${S}
- make DESTDIR=${D} install
+ make DESTDIR="${D}" install
if use usb ; then
sed -i -e "s/gpsd.hotplug/gpsd/g" gpsd.hotplug gpsd.usermap
@@ -81,8 +81,8 @@ src_install() {
newexe gpsd.hotplug gpsd
keepdir /var/run/usb # needed for REMOVER
else
- newconfd ${FILESDIR}/gpsd.conf gpsd
- newinitd ${FILESDIR}/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X ; then
insinto /etc/X11/app-defaults
@@ -93,7 +93,7 @@ src_install() {
diropts "-m0644"
exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
doexe gps.py gpsfake.py
- dodoc AUTHORS HACKING INSTALL README TODO ${FILESDIR}/40-usb-serial.rules
+ dodoc AUTHORS HACKING INSTALL README TODO "${FILESDIR}"/40-usb-serial.rules
}
pkg_postinst() {
diff --git a/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild b/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
index 694b4c13c444..b7da424b212c 100644
--- a/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild,v 1.2 2007/07/22 07:10:12 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild,v 1.3 2008/02/23 20:03:58 nerdboy Exp $
inherit eutils autotools distutils
@@ -47,7 +47,7 @@ WANT_AUTOCONF=2.5
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
eautoreconf
}
@@ -81,8 +81,8 @@ src_compile() {
}
src_install() {
- cd ${S}
- make DESTDIR=${D} install
+
+ make DESTDIR="${D}" install
if use usb ; then
insinto /etc/hotplug/usb
@@ -91,8 +91,8 @@ src_install() {
doexe gpsd.hotplug
keepdir /var/run/usb # needed for REMOVER
else
- newconfd ${FILESDIR}/gpsd.conf gpsd
- newinitd ${FILESDIR}/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X ; then
@@ -109,7 +109,7 @@ src_install() {
doexe gps.py gpsfake.py gpspacket.so
fi
- dodoc AUTHORS COPYING INSTALL README TODO
+ dodoc AUTHORS INSTALL README TODO
# add missing include file (see bug #162361)
insinto /usr/include
diff --git a/sci-geosciences/gpsd/gpsd-2.36.ebuild b/sci-geosciences/gpsd/gpsd-2.36.ebuild
new file mode 100644
index 000000000000..07b4793976b8
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-2.36.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.36.ebuild,v 1.1 2008/02/23 20:03:58 nerdboy Exp $
+
+inherit eutils autotools distutils
+
+DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients."
+HOMEPAGE="http://gpsd.berlios.de/"
+SRC_URI="http://download.berlios.de/gpsd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="dbus italk itrax minimal ntp python usb X"
+# tnt support is broken in this version - add tntc back when fixed
+
+RDEPEND="X? (
+ x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libXp
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXpm
+ x11-libs/libXaw
+ virtual/motif
+ )
+ python? ( dev-lang/python )
+ app-text/xmlto
+ dev-libs/libxslt
+ sys-libs/ncurses
+ dbus? ( >=sys-apps/dbus-0.94
+ >=dev-libs/glib-2.6
+ dev-libs/dbus-glib )
+ ntp? ( net-misc/ntp )
+ usb? ( virtual/dev-manager )"
+
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/xproto
+ x11-proto/xextproto
+ )"
+
+RESTRICT="test"
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF=2.5
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+
+ local my_conf="--enable-shared --with-pic --enable-static \
+ --disable-garmin --disable-garmintxt"
+ # Garmin support is broken in this version
+
+ use python && distutils_python_version
+
+ if use ntp; then
+ my_conf="${my_conf} --enable-ntpshm --enable-pps"
+ else
+ my_conf="${my_conf} --disable-ntpshm --disable-pps"
+ fi
+
+ if use minimal; then
+ local max_clients="5"
+ local max_devices="1"
+ my_conf="${my_conf} --enable-squelch --disable-pps"
+ my_conf="${my_conf} --enable-max-clients=${max_clients} \
+ --enable-max-devices=${max_devices} \
+ --without-x"
+ else
+ my_conf="${my_conf} $(use_with X x)"
+ fi
+
+ econf ${my_conf} $(use_enable dbus) $(use_enable python) \
+ $(use_enable italk) $(use_enable itrax) \
+ || die "econf failed"
+ # Support for the TNT digital compass is currently broken
+ # $(use_enable tntc tnt)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install
+
+ if use usb ; then
+ insinto /etc/hotplug/usb
+ doins gpsd.usermap
+ exeinto /etc/hotplug/usb
+ doexe gpsd.hotplug
+ insinto /etc/udev/rules.d
+ doins "${FILESDIR}"/99-gpsd-usb.rules
+ keepdir /var/run/usb # needed for REMOVER
+ else
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
+ fi
+
+ if use X && ! use minimal ; then
+ insinto /etc/X11/app-defaults
+ newins xgps.ad Xgps
+ newins xgpsspeed.ad Xgpsspeed
+ fi
+
+ diropts "-m0644"
+ dobin logextract
+
+ if use python ; then
+ exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doexe gps.py gpsfake.py gpspacket.so
+ fi
+
+ dodoc AUTHORS INSTALL README TODO
+
+ # add missing include file (see bug #162361)
+ insinto /usr/include
+ doins gpsd_config.h
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "This version of gpsd has broken the support for the TNT compass"
+ einfo "so it is temporarily disabled. If you need it, stay with the"
+ einfo "previous version for now. The minimal flag now removes X and"
+ einfo "enables the embedded device (ie, small footprint) support, but"
+ einfo "you'll need to modify the ebuild if you need to change either"
+ einfo "the number of clients or the number of devices. Although pps"
+ einfo "is enabled, it still needs the correct kernel patches. All"
+ einfo "recent versions of udev (>=udev-115 or so) should have correct"
+ einfo "usb device detection and startup of gpsd (ie, without hotplug)."
+ einfo ""
+ einfo "Most GPS devices will require the corresponding kernel options"
+ einfo "to be enabled, such as USB_SERIAL_GARMIN, or a USB serial driver"
+ einfo "for an adapter such as those that come with Deluo GPS units (eg,"
+ einfo "USB_SERIAL_PL2303). Straight serial devices should always work,"
+ einfo "even without udev/hotplug support (assuming you have the serial"
+ einfo "drivers enabled for your hardware)."
+ einfo ""
+ einfo "Read the INSTALL doc for more information on supported hardware,"
+ einfo "and make sure udev has the right group permissions set on the"
+ einfo "tty devices if using USB (it should Do The Right Thing (TM))..."
+ einfo ""
+}