summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-12-24 22:01:41 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-12-24 22:01:41 +0000
commitb745242101ba1a3c02a94355a67c2c082e895a0e (patch)
tree8390fe86ce3ccdc3b45b02626f4661f5a9552fac /sci-geosciences
parentStable on ppc, x86. (diff)
downloadgentoo-2-b745242101ba1a3c02a94355a67c2c082e895a0e.tar.gz
gentoo-2-b745242101ba1a3c02a94355a67c2c082e895a0e.tar.bz2
gentoo-2-b745242101ba1a3c02a94355a67c2c082e895a0e.zip
more updates to latest version
(Portage version: 2.1.2_rc3-r2)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/ChangeLog5
-rw-r--r--sci-geosciences/grass/grass-6.2.0.ebuild107
2 files changed, 61 insertions, 51 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 0a212f2366ae..bfc3e912d504 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-geosciences/grass
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.28 2006/12/24 21:00:03 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.29 2006/12/24 22:01:41 nerdboy Exp $
+
+ 24 Dec 2006; Steve Arnold <nerdboy@gentoo.org> grass-6.2.0.ebuild:
+ more updates to latest version (based on user feedback in bug below).
24 Dec 2006; Steve Arnold <nerdboy@gentoo.org> +grass-6.0.1.ebuild,
-grass-6.0.2.ebuild:
diff --git a/sci-geosciences/grass/grass-6.2.0.ebuild b/sci-geosciences/grass/grass-6.2.0.ebuild
index 8946f354b25b..24e5cde142b6 100644
--- a/sci-geosciences/grass/grass-6.2.0.ebuild
+++ b/sci-geosciences/grass/grass-6.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.0.ebuild,v 1.1 2006/12/24 02:14:55 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.0.ebuild,v 1.2 2006/12/24 22:01:41 nerdboy Exp $
inherit eutils autotools
@@ -13,7 +13,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
# To-do: get ppc64 gdal deps fixed up
-IUSE="ffmpeg fftw glw gmath jpeg largefile motif mysql ncurses nls odbc opengl png postgres proj readline sqlite tcl tk tiff truetype X"
+IUSE="ffmpeg fftw glw gmath jpeg largefile motif mysql nls odbc opengl png
+postgres python readline sqlite tcl tk tiff truetype"
RESTRICT="nostrip"
@@ -21,33 +22,34 @@ RDEPEND=">=sys-devel/make-3.80
>=sys-libs/zlib-1.1.4
>=sys-devel/flex-2.5.4a
>=sys-devel/bison-1.35
+ >=sys-libs/ncurses-5.3
>=sys-libs/gdbm-1.8.0
>=sys-devel/gcc-3.2.2
- sys-apps/man
+ || (
+ sys-apps/man
+ sys-apps/man-db )
sci-libs/gdal
>=sci-libs/proj-4.4.7
ffmpeg? ( media-video/ffmpeg )
- fftw? ( =sci-libs/fftw-2* )
+ fftw? ( sci-libs/fftw )
gmath? ( virtual/blas
virtual/lapack )
jpeg? ( media-libs/jpeg )
motif? ( x11-libs/openmotif )
- mysql? ( virtual/mysql )
- ncurses? ( >=sys-libs/ncurses-5.3 )
- nls? ( x11-terms/mlterm )
+ mysql? ( dev-db/mysql )
odbc? ( >=dev-db/unixODBC-2.0.6 )
opengl? ( ( virtual/opengl )
glw? ( media-libs/mesa ) )
png? ( >=media-libs/libpng-1.2.2 )
postgres? ( >=dev-db/postgresql-7.3 )
- proj? ( sci-libs/proj )
+ python? ( dev-lang/python )
readline? ( sys-libs/readline )
sqlite? ( dev-db/sqlite )
- tcl? ( >=dev-lang/tcl-8.3 )
- tk? ( >=dev-lang/tk-8.3 )
+ tcl? ( >=dev-lang/tcl-8.4 )
+ tk? ( >=dev-lang/tk-8.4 )
tiff? ( >=media-libs/tiff-3.5.7 )
truetype? ( >=media-libs/freetype-2.0 )
- X? ( || (
+ || (
( x11-libs/libXmu
x11-libs/libXext
x11-libs/libXp
@@ -57,46 +59,59 @@ RDEPEND=">=sys-devel/make-3.80
x11-libs/libICE
x11-libs/libXpm
x11-libs/libXaw )
- virtual/x11 )
- )"
+ virtual/x11 )"
DEPEND="${RDEPEND}
- X? ( || (
+ || (
( x11-proto/xproto x11-proto/xextproto )
- virtual/x11 )
- )"
+ virtual/x11 )"
src_unpack() {
- if use opengl && built_with_use dev-lang/tcl threads; then
+ if use glw && ! use opengl; then
+ ewarn "You set USE='glw -opengl'. GLw support needs OpenGL."
+ die "Set 'opengl' useflag!"
+ fi
+ if use glw && ! built_with_use media-libs/mesa motif; then
+ ewarn "GRASS OpenGL support needs mesa with motif headers."
+ ewarn "Please rebuild mesa with motif support."
+ die "re-emerge mesa with motif"
+ fi
+
+ if use tcl && ! use tk; then
+ ewarn "You set USE='tcl -tk'. GRASS needs both tcl and tk."
+ die "Set 'tk' useflag!"
+ fi
+
+ if use tk && ! use tcl; then
+ ewarn "You set USE='-tcl tk'. GRASS needs both tcl and tk."
+ die "Set 'tcl' useflag!"
+ fi
+
+ if use tcl && built_with_use dev-lang/tcl threads; then
ewarn "GRASS nviz will not work with Tcl compiled with threads!"
ewarn "Please disable either opengl or tcl threads."
die "emerge TCL without threads"
fi
- if use opengl && built_with_use dev-lang/tk threads; then
+ if use tk && built_with_use dev-lang/tk threads; then
ewarn "GRASS nviz will not work with Tk compiled with threads!"
ewarn "Please disable either opengl or tk threads."
die "emerge tk without threads"
fi
- if use glw && ! built_with_use media-libs/mesa motif; then
- ewarn "GRASS OpenGL support needs mesa with motif headers."
- ewarn "Please rebuild mesa with motif support."
- die "emerge mesa with motif"
- fi
-
unpack ${A}
cd ${S}
epatch rpm/fedora/grass-readline.patch
-
elibtoolize
}
src_compile() {
local myconf
myconf="--prefix=/usr --with-cxx --enable-shared \
- --with-gdal=$(which gdal-config)"
+ --with-gdal=$(which gdal-config) --with-curses --with-proj \
+ --with-proj-includes=/usr/include --with-proj-libs=/usr/lib \
+ --with-proj-share=/usr/share/proj --with-x"
- if use tcl || use tk ; then
+ if use tcl || use tk; then
myconf="${myconf} --with-tcltk \
--with-tcltk-includes=/usr/include \
--with-tcltk-libs=/usr/$(get_libdir)/tcl8.4"
@@ -120,12 +135,6 @@ src_compile() {
myconf="${myconf} --without-mysql"
fi
- if use proj; then
- myconf="${myconf} --with-proj --with-proj-includes=/usr/include --with-proj-libs=/usr/lib --with-proj-share=/usr/share/proj"
- else
- myconf="${myconf} --without-proj"
- fi
-
if use opengl; then
myconf="${myconf} --with-opengl --with-opengl-libs=/usr/$(get_libdir)/opengl/xorg-x11/lib"
if use glw; then
@@ -142,23 +151,21 @@ src_compile() {
export LD_LIBRARY_PATH="/${WORKDIR}/image/usr/${P}/$(get_libdir):${LD_LIBRARY_PATH}"
econf ${myconf} \
- `use_enable amd64 64bit` \
- `use_with ncurses curses` \
- `use_with fftw` \
- `use_with gmath blas` \
- `use_with gmath lapack` \
- `use_with jpeg` \
- `use_enable largefile` \
- `use_with motif` \
- `use_with nls` \
- `use_with odbc` \
- `use_with png` \
- `use_with postgres` \
- `use_with readline` \
- `use_with tiff` \
- `use_with tcl tcltk` \
- `use_with tk tcltk` \
- `use_with X x` || die "Error: configure failed!"
+ $(use_enable amd64 64bit) \
+ $(use_with fftw) \
+ $(use_with gmath blas) \
+ $(use_with gmath lapack) \
+ $(use_with jpeg) \
+ $(use_enable largefile) \
+ $(use_with motif) \
+ $(use_with nls) \
+ $(use_with odbc) \
+ $(use_with png) \
+ $(use_with postgres) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with tiff) \
+ $(use_with tcl tcltk) || die "Error: configure failed!"
# patch missing math functions
sed -i 's:EXTRA_LIBS=:EXTRA_LIBS=-lm :g' ${S}/lib/gmath/Makefile
sed -i 's:EXTRA_LIBS = :EXTRA_LIBS = -lm :g' ${S}/lib/gis/Makefile