summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-09 10:05:05 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-09 10:05:05 +0000
commit6761c43cfbd4213ca225b5118cde5119eefdcdfa (patch)
treeea8ac8b23ef2b40b6e37197d9f05e97f0e957030 /sci-libs/alglib
parentRemove old. (diff)
downloadgentoo-2-6761c43cfbd4213ca225b5118cde5119eefdcdfa.tar.gz
gentoo-2-6761c43cfbd4213ca225b5118cde5119eefdcdfa.tar.bz2
gentoo-2-6761c43cfbd4213ca225b5118cde5119eefdcdfa.zip
sci-libs/alglib: Seperate test from build
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/alglib')
-rw-r--r--sci-libs/alglib/ChangeLog6
-rw-r--r--sci-libs/alglib/alglib-3.8.2.ebuild13
-rw-r--r--sci-libs/alglib/files/CMakeLists.txt-3.8.224
3 files changed, 26 insertions, 17 deletions
diff --git a/sci-libs/alglib/ChangeLog b/sci-libs/alglib/ChangeLog
index 736a68f37cb6..eef55a56cd68 100644
--- a/sci-libs/alglib/ChangeLog
+++ b/sci-libs/alglib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/alglib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/alglib/ChangeLog,v 1.2 2013/12/06 10:50:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/alglib/ChangeLog,v 1.3 2013/12/09 10:05:05 jlec Exp $
+
+ 09 Dec 2013; Justin Lecher <jlec@gentoo.org> alglib-3.8.2.ebuild,
+ files/CMakeLists.txt-3.8.2:
+ Seperate test from build
*alglib-3.8.2 (06 Dec 2013)
diff --git a/sci-libs/alglib/alglib-3.8.2.ebuild b/sci-libs/alglib/alglib-3.8.2.ebuild
index 67ebbfe740c2..74f3968808ff 100644
--- a/sci-libs/alglib/alglib-3.8.2.ebuild
+++ b/sci-libs/alglib/alglib-3.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/alglib/alglib-3.8.2.ebuild,v 1.1 2013/12/06 10:50:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/alglib/alglib-3.8.2.ebuild,v 1.2 2013/12/09 10:05:05 jlec Exp $
EAPI=5
@@ -13,11 +13,7 @@ SRC_URI="http://www.alglib.net/translator/re/${P}.cpp.tgz"
SLOT="0"
LICENSE="GPL-2+"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-"
+IUSE="test"
S="${WORKDIR}"/cpp/
@@ -25,3 +21,8 @@ src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt-${PV} CMakeLists.txt || die
cmake-utils_src_prepare
}
+
+src_configure() {
+ local mycmakeargs=( $(cmake-utils_use_build test) )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/alglib/files/CMakeLists.txt-3.8.2 b/sci-libs/alglib/files/CMakeLists.txt-3.8.2
index 0b1c5f51150d..483c63dc7f59 100644
--- a/sci-libs/alglib/files/CMakeLists.txt-3.8.2
+++ b/sci-libs/alglib/files/CMakeLists.txt-3.8.2
@@ -6,6 +6,8 @@ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/src)
SET(VERSION 3.8.2)
SET(SOVERSION 3.8)
+option(BUILD_TEST "Build tests" OFF)
+
FILE(GLOB ALGLIB_SRC_LIB "src/*.cpp")
FILE(GLOB ALGLIB_HDR_LIB "src/*.h")
@@ -17,16 +19,18 @@ SET_TARGET_PROPERTIES(alglib PROPERTIES
INSTALL(TARGETS alglib DESTINATION ${CMAKE_INSTALL_LIBDIR}/)
INSTALL(FILES ${ALGLIB_HDR_LIB} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-#===========================================================
-ADD_EXECUTABLE(test_c tests/test_c.cpp)
-TARGET_LINK_LIBRARIES(test_c alglib)
-#INSTALL(TARGETS test_c DESTINATION ${CMAKE_INSTALL_BINDIR}/)
-#===========================================================
-ADD_EXECUTABLE(test_i tests/test_i.cpp)
-TARGET_LINK_LIBRARIES(test_i alglib)
-#INSTALL(TARGETS test_i DESTINATION ${CMAKE_INSTALL_BINDIR}/)
-#===========================================================
+if (BUILD_TEST)
+ #===========================================================
+ ADD_EXECUTABLE(test_c tests/test_c.cpp)
+ TARGET_LINK_LIBRARIES(test_c alglib)
+ #INSTALL(TARGETS test_c DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+ #===========================================================
+ ADD_EXECUTABLE(test_i tests/test_i.cpp)
+ TARGET_LINK_LIBRARIES(test_i alglib)
+ #INSTALL(TARGETS test_i DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+ #===========================================================
-enable_testing()
+ enable_testing()
+endif (BUILD_TEST)
add_test( test_c ${CMAKE_BUILD_DIR}/test_c)
add_test( test_i ${CMAKE_BUILD_DIR}/test_i)