summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-10-23 18:42:08 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-10-23 18:42:08 +0000
commit9d1f286e2cb8d3ad4825972159f1c3381a168f2a (patch)
tree05a71c1a7f3d64f1bd434a0a92db76168bd1496e /sci-libs/cminpack
parentVersion bump (diff)
downloadgentoo-2-9d1f286e2cb8d3ad4825972159f1c3381a168f2a.tar.gz
gentoo-2-9d1f286e2cb8d3ad4825972159f1c3381a168f2a.tar.bz2
gentoo-2-9d1f286e2cb8d3ad4825972159f1c3381a168f2a.zip
Version bump
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/cminpack')
-rw-r--r--sci-libs/cminpack/ChangeLog8
-rw-r--r--sci-libs/cminpack/cminpack-1.3.1.ebuild32
-rw-r--r--sci-libs/cminpack/metadata.xml4
3 files changed, 41 insertions, 3 deletions
diff --git a/sci-libs/cminpack/ChangeLog b/sci-libs/cminpack/ChangeLog
index 706fe250de7d..36532e45f6af 100644
--- a/sci-libs/cminpack/ChangeLog
+++ b/sci-libs/cminpack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/cminpack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cminpack/ChangeLog,v 1.7 2013/02/05 18:38:50 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cminpack/ChangeLog,v 1.8 2013/10/23 18:42:08 bicatali Exp $
+
+*cminpack-1.3.1 (23 Oct 2013)
+
+ 23 Oct 2013; Sébastien Fabbro <bicatali@gentoo.org> +cminpack-1.3.1.ebuild,
+ metadata.xml:
+ Version bump
05 Feb 2013; Ulrich Müller <ulm@gentoo.org> cminpack-1.3.0.ebuild:
Specify LICENSE more precisely, see CopyrightMINPACK.txt, bug 455574.
diff --git a/sci-libs/cminpack/cminpack-1.3.1.ebuild b/sci-libs/cminpack/cminpack-1.3.1.ebuild
new file mode 100644
index 000000000000..26056062d1aa
--- /dev/null
+++ b/sci-libs/cminpack/cminpack-1.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cminpack/cminpack-1.3.1.ebuild,v 1.1 2013/10/23 18:42:08 bicatali Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C implementation of the MINPACK nonlinear optimization library"
+HOMEPAGE="http://devernay.free.fr/hacks/cminpack/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="minpack"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.2-underlinking.patch )
+
+src_configure() {
+ local mycmakeargs+=(
+ -DSHARED_LIBS=ON
+ $(cmake-utils_use_build test examples)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc readme*
+ use doc && dohtml -A .txt doc/*
+}
diff --git a/sci-libs/cminpack/metadata.xml b/sci-libs/cminpack/metadata.xml
index 243b487434c9..7f432fd0dc55 100644
--- a/sci-libs/cminpack/metadata.xml
+++ b/sci-libs/cminpack/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+<herd>sci</herd>
+<longdescription lang="en">
Minpack includes software for solving nonlinear equations and
nonlinear least squares problems. Five algorithmic paths each
include a core subroutine and an easy-to-use driver. The algorithms