summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-25 17:48:26 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-25 17:48:26 +0000
commit781bf666aacd2de507cc57f8213066bc91d71674 (patch)
tree5fe20f50e0699c8e3eb9b8d38d5eb0783d7982a9 /sci-libs/fftw
parentVersion bump. (diff)
downloadgentoo-2-781bf666aacd2de507cc57f8213066bc91d71674.tar.gz
gentoo-2-781bf666aacd2de507cc57f8213066bc91d71674.tar.bz2
gentoo-2-781bf666aacd2de507cc57f8213066bc91d71674.zip
sci-libs/fftw: -v
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/fftw-2.1.5-r5.ebuild6
-rw-r--r--sci-libs/fftw/metadata.xml18
2 files changed, 12 insertions, 12 deletions
diff --git a/sci-libs/fftw/fftw-2.1.5-r5.ebuild b/sci-libs/fftw/fftw-2.1.5-r5.ebuild
index 9e96c85e26c0..4bc0092f512f 100644
--- a/sci-libs/fftw/fftw-2.1.5-r5.ebuild
+++ b/sci-libs/fftw/fftw-2.1.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r5.ebuild,v 1.23 2011/06/24 10:58:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r5.ebuild,v 1.24 2012/04/25 17:48:26 jlec Exp $
inherit autotools eutils flag-o-matic fortran-2 toolchain-funcs
@@ -90,11 +90,11 @@ src_compile() {
--without-openmp"
fi
cd "${S}-single"
- econf ${myconf} --enable-float || die "econf for float failed"
+ econf ${myconf} --enable-float
emake || die "emake for float failed"
cd "${S}-double"
- econf ${myconf} || die "econf for double failed"
+ econf ${myconf}
emake || die "emake for double failed"
}
diff --git a/sci-libs/fftw/metadata.xml b/sci-libs/fftw/metadata.xml
index adf47d40fd4c..e6d20c6a3cd5 100644
--- a/sci-libs/fftw/metadata.xml
+++ b/sci-libs/fftw/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
The Fastest Fourier Transform in the West is a C subroutine library
for computing the Discrete Fourier Transform (DFT) in one or more
dimensions, of both real and complex data, and of arbitrary input
@@ -11,12 +11,12 @@
that FFTW's performance is typically superior to that of other
publicly available FFT software.
</longdescription>
-<use>
- <flag name='avx'>Adds support for Advanced Vector Extensions</flag>
- <flag name='float'>Link default library to single precision instead of
+ <use>
+ <flag name="avx">Adds support for Advanced Vector Extensions</flag>
+ <flag name="float">Link default library to single precision instead of
double (symlinks only and fftw-2.1)</flag>
- <flag name='paired-single'>Adds support for pair-single optimizations of mips</flag>
- <flag name='quad'>Build quadruple precision lib</flag>
- <flag name='zbus'>Adds support for ZBus cycle-counter of mips</flag>
-</use>
+ <flag name="paired-single">Adds support for pair-single optimizations of mips</flag>
+ <flag name="quad">Build quadruple precision lib</flag>
+ <flag name="zbus">Adds support for ZBus cycle-counter of mips</flag>
+ </use>
</pkgmetadata>