summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2005-10-25 07:22:14 +0000
committerSteve Arnold <nerdboy@gentoo.org>2005-10-25 07:22:14 +0000
commite9c5111bc226ee685b21bef524eb260ebdc7b2ac (patch)
treeaa0e1cea3850e53179957e55682f45ae1ff3098f /sci-libs/gdal/gdal-1.2.6-r4.ebuild
parent0.12.0-r1 stable on x86. Removed 0.12.0. (diff)
downloadgentoo-2-e9c5111bc226ee685b21bef524eb260ebdc7b2ac.tar.gz
gentoo-2-e9c5111bc226ee685b21bef524eb260ebdc7b2ac.tar.bz2
gentoo-2-e9c5111bc226ee685b21bef524eb260ebdc7b2ac.zip
removed grass deps and added new version
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'sci-libs/gdal/gdal-1.2.6-r4.ebuild')
-rw-r--r--sci-libs/gdal/gdal-1.2.6-r4.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/sci-libs/gdal/gdal-1.2.6-r4.ebuild b/sci-libs/gdal/gdal-1.2.6-r4.ebuild
index e10a6262f69a..5df373437d61 100644
--- a/sci-libs/gdal/gdal-1.2.6-r4.ebuild
+++ b/sci-libs/gdal/gdal-1.2.6-r4.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r4.ebuild,v 1.2 2005/10/13 06:46:23 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r4.ebuild,v 1.3 2005/10/25 07:22:14 nerdboy Exp $
inherit eutils libtool gnuconfig distutils
-IUSE="jpeg png geos gif grass jasper netcdf hdf python postgres mysql \
- odbc sqlite ogdi fits gml doc debug"
+IUSE="jpeg png geos gif jasper netcdf hdf python postgres mysql sqlite \
+ odbc ogdi fits gml doc debug"
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
HOMEPAGE="http://www.remotesensing.org/gdal/index.html"
@@ -21,7 +21,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
>=media-libs/tiff-3.7.0
sci-libs/libgeotiff
jpeg? ( media-libs/jpeg )
- gif? ( media-libs/giflib )
+ gif? ( media-libs/libungif )
png? ( media-libs/libpng )
python? ( dev-lang/python )
fits? ( sci-libs/cfitsio )
@@ -38,7 +38,6 @@ DEPEND=">=sys-libs/zlib-1.1.4
jasper? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
- grass? ( >=sci-geosciences/grass-6.0.0 )
sqlite? ( dev-db/sqlite )
doc? ( app-doc/doxygen )"
@@ -86,12 +85,6 @@ src_compile() {
export CFG=debug
fi
- # Enable newer Grass support only
- if useq grass ; then
- use_conf="--with-grass=/usr/grass60 ${use_conf}"
- use_conf="--with-libgrass=no ${use_conf}"
- fi
-
if useq python ; then
use_conf="--with-pymoddir=/usr/${get_libdir}/python${PYVER}/site-packages \
${use_conf}"
@@ -124,7 +117,8 @@ pkg_postinst() {
einfo "GDAL is most useful with full graphics support enabled via various"
einfo "USE flags: png, jpeg, gif, jasper, etc. Also python, fits, ogdi,"
einfo "geos, and support for either netcdf or HDF4 is available, as well as"
- einfo "grass, and mysql, sqlite, or postgres (grass support requires grass 6)."
+ einfo "grass, and mysql, sqlite, or postgres (grass support requires newer"
+ einfo "gdal and gdal-grass)."
ewarn
einfo "Note: tiff and geotiff are now hard depends, so no USE flags."
einfo "Also, this package will check for netcdf before hdf, so if you"