summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-07-26 16:21:29 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-07-26 16:21:29 +0000
commit59ee633edf7d8c901cc0bc5a72424af859473495 (patch)
tree7b3021996ab63e881678fe46cdefcefc872f456c /sci-libs/gdal
parentFix the gtk patch, add patch for sandbox violation during install, enforce no... (diff)
downloadgentoo-2-59ee633edf7d8c901cc0bc5a72424af859473495.tar.gz
gentoo-2-59ee633edf7d8c901cc0bc5a72424af859473495.tar.bz2
gentoo-2-59ee633edf7d8c901cc0bc5a72424af859473495.zip
Added python_mod_cleanup in pkg_postrm
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog5
-rw-r--r--sci-libs/gdal/gdal-1.8.1.ebuild8
2 files changed, 11 insertions, 2 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 45c848cdca11..9a895f6a2790 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.117 2011/07/25 17:12:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.118 2011/07/26 16:21:29 neurogeek Exp $
+
+ 26 Jul 2011; Jesus Rivero <neurogeek@gentoo.org> gdal-1.8.1.ebuild:
+ Added python_mod_cleanup in pkg_postrm
25 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org> gdal-1.8.1.ebuild:
Shutup python warning. Fixes bug #376295.
diff --git a/sci-libs/gdal/gdal-1.8.1.ebuild b/sci-libs/gdal/gdal-1.8.1.ebuild
index f591e4e75469..8275c43e612e 100644
--- a/sci-libs/gdal/gdal-1.8.1.ebuild
+++ b/sci-libs/gdal/gdal-1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.8.1.ebuild,v 1.2 2011/07/25 17:12:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.8.1.ebuild,v 1.3 2011/07/26 16:21:29 neurogeek Exp $
EAPI=2
@@ -256,3 +256,9 @@ pkg_postinst() {
elog "Check available image and data formats after building with"
elog "gdalinfo and ogrinfo (using the --formats switch)."
}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup ${PN}.py ogr.py
+ fi
+}