summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-27 07:49:48 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-27 07:49:48 +0000
commit791728a4d2ed57362f3457e67fc5ca068a8c0536 (patch)
treec5bfa8b2d20535d4a3d3774fee30913992090b64 /sci-libs/gdal
parentDepend on media-libs/alsa-lib (bug #414827) (diff)
downloadgentoo-2-791728a4d2ed57362f3457e67fc5ca068a8c0536.tar.gz
gentoo-2-791728a4d2ed57362f3457e67fc5ca068a8c0536.tar.bz2
gentoo-2-791728a4d2ed57362f3457e67fc5ca068a8c0536.zip
Fix configure failure when building with -python. thanks to Nikoli for spotting.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog6
-rw-r--r--sci-libs/gdal/gdal-1.9.1.ebuild9
2 files changed, 12 insertions, 3 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index b281999f0580..ea951c3fa351 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.127 2012/05/26 07:13:27 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.128 2012/05/27 07:49:48 scarabeus Exp $
+
+ 27 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> gdal-1.9.1.ebuild:
+ Fix configure failure when building with -python. thanks to Nikoli for
+ spotting.
26 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> gdal-1.9.1.ebuild:
Do not use ruby eclass as we can build only against one implementation anyway.
diff --git a/sci-libs/gdal/gdal-1.9.1.ebuild b/sci-libs/gdal/gdal-1.9.1.ebuild
index f8a7e9b82eac..2e0daf6d6ce4 100644
--- a/sci-libs/gdal/gdal-1.9.1.ebuild
+++ b/sci-libs/gdal/gdal-1.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.9.1.ebuild,v 1.3 2012/05/26 07:13:27 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.9.1.ebuild,v 1.4 2012/05/27 07:49:48 scarabeus Exp $
EAPI=4
@@ -135,6 +135,12 @@ src_configure() {
echo "Ruby module dir is: $RUBY_MOD_DIR"
fi
+ if use python; then
+ myopts+="
+ --with-pymoddir="${EPREFIX}"/$(python_get_sitedir)
+ "
+ fi
+
if use java; then
myopts+="
--with-java=$(java-config --jdk-home 2>/dev/null)
@@ -209,7 +215,6 @@ src_configure() {
$(use_with python) \
$(use_with threads) \
$(use_with xls freexl) \
- --with-pymoddir="${EPREFIX}"/$(python_get_sitedir) \
${myopts}
# mysql-config puts this in (and boy is it a PITA to get it out)