summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-25 18:54:00 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-25 18:54:00 +0000
commitc0744a7b55ddf9b1f9aeb2581f5a9b86d158d2a1 (patch)
treed47590d73bb33f7b987545ae717b72e0dc92ec7a /sci-libs/gdal
parentRemove old. (diff)
downloadgentoo-2-c0744a7b55ddf9b1f9aeb2581f5a9b86d158d2a1.tar.gz
gentoo-2-c0744a7b55ddf9b1f9aeb2581f5a9b86d158d2a1.tar.bz2
gentoo-2-c0744a7b55ddf9b1f9aeb2581f5a9b86d158d2a1.zip
Version bump to 1.9.1. Fixes bug#396121 and bug#395273.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog9
-rw-r--r--sci-libs/gdal/files/gdal-1.9.1-opencl.patch27
-rw-r--r--sci-libs/gdal/files/gdal-1.9.1-ruby-makefile.patch43
-rw-r--r--sci-libs/gdal/gdal-1.9.1.ebuild309
-rw-r--r--sci-libs/gdal/metadata.xml23
5 files changed, 398 insertions, 13 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 0b1f2c95c29f..76d8002604c1 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.124 2012/05/24 19:20:51 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.125 2012/05/25 18:54:00 scarabeus Exp $
+
+*gdal-1.9.1 (25 May 2012)
+
+ 25 May 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/gdal-1.9.1-opencl.patch, +files/gdal-1.9.1-ruby-makefile.patch,
+ +gdal-1.9.1.ebuild, metadata.xml:
+ Version bump to 1.9.1. Fixes bug#396121 and bug#395273.
24 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> gdal-1.8.1-r1.ebuild:
Stable on amd64, x86 and ppc. Wrt bug#413835.
diff --git a/sci-libs/gdal/files/gdal-1.9.1-opencl.patch b/sci-libs/gdal/files/gdal-1.9.1-opencl.patch
new file mode 100644
index 000000000000..f5377844683e
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.9.1-opencl.patch
@@ -0,0 +1,27 @@
+diff -ur gdal-1.9.0b1_orig/alg/gdalwarpkernel_opencl.c gdal-1.9.0b1/alg/gdalwarpkernel_opencl.c
+--- gdal-1.9.0b1_orig/alg/gdalwarpkernel_opencl.c 2011-12-20 02:18:27.000000000 +0100
++++ gdal-1.9.0b1/alg/gdalwarpkernel_opencl.c 2011-12-26 19:28:04.564576034 +0100
+@@ -1409,20 +1409,9 @@
+ handleErr(err);
+ } else {
+ //Make a fake image so we don't have a NULL pointer
+- if (warper->bIsATI)
+- {
+- /* The code in the else clause generates a CL_INVALID_IMAGE_SIZE with ATI SDK 2.2 */
+- /* while theoretically correct and working on other SDKs. The following is a */
+- /* workaround */
+- char dummyImageData[16];
+- (*srcImag) = clCreateImage2D(warper->context, CL_MEM_READ_ONLY | CL_MEM_COPY_HOST_PTR, &imgFmt,
+- 1, 1, sz, dummyImageData, &err);
+- }
+- else
+- {
+- (*srcImag) = clCreateImage2D(warper->context, CL_MEM_READ_ONLY, &imgFmt,
+- 1, 1, sz, NULL, &err);
+- }
++ char dummyImageData[16];
++ (*srcImag) = clCreateImage2D(warper->context, CL_MEM_READ_ONLY | CL_MEM_COPY_HOST_PTR, &imgFmt,
++ 1, 1, sz, dummyImageData, &err);
+ handleErr(err);
+ }
+
diff --git a/sci-libs/gdal/files/gdal-1.9.1-ruby-makefile.patch b/sci-libs/gdal/files/gdal-1.9.1-ruby-makefile.patch
new file mode 100644
index 000000000000..b98f68403526
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.9.1-ruby-makefile.patch
@@ -0,0 +1,43 @@
+diff -urN gdal-1.9.1.old//swig/ruby/RubyMakefile.mk gdal-1.9.1/swig/ruby/RubyMakefile.mk
+--- gdal-1.9.1.old//swig/ruby/RubyMakefile.mk 2012-05-25 19:54:12.073974979 +0200
++++ gdal-1.9.1/swig/ruby/RubyMakefile.mk 2012-05-25 19:56:56.014977833 +0200
+@@ -37,13 +37,13 @@
+
+ ifeq ("$(shell uname -s)", "Darwin")
+ RUBY_MODULES=$(RUBY_MODULES_MAC)
+-LDFLAGS += -Xcompiler -bundle -L$(RUBY_LIB_DIR)
+-RUBY_LIB := -l$(RUBY_SO_NAME)
+ else
+ RUBY_MODULES=$(RUBY_MODULES_LIN)
+-LDFLAGS += -Xcompiler -shared -L$(RUBY_LIB_DIR)
+-RUBY_LIB := -l$(RUBY_SO_NAME)
+ endif
++LDFLAGS += -fPIC -DPIC -shared -L$(RUBY_LIB_DIR)
++CFLAGS += -fPIC -DPIC
++CXXFLAGS += -fPIC -DPIC
++RUBY_LIB := -l$(RUBY_SO_NAME)
+
+ build: $(RUBY_MODULES)
+
+@@ -59,7 +59,7 @@
+ $(INSTALL_DIR):
+ mkdir -p $(DESTDIR)$(INSTALL_DIR)
+
+-install: $(INSTALL_DIR)
++install: $(INSTALL_DIR) $(RUBY_MODULES)
+ for i in $(RUBY_MODULES) ; do $(INSTALL) $$i $(DESTDIR)$(INSTALL_DIR) ; done
+
+ $(RUBY_MODULES_MAC): %.bundle: %_wrap.o
+@@ -69,10 +69,10 @@
+ $(LD) $(LDFLAGS) $(LIBS) $(GDAL_SLIB_LINK) $(RUBY_LIB) $< -o $@
+
+ %.o: %.cpp
+- $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
++ $(CXX) $(CXXFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
+
+ %.o: %.cxx
+- $(CXX) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
++ $(CXX) $(CXXFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(GDAL_INCLUDE) $(RUBY_INCLUDE) -c $<
diff --git a/sci-libs/gdal/gdal-1.9.1.ebuild b/sci-libs/gdal/gdal-1.9.1.ebuild
new file mode 100644
index 000000000000..7311210f2267
--- /dev/null
+++ b/sci-libs/gdal/gdal-1.9.1.ebuild
@@ -0,0 +1,309 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.9.1.ebuild,v 1.1 2012/05/25 18:54:00 scarabeus Exp $
+
+EAPI=3
+
+WANT_AUTOCONF="2.5"
+
+RUBY_OPTIONAL="yes"
+USE_RUBY="ruby18 ruby19"
+
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit autotools eutils libtool perl-module python ruby-ng toolchain-funcs java-pkg-opt-2
+
+DESCRIPTION="Translator library for raster geospatial data formats (includes OGR support)"
+HOMEPAGE="http://www.gdal.org/"
+SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="armadillo +aux_xml curl debug doc ecwj2k fits geos gif gml hdf5 java jpeg jpeg2k mdb mysql netcdf odbc opencl ogdi pdf perl png postgres python ruby spatialite sqlite threads xls"
+
+RDEPEND="
+ dev-libs/expat
+ media-libs/tiff
+ sci-libs/libgeotiff
+ ( || ( <sys-libs/zlib-1.2.5.1-r1 >=sys-libs/zlib-1.2.5.1-r2[minizip] ) )
+ armadillo? ( >=sci-libs/armadillo-3.0.2 )
+ curl? ( net-misc/curl )
+ ecwj2k? ( sci-libs/libecwj2 )
+ fits? ( sci-libs/cfitsio )
+ geos? ( >=sci-libs/geos-2.2.1 )
+ gif? ( media-libs/giflib )
+ gml? ( >=dev-libs/xerces-c-3 )
+ hdf5? ( >=sci-libs/hdf5-1.6.4[szip] )
+ java? ( >=virtual/jre-1.6 )
+ jpeg? ( virtual/jpeg )
+ jpeg2k? ( media-libs/jasper )
+ mysql? ( virtual/mysql )
+ netcdf? ( sci-libs/netcdf )
+ odbc? ( dev-db/unixODBC )
+ ogdi? ( sci-libs/ogdi )
+ opencl? ( virtual/opencl )
+ pdf? (
+ app-text/podofo
+ app-text/poppler
+ )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng )
+ postgres? ( >=dev-db/postgresql-base-8.4 )
+ python? ( dev-python/numpy )
+ ruby? ( $(ruby_implementation_depend ruby18) )
+ sqlite? ( dev-db/sqlite:3 )
+ spatialite? (
+ dev-db/spatialite
+ dev-db/sqlite:3
+ )
+ xls? ( dev-libs/freexl )
+"
+
+SWIG_DEP=">=dev-lang/swig-2.0.2"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ java? ( >=virtual/jdk-1.6 )
+ perl? ( ${SWIG_DEP} )
+ python? ( ${SWIG_DEP} )
+ ruby? ( ${SWIG_DEP} )"
+
+AT_M4DIR="${S}/m4"
+MAKEOPTS+=" -j1"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ # prevent ruby-ng.eclass from messing with the src path
+ default
+}
+
+src_prepare() {
+ # fix datadir and docdir placement
+ sed -i \
+ -e "s:@datadir@:@datadir@/gdal:" \
+ -e "s:@exec_prefix@/doc:@exec_prefix@/share/doc/${PF}/html:g" \
+ "${S}"/GDALmake.opt.in || die
+
+ # the second sed expression should fix bug 371075
+ sed -i \
+ -e "s:setup.py install:setup.py install --root=\$(DESTDIR):" \
+ -e "s:--prefix=\$(DESTDIR):--prefix=:" \
+ "${S}"/swig/python/GNUmakefile || die
+
+ epatch "${FILESDIR}"/${PN}-1.9.1-ruby-makefile.patch
+
+ # Opencl seems broken with nvidia without this
+ epatch "${FILESDIR}"/${PN}-1.9.1-opencl.patch
+
+ # -soname is only accepted by GNU ld/ELF
+ [[ ${CHOST} == *-darwin* ]] \
+ && epatch "${FILESDIR}"/${PN}-1.5.0-install_name.patch \
+ || epatch "${FILESDIR}"/${PN}-1.5.0-soname.patch
+
+ # Update for zlib header changes (see bug #383569)
+ epatch "${FILESDIR}"/${PN}-1.8.1-zlib_header_fix.patch
+
+ # Fix spatialite/sqlite include issue
+ sed -i \
+ -e 's:spatialite/sqlite3.h:sqlite3.h:g' \
+ ogr/ogrsf_frmts/sqlite/ogr_sqlite.h || die
+
+ # Fix freexl configure check
+ sed -i \
+ -e 's:FREEXL_LIBS=missing):FREEXL_LIBS=missing,-lm):g' \
+ configure.in || die
+
+ # autoheader fail
+ eaclocal
+ eautoconf
+ eautomake
+ elibtoolize
+}
+
+src_configure() {
+ local myopts=""
+
+ if use ruby; then
+ RUBY_MOD_DIR="$(ruby18 -r rbconfig -e 'print Config::CONFIG["sitearchdir"]')"
+ echo "Ruby module dir is: $RUBY_MOD_DIR"
+ fi
+
+ if use java; then
+ myopts+="
+ --with-java=$(java-config --jdk-home 2>/dev/null)
+ $(use_with mdb)
+ "
+ else
+ myopts+=" --without-java --without-mdb"
+ use mdb && ewarn "mdb requires java use enabled. disabling"
+ fi
+
+ # pcidsk is internal, because there is no such library yet released
+ # also that thing is developed by the gdal people
+ # kakadu, mrsid jp2mrsid - another jpeg2k stuff, ignore
+ # bsb - legal issues
+ # oracle - disabled, i dont have and can't test
+ # ingres - same story as oracle oci
+ # podofo - we use poppler instead they are exclusive for each other
+ # tiff is a hard dep
+ econf \
+ --enable-shared \
+ --disable-static \
+ --with-expat \
+ --without-grass \
+ --without-hdf4 \
+ --without-fme \
+ --without-pcraster \
+ --without-kakadu \
+ --without-mrsid \
+ --without-jp2mrsid \
+ --without-msg \
+ --without-bsb \
+ --without-dods-root \
+ --without-oci \
+ --without-ingres \
+ --without-dwgdirect \
+ --without-epsilon \
+ --without-idb \
+ --without-podofo \
+ --without-sde \
+ --without-libtool \
+ --with-libz="${EPREFIX}/usr/" \
+ --with-ogr \
+ --with-grib \
+ --with-vfk \
+ --with-libtiff=external \
+ --with-geotiff=external \
+ $(use_enable debug) \
+ $(use_with armadillo) \
+ $(use_with postgres pg) \
+ $(use_with fits cfitsio) \
+ $(use_with netcdf) \
+ $(use_with png) \
+ $(use_with jpeg) \
+ $(use_with jpeg pcidsk) \
+ $(use_with gif) \
+ $(use_with hdf5) \
+ $(use_with jpeg2k jasper) \
+ $(use_with ecwj2k ecw) \
+ $(use_with gml xerces) \
+ $(use_with odbc) \
+ $(use_with ogdi ogdi "${EPREFIX}"/usr) \
+ $(use_with opencl) \
+ $(use_with curl) \
+ $(use_with sqlite sqlite3 "${EPREFIX}"/usr) \
+ $(use_with spatialite) \
+ $(use_with mysql mysql "${EPREFIX}"/usr/bin/mysql_config) \
+ $(use_with geos) \
+ $(use_with aux_xml pam) \
+ $(use_with pdf poppler) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with python) \
+ $(use_with threads) \
+ $(use_with xls freexl) \
+ --with-pymoddir="${EPREFIX}"/$(python_get_sitedir) \
+ ${myopts}
+
+ # mysql-config puts this in (and boy is it a PITA to get it out)
+ if use mysql; then
+ sed -i \
+ -e "s: -rdynamic : :" \
+ GDALmake.opt || die "sed LIBS failed"
+ fi
+
+ # updated for newer swig (must specify the path to input files)
+ if use python; then
+ sed -i \
+ -e "s: gdal_array.i: ../include/gdal_array.i:" \
+ -e "s:\$(DESTDIR)\$(prefix):\$(DESTDIR)\$(INST_PREFIX):g" \
+ swig/python/GNUmakefile || die "sed python makefile failed"
+ sed -i \
+ -e "s:library_dirs = :library_dirs = /usr/$(get_libdir):g" \
+ swig/python/setup.cfg || die "sed python setup.cfg failed"
+ fi
+}
+
+src_compile() {
+ local i
+ for i in perl ruby python; do
+ if use $i; then
+ rm "${S}"/swig/$i/*_wrap.cpp
+ emake -C "${S}"/swig/$i generate || \
+ die "make generate failed for swig/$i"
+ fi
+ done
+
+ emake || die "emake failed"
+
+ if use perl ; then
+ pushd "${S}"/swig/perl > /dev/null
+ perl-module_src_prep
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+
+ if use doc ; then
+ emake docs || die "make docs failed"
+ fi
+}
+
+src_install() {
+ if use perl ; then
+ pushd "${S}"/swig/perl > /dev/null
+ perl-module_src_install
+ popd > /dev/null
+ sed -i \
+ -e "s:BINDINGS = python ruby perl:BINDINGS = python ruby:g" \
+ GDALmake.opt || die
+ fi
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use ruby ; then
+ # weird reinstall collision; needs manual intervention...
+ pushd "${S}"/swig/ruby > /dev/null
+ rm -rf "${D}"${RUBY_MOD_DIR}/gdal
+ exeinto ${RUBY_MOD_DIR}/gdal
+ doexe *.so || die "doins ruby modules failed"
+ popd > /dev/null
+ fi
+
+ use perl && fixlocalpod
+
+ dodoc Doxyfile HOWTO-RELEASE NEWS || die
+
+ if use doc ; then
+ dohtml html/* || die "install html failed"
+ docinto ogr
+ dohtml ogr/html/* || die "install ogr html failed"
+ fi
+
+ if use python; then
+ newdoc swig/python/README.txt README-python.txt || die
+ insinto /usr/share/${PN}/samples
+ doins swig/python/samples/* || die
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_need_rebuild
+ python_mod_optimize osgeo
+ fi
+ echo
+ elog "Check available image and data formats after building with"
+ elog "gdalinfo and ogrinfo (using the --formats switch)."
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup osgeo
+ fi
+}
diff --git a/sci-libs/gdal/metadata.xml b/sci-libs/gdal/metadata.xml
index b89ac1d58457..b557c0354d3c 100644
--- a/sci-libs/gdal/metadata.xml
+++ b/sci-libs/gdal/metadata.xml
@@ -7,20 +7,19 @@
<name>Steve Arnold</name>
<description>Primary Maintainer</description>
</maintainer>
- <longdescription>GDAL is the Geospatial Data Abstraction Library, a set of tools for
- converting between geospatial raster data formats (includes OGR for vector data).</longdescription>
+ <longdescription>GDAL is the Geospatial Data Abstraction Library, a set of tools for converting between geospatial raster data formats (includes OGR for vector data).</longdescription>
<use>
+ <flag name="armadillo">Use <pkg>sci-libs/armadillo</pkg> for faster TPS transform computation</flag>
<flag name="aux_xml">Enable Portable Auxilliary Metadata generation</flag>
- <flag name="ecwj2k">Enable support for alternate jpeg2k library
- <pkg>sci-libs/libecwj2</pkg></flag>
- <flag name="fits">Enable support for NASA's <pkg>sci-libs/cfitsio</pkg>
- library</flag>
- <flag name="geos">Add support for geometry engine (<pkg>sci-libs/geos</pkg>
- </flag>
+ <flag name="ecwj2k">Enable support for alternate jpeg2k library <pkg>sci-libs/libecwj2</pkg></flag>
+ <flag name="fits">Enable support for NASA's <pkg>sci-libs/cfitsio</pkg> library</flag>
+ <flag name="geos">Add support for geometry engine (<pkg>sci-libs/geos</pkg></flag>
<flag name="gml">Enable support for <pkg>dev-libs/xerces-c</pkg> C++ API</flag>
- <flag name="hdf">Add support for the Hierarchical Data Format v. 4
- (<pkg>sci-libs/hdf</pkg>)</flag>
- <flag name="ogdi">Enable support for the open geographic datastore interface
- (<pkg>sci-libs/ogdi</pkg>)</flag>
+ <flag name="hdf">Add support for the Hierarchical Data Format v. 4 (<pkg>sci-libs/hdf</pkg>)</flag>
+ <flag name="mdb">Enable support for Microsoft Access database</flag>
+ <flag name="spatialite">Enable Spatial DBMS over sqlite <pkg>dev-db/spatialite</pkg></flag>
+ <flag name="opencl">Enable OpenCL support</flag>
+ <flag name="ogdi">Enable support for the open geographic datastore interface (<pkg>sci-libs/ogdi</pkg>)</flag>
+ <flag name="xls">Add the <pkg>dev-libs/freexl</pkg> library for xls import support</flag>
</use>
</pkgmetadata>