summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-26 07:13:27 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-26 07:13:27 +0000
commitd2b75651fbee90a37536a0e7146e335ef0eb9846 (patch)
treeb50f783829927e8d52f445f3c8638a0bc8db4138 /sci-libs/gdal
parentJust use ruby1.9, build system does not support multiple of those anyway. (diff)
downloadgentoo-2-d2b75651fbee90a37536a0e7146e335ef0eb9846.tar.gz
gentoo-2-d2b75651fbee90a37536a0e7146e335ef0eb9846.tar.bz2
gentoo-2-d2b75651fbee90a37536a0e7146e335ef0eb9846.zip
Do not use ruby eclass as we can build only against one implementation anyway.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog5
-rw-r--r--sci-libs/gdal/gdal-1.9.1.ebuild17
2 files changed, 13 insertions, 9 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 78c312d56b52..b281999f0580 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.126 2012/05/26 07:10:31 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.127 2012/05/26 07:13:27 scarabeus Exp $
+
+ 26 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> gdal-1.9.1.ebuild:
+ Do not use ruby eclass as we can build only against one implementation anyway.
26 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> gdal-1.9.1.ebuild:
Just use ruby1.9, build system does not support multiple of those anyway.
diff --git a/sci-libs/gdal/gdal-1.9.1.ebuild b/sci-libs/gdal/gdal-1.9.1.ebuild
index 03d317c4cd11..f8a7e9b82eac 100644
--- a/sci-libs/gdal/gdal-1.9.1.ebuild
+++ b/sci-libs/gdal/gdal-1.9.1.ebuild
@@ -1,17 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.9.1.ebuild,v 1.2 2012/05/26 07:10:31 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.9.1.ebuild,v 1.3 2012/05/26 07:13:27 scarabeus Exp $
-EAPI=3
+EAPI=4
WANT_AUTOCONF="2.5"
-RUBY_OPTIONAL="yes"
-USE_RUBY="ruby19"
-
PYTHON_DEPEND="python? 2:2.6"
-inherit autotools eutils libtool perl-module python ruby-ng toolchain-funcs java-pkg-opt-2
+inherit autotools eutils libtool perl-module python toolchain-funcs java-pkg-opt-2
DESCRIPTION="Translator library for raster geospatial data formats (includes OGR support)"
HOMEPAGE="http://www.gdal.org/"
@@ -51,11 +48,10 @@ RDEPEND="
png? ( media-libs/libpng )
postgres? ( >=dev-db/postgresql-base-8.4 )
python? ( dev-python/numpy )
- ruby? ( $(ruby_implementation_depend ruby18) )
+ ruby? ( dev-lang/ruby:1.9 )
sqlite? ( dev-db/sqlite:3 )
spatialite? (
dev-db/spatialite
- dev-db/sqlite:3
)
xls? ( dev-libs/freexl )
"
@@ -71,6 +67,11 @@ DEPEND="${RDEPEND}
AT_M4DIR="${S}/m4"
MAKEOPTS+=" -j1"
+REQUIRED_USE="
+ spatialite? ( sqlite )
+ mdb? ( java )
+"
+
pkg_setup() {
if use python; then
python_set_active_version 2