summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-08 10:32:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-08 10:32:13 +0000
commitffd06d26363b7e374743fb6765ab0afa41d0160e (patch)
tree2bf2382bcaa683fbf92f7cbae8a4274339105d3c /sci-libs/gdal
parentUpdate site-init file to use autoloads, bug 385167. Remove redundant src_test... (diff)
downloadgentoo-2-ffd06d26363b7e374743fb6765ab0afa41d0160e.tar.gz
gentoo-2-ffd06d26363b7e374743fb6765ab0afa41d0160e.tar.bz2
gentoo-2-ffd06d26363b7e374743fb6765ab0afa41d0160e.zip
Backport libpng15 compability patch from gdal-1.8 to gdal-1.6 wrt #386009
(Portage version: 2.2.0_alpha61/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog6
-rw-r--r--sci-libs/gdal/files/gdal-1.6.3-libpng15.patch40
-rw-r--r--sci-libs/gdal/gdal-1.6.3-r1.ebuild5
3 files changed, 48 insertions, 3 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 19703bf9e21f..769fbc35ef70 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.119 2011/09/26 03:33:45 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.120 2011/10/08 10:32:13 ssuominen Exp $
+
+ 08 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> gdal-1.6.3-r1.ebuild,
+ +files/gdal-1.6.3-libpng15.patch:
+ Backport libpng15 compability patch from gdal-1.8 to gdal-1.6 wrt #386009
*gdal-1.8.1-r1 (26 Sep 2011)
diff --git a/sci-libs/gdal/files/gdal-1.6.3-libpng15.patch b/sci-libs/gdal/files/gdal-1.6.3-libpng15.patch
new file mode 100644
index 000000000000..e0411a3ea696
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.6.3-libpng15.patch
@@ -0,0 +1,40 @@
+https://bugs.gentoo.org/386009
+
+--- frmts/png/pngdataset.cpp
++++ frmts/png/pngdataset.cpp
+@@ -1288,7 +1288,7 @@
+ * instead of an int, which is what fread() actually returns.
+ */
+ check = (png_size_t)VSIFReadL(data, (png_size_t)1, length,
+- (png_FILE_p)png_ptr->io_ptr);
++ (png_FILE_p)png_get_io_ptr(png_ptr));
+
+ if (check != length)
+ png_error(png_ptr, "Read Error");
+@@ -1303,7 +1303,7 @@
+ {
+ png_uint_32 check;
+
+- check = VSIFWriteL(data, 1, length, (png_FILE_p)(png_ptr->io_ptr));
++ check = VSIFWriteL(data, 1, length, (png_FILE_p)(png_get_io_ptr(png_ptr)));
+
+ if (check != length)
+ png_error(png_ptr, "Write Error");
+@@ -1314,7 +1314,7 @@
+ /************************************************************************/
+ static void png_vsi_flush(png_structp png_ptr)
+ {
+- VSIFFlushL( (png_FILE_p)(png_ptr->io_ptr) );
++ VSIFFlushL( (png_FILE_p)(png_get_io_ptr(png_ptr)) );
+ }
+
+ /************************************************************************/
+@@ -1330,7 +1330,7 @@
+ // libpng is generally not built as C++ and so won't honour unwind
+ // semantics. Ugg.
+
+- jmp_buf* psSetJmpContext = (jmp_buf*) png_ptr->error_ptr;
++ jmp_buf* psSetJmpContext = (jmp_buf*) png_get_error_ptr(png_ptr);
+ if (psSetJmpContext)
+ {
+ longjmp( *psSetJmpContext, 1 );
diff --git a/sci-libs/gdal/gdal-1.6.3-r1.ebuild b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
index 4d494b3ead42..e486f84521ed 100644
--- a/sci-libs/gdal/gdal-1.6.3-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.3-r1.ebuild,v 1.20 2011/07/16 17:45:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.3-r1.ebuild,v 1.21 2011/10/08 10:32:13 ssuominen Exp $
EAPI=3
@@ -81,7 +81,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.4.2-datadir.patch \
"${FILESDIR}"/${PN}-1.5.1-python-install.patch \
"${FILESDIR}"/${PN}-1.6.0-swig-fix.patch \
- "${FILESDIR}"/${PN}-1.6.1-ruby-make.patch
+ "${FILESDIR}"/${PN}-1.6.1-ruby-make.patch \
+ "${FILESDIR}"/${PN}-1.6.3-libpng15.patch
[[ ${CHOST} == *-darwin* ]] \
&& epatch "${FILESDIR}"/${PN}-1.5.0-install_name.patch \