summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-09-13 21:05:24 +0000
committerJustin Lecher <jlec@gentoo.org>2011-09-13 21:05:24 +0000
commit605ae23bc1b87819e7d3a1ec0b3c3d2fb775c435 (patch)
treef58134a244864e1c5135aadd4983df5230a9040b /sci-libs/getdata
parentBackport performance improvement from upstream to 4.6 (diff)
downloadgentoo-2-605ae23bc1b87819e7d3a1ec0b3c3d2fb775c435.tar.gz
gentoo-2-605ae23bc1b87819e7d3a1ec0b3c3d2fb775c435.tar.bz2
gentoo-2-605ae23bc1b87819e7d3a1ec0b3c3d2fb775c435.zip
Cleaned and enhanced ebuild
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/getdata')
-rw-r--r--sci-libs/getdata/ChangeLog8
-rw-r--r--sci-libs/getdata/getdata-0.6.3-r1.ebuild92
-rw-r--r--sci-libs/getdata/metadata.xml4
3 files changed, 103 insertions, 1 deletions
diff --git a/sci-libs/getdata/ChangeLog b/sci-libs/getdata/ChangeLog
index 00ec1198aa78..7962c51850b0 100644
--- a/sci-libs/getdata/ChangeLog
+++ b/sci-libs/getdata/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/getdata
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/ChangeLog,v 1.4 2011/09/13 19:54:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/ChangeLog,v 1.5 2011/09/13 21:05:24 jlec Exp $
+
+*getdata-0.6.3-r1 (13 Sep 2011)
+
+ 13 Sep 2011; Justin Lecher <jlec@gentoo.org> +getdata-0.6.3-r1.ebuild,
+ metadata.xml:
+ Cleaned and enhanced ebuild
13 Sep 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
sci takes maintainer ship
diff --git a/sci-libs/getdata/getdata-0.6.3-r1.ebuild b/sci-libs/getdata/getdata-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..1701235de76b
--- /dev/null
+++ b/sci-libs/getdata/getdata-0.6.3-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/getdata-0.6.3-r1.ebuild,v 1.1 2011/09/13 21:05:24 jlec Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+
+FORTRAN_STANDARD="95"
+
+inherit autotools fortran-2 python
+
+DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
+HOMEPAGE="http://getdata.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 fortran lzma python static-libs"
+
+DEPEND="
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ # Python bindings are built/tested/installed manually.
+ sed -e "/PY_SUBDIR/s/python//" -i bindings/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-idl \
+ --without-libslim \
+ --with-libz \
+ --enable-shared \
+ --docdir="${EPREFIX}/usr/share/doc/${P}" \
+ $(use_enable fortran) \
+ $(use_enable fortran fortran95) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use_with bzip2 libbz2) \
+ $(use_with lzma liblzma)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources bindings/python
+ building() {
+ sed "s:-lpython...:$(python_get_library --linker-option):g" -i Makefile || die
+ emake \
+ PYTHON_VERSION="$(python_get_version)" \
+ NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir bindings/python building
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_VERSION="$(python_get_version)" \
+ NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ if use static-libs; then
+ find "${ED}/$(python_get_sitedir)" -type f -name "*.a" -delete || die
+ fi
+ }
+ python_execute_function -s --source-dir bindings/python installation
+ python_clean_installation_image
+ fi
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "Installing docs failed"
+}
diff --git a/sci-libs/getdata/metadata.xml b/sci-libs/getdata/metadata.xml
index be3ea5eeb44f..7527ea188d26 100644
--- a/sci-libs/getdata/metadata.xml
+++ b/sci-libs/getdata/metadata.xml
@@ -6,4 +6,8 @@
<email>sci@gentoo.org</email>
</maintainer>
<longdescription lang="en"/>
+ <use>
+ <flag name="fortran">Build fortran bindings</flag>
+ <flag name="python">Build python bindings</flag>
+ </use>
</pkgmetadata>