summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-10-02 16:09:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-10-02 16:09:26 +0000
commita48bbba0b0090fbdb54779f73c1b792787c7f0e3 (patch)
treea60dfc3a62113cf04c4026295b2497099a74b129 /sci-libs/hdf5/hdf5-1.8.3-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-a48bbba0b0090fbdb54779f73c1b792787c7f0e3.tar.gz
gentoo-2-a48bbba0b0090fbdb54779f73c1b792787c7f0e3.tar.bz2
gentoo-2-a48bbba0b0090fbdb54779f73c1b792787c7f0e3.zip
Set CC=mpicc when building with mpi enabled (bug #286353), added --enabled-shared which was disabled with mpi enabled (bug #287124), and added slashes in destdir patch
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/hdf5/hdf5-1.8.3-r1.ebuild')
-rw-r--r--sci-libs/hdf5/hdf5-1.8.3-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sci-libs/hdf5/hdf5-1.8.3-r1.ebuild b/sci-libs/hdf5/hdf5-1.8.3-r1.ebuild
index 7d4f752b40b7..c8ab06a72696 100644
--- a/sci-libs/hdf5/hdf5-1.8.3-r1.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.3-r1.ebuild,v 1.3 2009/10/01 19:27:44 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.3-r1.ebuild,v 1.4 2009/10/02 16:09:26 bicatali Exp $
EAPI=2
inherit eutils autotools
@@ -27,12 +27,13 @@ DEPEND="${RDEPEND}
sys-process/time"
pkg_setup() {
- if use mpi && use cxx; then
- ewarn "Simultaneous mpi and cxx is not supported by ${PN}"
- ewarn "Will disable cxx interface"
- fi
- if use mpi && use fortran; then
- export FC=mpif90
+ if use mpi; then
+ if use cxx; then
+ ewarn "Simultaneous mpi and cxx is not supported by ${PN}"
+ ewarn "Will disable cxx interface"
+ fi
+ export CC=mpicc
+ use fortran && export FC=mpif90
fi
}
@@ -72,6 +73,7 @@ src_configure() {
--enable-production \
--enable-strict-format-checks \
--enable-deprecated-symbols \
+ --enable-shared \
$(use_enable fortran) \
$(use_enable mpi parallel) \
$(use_with szip szlib) \