summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-03-04 17:46:28 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-03-04 17:46:28 +0000
commit526881b1b703fa13b80178b847e9d4df41154ab4 (patch)
tree4b826967080ff5c02ace5ab56e052c966955b6e1 /sci-libs/indilib
parentDrop 4.0.2 and 4.0.4 as recent e-ids require later versions to be read/used (diff)
downloadgentoo-2-526881b1b703fa13b80178b847e9d4df41154ab4.tar.gz
gentoo-2-526881b1b703fa13b80178b847e9d4df41154ab4.tar.bz2
gentoo-2-526881b1b703fa13b80178b847e9d4df41154ab4.zip
Version bump.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'sci-libs/indilib')
-rw-r--r--sci-libs/indilib/ChangeLog9
-rw-r--r--sci-libs/indilib/indilib-1.0.0.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/sci-libs/indilib/ChangeLog b/sci-libs/indilib/ChangeLog
index edad4a16540e..4bffe642b60b 100644
--- a/sci-libs/indilib/ChangeLog
+++ b/sci-libs/indilib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/indilib
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/ChangeLog,v 1.49 2014/11/29 13:23:51 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/ChangeLog,v 1.50 2015/03/04 17:46:28 mrueg Exp $
+
+*indilib-1.0.0 (04 Mar 2015)
+
+ 04 Mar 2015; Manuel Rüger <mrueg@gentoo.org> +indilib-1.0.0.ebuild:
+ Version bump.
29 Nov 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unneeded useflag description from metadata.xml
diff --git a/sci-libs/indilib/indilib-1.0.0.ebuild b/sci-libs/indilib/indilib-1.0.0.ebuild
new file mode 100644
index 000000000000..bac959ebd5e0
--- /dev/null
+++ b/sci-libs/indilib/indilib-1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/indilib-1.0.0.ebuild,v 1.1 2015/03/04 17:46:28 mrueg Exp $
+
+EAPI=5
+
+MY_PN="lib${PN/lib/}"
+
+inherit cmake-utils udev
+
+DESCRIPTION="INDI Astronomical Control Protocol library"
+HOMEPAGE="http://www.indilib.org/"
+SRC_URI="mirror://sourceforge/${PN/lib/}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-libs/cfitsio
+ sci-libs/libnova
+ sci-libs/gsl
+ sys-libs/zlib
+ virtual/jpeg:0
+ virtual/libusb:0
+"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.8.1-symlinks.patch"
+)
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUDEVRULES_INSTALL_DIR=$(get_udevdir)
+ )
+
+ cmake-utils_src_configure
+}