summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 14:32:39 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 14:32:39 +0000
commit773bdc23c9744fc7a33e16c3073834fd631b1822 (patch)
tree6a5cb6c465f04ba86ce09119bae7e2cd2af606f3 /sci-libs/lapack-atlas
parentConvert to virtual/jpeg, bug #347980 by Andrew Savchenko <bircoph@gmail.com>. (diff)
downloadgentoo-2-773bdc23c9744fc7a33e16c3073834fd631b1822.tar.gz
gentoo-2-773bdc23c9744fc7a33e16c3073834fd631b1822.tar.bz2
gentoo-2-773bdc23c9744fc7a33e16c3073834fd631b1822.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/lapack-atlas')
-rw-r--r--sci-libs/lapack-atlas/ChangeLog9
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild18
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.8.2.ebuild18
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.9.21-r1.ebuild16
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.9.21.ebuild16
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.9.23-r2.ebuild16
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild16
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.9.23.ebuild16
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.9.3.ebuild18
9 files changed, 67 insertions, 76 deletions
diff --git a/sci-libs/lapack-atlas/ChangeLog b/sci-libs/lapack-atlas/ChangeLog
index 68b9cec976be..96b736f032aa 100644
--- a/sci-libs/lapack-atlas/ChangeLog
+++ b/sci-libs/lapack-atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/lapack-atlas
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.81 2010/04/20 18:41:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.82 2010/12/16 14:32:39 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> lapack-atlas-3.8.0.ebuild,
+ lapack-atlas-3.8.2.ebuild, lapack-atlas-3.9.3.ebuild,
+ lapack-atlas-3.9.21.ebuild, lapack-atlas-3.9.21-r1.ebuild,
+ lapack-atlas-3.9.23.ebuild, lapack-atlas-3.9.23-r2.ebuild,
+ lapack-atlas-3.9.23-r3.ebuild:
+ Removal of fortran.eclass, #348851
*lapack-atlas-3.9.23-r3 (20 Apr 2010)
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild
index 36be70a183c7..7c0cc392e1d9 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild,v 1.15 2008/11/28 09:37:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild,v 1.16 2010/12/16 14:32:39 jlec Exp $
-inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+inherit eutils flag-o-matic toolchain-funcs autotools versionator
MY_PN="${PN/lapack-/}"
PATCH_V="3.7.39"
@@ -33,8 +33,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
doc? ( app-doc/lapack-docs )"
-FORTRAN="g77 gfortran ifc"
-
S="${WORKDIR}/ATLAS"
S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
BLD_DIR="${S}/gentoo-build"
@@ -78,7 +76,7 @@ src_unpack() {
--libdir="${D}/${DESTTREE}"/$(get_libdir)/atlas \
--incdir="${D}/${DESTTREE}"/include \
-C ac "$(tc-getCC)" -F ac "${CFLAGS}" \
- -C if ${FORTRANC} -F if "${FFLAGS:--O2}" \
+ -C if $(tc-getFC) -F if "${FFLAGS:--O2}" \
-Ss pmake "\$(MAKE) ${MAKEOPTS}" \
-Si cputhrchk 0 ${archselect} \
|| die "configure failed"
@@ -89,7 +87,7 @@ src_unpack() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas cblas):" \
@@ -123,9 +121,9 @@ src_compile() {
RPATH="${DESTTREE}"/$(get_libdir)/${L_PN}/${MY_PN}
local flibs
- [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
- [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
- ../libtool --mode=link --tag=F77 ${FORTRANC} \
+ [[ $(tc-getFC) == gfortran ]] && flibs=-lgfortran
+ [[ $(tc-getFC) == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 $(tc-getFC) \
$(pkg-config --libs blas cblas) -latlas ${flibs} \
-o liblapack.la *.lo -rpath "${RPATH}" \
|| die "Failed to create liblapack.la"
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.8.2.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.8.2.ebuild
index 5a9ed390f68b..884da664bc60 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.8.2.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.8.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.8.2.ebuild,v 1.2 2008/11/28 09:37:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.8.2.ebuild,v 1.3 2010/12/16 14:32:39 jlec Exp $
-inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+inherit eutils flag-o-matic toolchain-funcs autotools versionator
MY_PN="${PN/lapack-/}"
PATCH_V="3.7.39"
@@ -33,8 +33,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
doc? ( app-doc/lapack-docs )"
-FORTRAN="g77 gfortran ifc"
-
S="${WORKDIR}/ATLAS"
S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
BLD_DIR="${S}/gentoo-build"
@@ -75,7 +73,7 @@ src_unpack() {
--libdir="${D}/${DESTTREE}"/$(get_libdir)/atlas \
--incdir="${D}/${DESTTREE}"/include \
-C ac "$(tc-getCC)" -F ac "${CFLAGS}" \
- -C if ${FORTRANC} -F if "${FFLAGS:--O2}" \
+ -C if $(tc-getFC) -F if "${FFLAGS:--O2}" \
-Ss pmake "\$(MAKE) ${MAKEOPTS}" \
-Si cputhrchk 0 ${archselect} \
|| die "configure failed"
@@ -86,7 +84,7 @@ src_unpack() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas cblas):" \
@@ -120,9 +118,9 @@ src_compile() {
RPATH="${DESTTREE}"/$(get_libdir)/${L_PN}/${MY_PN}
local flibs
- [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
- [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
- ../libtool --mode=link --tag=F77 ${FORTRANC} \
+ [[ $(tc-getFC) == gfortran ]] && flibs=-lgfortran
+ [[ $(tc-getFC) == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 $(tc-getFC) \
$(pkg-config --libs blas cblas) -latlas ${flibs} \
-o liblapack.la *.lo -rpath "${RPATH}" \
|| die "Failed to create liblapack.la"
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.9.21-r1.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.9.21-r1.ebuild
index cc77ad0a5839..5ced8d9d6a23 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.9.21-r1.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.9.21-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.21-r1.ebuild,v 1.1 2010/02/06 17:09:49 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.21-r1.ebuild,v 1.2 2010/12/16 14:32:39 jlec Exp $
-inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+inherit eutils flag-o-matic toolchain-funcs autotools versionator
MY_PN="${PN/lapack-/}"
PATCH_V="3.9.0"
@@ -33,8 +33,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
doc? ( app-doc/lapack-docs )"
-FORTRAN="g77 gfortran ifc"
-
S="${WORKDIR}/ATLAS"
S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
BLD_DIR="${S}/gentoo-build"
@@ -88,7 +86,7 @@ src_unpack() {
--libdir="${D}/${DESTTREE}"/$(get_libdir)/atlas \
--incdir="${D}/${DESTTREE}"/include \
-C ac "${c_compiler}" -F ac "${CFLAGS}" \
- -C if ${FORTRANC} -F if "${FFLAGS:-'-O2'}" \
+ -C if $(tc-getFC) -F if "${FFLAGS:-'-O2'}" \
-Ss pmake "\$(MAKE) ${MAKEOPTS}" \
-Si cputhrchk 0 ${archselect} \
|| die "configure failed"
@@ -99,7 +97,7 @@ src_unpack() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas cblas):" \
@@ -133,9 +131,9 @@ src_compile() {
RPATH="${DESTTREE}"/$(get_libdir)/${L_PN}/${MY_PN}
local flibs
- [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
- [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
- ../libtool --mode=link --tag=F77 ${FORTRANC} ${LDFLAGS} \
+ [[ $(tc-getFC) == gfortran ]] && flibs=-lgfortran
+ [[ $(tc-getFC) == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 $(tc-getFC) ${LDFLAGS} \
$(pkg-config --libs blas cblas) -latlas ${flibs} \
-o liblapack.la *.lo -rpath "${RPATH}" \
|| die "Failed to create liblapack.la"
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.9.21.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.9.21.ebuild
index d3b72db3d300..b5dc4e9bee3d 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.9.21.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.9.21.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.21.ebuild,v 1.3 2010/01/29 04:44:09 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.21.ebuild,v 1.4 2010/12/16 14:32:39 jlec Exp $
-inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+inherit eutils flag-o-matic toolchain-funcs autotools versionator
MY_PN="${PN/lapack-/}"
PATCH_V="3.9.0"
@@ -33,8 +33,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
doc? ( app-doc/lapack-docs )"
-FORTRAN="g77 gfortran ifc"
-
S="${WORKDIR}/ATLAS"
S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
BLD_DIR="${S}/gentoo-build"
@@ -88,7 +86,7 @@ src_unpack() {
--libdir="${D}/${DESTTREE}"/$(get_libdir)/atlas \
--incdir="${D}/${DESTTREE}"/include \
-C ac "${c_compiler}" -F ac "${CFLAGS}" \
- -C if ${FORTRANC} -F if "${FFLAGS:-'-O2'}" \
+ -C if $(tc-getFC) -F if "${FFLAGS:-'-O2'}" \
-Ss pmake "\$(MAKE) ${MAKEOPTS}" \
-Si cputhrchk 0 ${archselect} \
|| die "configure failed"
@@ -99,7 +97,7 @@ src_unpack() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas cblas):" \
@@ -133,9 +131,9 @@ src_compile() {
RPATH="${DESTTREE}"/$(get_libdir)/${L_PN}/${MY_PN}
local flibs
- [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
- [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
- ../libtool --mode=link --tag=F77 ${FORTRANC} ${LDFLAGS} \
+ [[ $(tc-getFC) == gfortran ]] && flibs=-lgfortran
+ [[ $(tc-getFC) == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 $(tc-getFC) ${LDFLAGS} \
$(pkg-config --libs blas cblas) -latlas ${flibs} \
-o liblapack.la *.lo -rpath "${RPATH}" \
|| die "Failed to create liblapack.la"
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r2.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r2.ebuild
index 6484a1a8d1b7..1bd958afaf59 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r2.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r2.ebuild,v 1.2 2010/04/15 20:28:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r2.ebuild,v 1.3 2010/12/16 14:32:39 jlec Exp $
EAPI="3"
-inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+inherit eutils flag-o-matic toolchain-funcs autotools versionator
MY_PN="${PN/lapack-/}"
PATCH_V="3.9.21"
@@ -35,8 +35,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
doc? ( app-doc/lapack-docs )"
-FORTRAN="g77 gfortran ifc"
-
S="${WORKDIR}/ATLAS"
S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
BLD_DIR="${S}/gentoo-build"
@@ -104,14 +102,14 @@ src_configure() {
--libdir="${ED}/${DESTTREE}"/$(get_libdir)/atlas \
--incdir="${ED}/${DESTTREE}"/include \
-C ac "${c_compiler}" -F ac "${CFLAGS}" \
- -C if ${FORTRANC} -F if "${FFLAGS:-'-O2'}" \
+ -C if $(tc-getFC) -F if "${FFLAGS:-'-O2'}" \
-Ss pmake "\$(MAKE) ${MAKEOPTS}" \
-Si cputhrchk 0 ${archselect} \
|| die "configure failed"
cd "${S_LAPACK}"
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas cblas):" \
@@ -144,9 +142,9 @@ src_compile() {
RPATH="${DESTTREE}"/$(get_libdir)/${L_PN}/${MY_PN}
local flibs
- [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
- [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
- ../libtool --mode=link --tag=F77 ${FORTRANC} ${LDFLAGS} \
+ [[ $(tc-getFC) == gfortran ]] && flibs=-lgfortran
+ [[ $(tc-getFC) == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 $(tc-getFC) ${LDFLAGS} \
$(pkg-config --libs blas cblas) -latlas ${flibs} \
-o liblapack.la *.lo -rpath "${RPATH}" \
|| die "Failed to create liblapack.la"
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild
index b680b38a7fe0..bad6c696ff6d 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild,v 1.1 2010/04/20 18:41:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.23-r3.ebuild,v 1.2 2010/12/16 14:32:39 jlec Exp $
EAPI="3"
-inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+inherit eutils flag-o-matic toolchain-funcs autotools versionator
MY_PN="${PN/lapack-/}"
PATCH_V="3.9.21"
@@ -35,8 +35,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
doc? ( app-doc/lapack-docs )"
-FORTRAN="g77 gfortran ifc"
-
S="${WORKDIR}/ATLAS"
S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
BLD_DIR="${S}/gentoo-build"
@@ -106,14 +104,14 @@ src_configure() {
--libdir="${ED}"/usr/$(get_libdir)/atlas \
--incdir="${ED}"/usr/include \
-C ac "${c_compiler}" -F ac "${CFLAGS}" \
- -C if ${FORTRANC} -F if "${FFLAGS:-'-O2'}" \
+ -C if $(tc-getFC) -F if "${FFLAGS:-'-O2'}" \
-Ss pmake "\$(MAKE) ${MAKEOPTS}" \
-Si cputhrchk 0 ${archselect} \
|| die "configure failed"
cd "${S_LAPACK}"
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} ${BLAS_LIBS}:" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} ${BLAS_LIBS}:" \
-e "s:../../blas\$(PLAT).a:${BLAS_LIBS}:" \
@@ -145,9 +143,9 @@ src_compile() {
cp -sf "${BLD_DIR}"/gentoo/liblapack.a/.libs/*.o .libs/
local flibs
- [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
- [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
- ../libtool --mode=link --tag=F77 ${FORTRANC} ${LDFLAGS} \
+ [[ $(tc-getFC) == gfortran ]] && flibs=-lgfortran
+ [[ $(tc-getFC) == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 $(tc-getFC) ${LDFLAGS} \
"${BLAS_LIBS}" -latlas ${flibs} \
-o "${S_LAPACK}"/SRC/liblapack.la *.lo -rpath "${EPREFIX}/${RPATH}" \
|| die "Failed to create liblapack.la"
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.9.23.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.9.23.ebuild
index a4c92899b4df..ee73c333531b 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.9.23.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.9.23.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.23.ebuild,v 1.1 2010/02/19 02:36:43 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.23.ebuild,v 1.2 2010/12/16 14:32:39 jlec Exp $
-inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+inherit eutils flag-o-matic toolchain-funcs autotools versionator
MY_PN="${PN/lapack-/}"
PATCH_V="3.9.21"
@@ -33,8 +33,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
doc? ( app-doc/lapack-docs )"
-FORTRAN="g77 gfortran ifc"
-
S="${WORKDIR}/ATLAS"
S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
BLD_DIR="${S}/gentoo-build"
@@ -88,7 +86,7 @@ src_unpack() {
--libdir="${D}/${DESTTREE}"/$(get_libdir)/atlas \
--incdir="${D}/${DESTTREE}"/include \
-C ac "${c_compiler}" -F ac "${CFLAGS}" \
- -C if ${FORTRANC} -F if "${FFLAGS:-'-O2'}" \
+ -C if $(tc-getFC) -F if "${FFLAGS:-'-O2'}" \
-Ss pmake "\$(MAKE) ${MAKEOPTS}" \
-Si cputhrchk 0 ${archselect} \
|| die "configure failed"
@@ -99,7 +97,7 @@ src_unpack() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas cblas):" \
@@ -133,9 +131,9 @@ src_compile() {
RPATH="${DESTTREE}"/$(get_libdir)/${L_PN}/${MY_PN}
local flibs
- [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
- [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
- ../libtool --mode=link --tag=F77 ${FORTRANC} ${LDFLAGS} \
+ [[ $(tc-getFC) == gfortran ]] && flibs=-lgfortran
+ [[ $(tc-getFC) == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 $(tc-getFC) ${LDFLAGS} \
$(pkg-config --libs blas cblas) -latlas ${flibs} \
-o liblapack.la *.lo -rpath "${RPATH}" \
|| die "Failed to create liblapack.la"
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.9.3.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.9.3.ebuild
index 6a2ca484a128..6dc35b508125 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.9.3.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.9.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.3.ebuild,v 1.4 2009/01/14 19:14:03 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.9.3.ebuild,v 1.5 2010/12/16 14:32:39 jlec Exp $
-inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+inherit eutils flag-o-matic toolchain-funcs autotools versionator
MY_PN="${PN/lapack-/}"
PATCH_V="3.9.0"
@@ -33,8 +33,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
doc? ( app-doc/lapack-docs )"
-FORTRAN="g77 gfortran ifc"
-
S="${WORKDIR}/ATLAS"
S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
BLD_DIR="${S}/gentoo-build"
@@ -88,7 +86,7 @@ src_unpack() {
--libdir="${D}/${DESTTREE}"/$(get_libdir)/atlas \
--incdir="${D}/${DESTTREE}"/include \
-C ac "${c_compiler}" -F ac "${CFLAGS}" \
- -C if ${FORTRANC} -F if "${FFLAGS:-'-O2'}" \
+ -C if $(tc-getFC) -F if "${FFLAGS:-'-O2'}" \
-Ss pmake "\$(MAKE) ${MAKEOPTS}" \
-Si cputhrchk 0 ${archselect} \
|| die "configure failed"
@@ -99,7 +97,7 @@ src_unpack() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas cblas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas cblas):" \
@@ -133,9 +131,9 @@ src_compile() {
RPATH="${DESTTREE}"/$(get_libdir)/${L_PN}/${MY_PN}
local flibs
- [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
- [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
- ../libtool --mode=link --tag=F77 ${FORTRANC} \
+ [[ $(tc-getFC) == gfortran ]] && flibs=-lgfortran
+ [[ $(tc-getFC) == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 $(tc-getFC) \
$(pkg-config --libs blas cblas) -latlas ${flibs} \
-o liblapack.la *.lo -rpath "${RPATH}" \
|| die "Failed to create liblapack.la"