summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-04-07 13:57:30 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-04-07 13:57:30 +0000
commit8994df0fe89053e060ac5a2ad46887a1d2a884cf (patch)
tree448c5c2eb448b2e23a777702217bea21e025836e /sci-libs/netcdf/netcdf-3.6.1.ebuild
parentDon't require virtual/dev-manager on BSDs. (diff)
downloadgentoo-2-8994df0fe89053e060ac5a2ad46887a1d2a884cf.tar.gz
gentoo-2-8994df0fe89053e060ac5a2ad46887a1d2a884cf.tar.bz2
gentoo-2-8994df0fe89053e060ac5a2ad46887a1d2a884cf.zip
Version bump. This fixes bug #128936.
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'sci-libs/netcdf/netcdf-3.6.1.ebuild')
-rw-r--r--sci-libs/netcdf/netcdf-3.6.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/netcdf/netcdf-3.6.1.ebuild b/sci-libs/netcdf/netcdf-3.6.1.ebuild
new file mode 100644
index 000000000000..b87bd5ea9694
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-3.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.1.ebuild,v 1.1 2006/04/07 13:57:30 markusle Exp $
+
+inherit fortran eutils
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+HOMEPAGE="http://my.unidata.ucar.edu/content/software/netcdf/index.html"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+S="${WORKDIR}/${P}/src"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/fPIC.patch || die "fPIC patch failed"
+}
+
+src_compile() {
+ local myconf
+
+ if [[ ${FORTRANC} == gfortran ]]; then
+ myconf="${myconf} CPPFLAGS=-DpgiFortran"
+ else
+ myconf="${myconf} CPPFLAGS=-Df2cFortran"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ make || die "make failed"
+ make test || die "make test failed"
+}
+
+src_install() {
+ dodir /usr/{lib,share} /usr/share/man/man3 /usr/share/man/man3f
+ einstall MANDIR=${D}/usr/share/man \
+ || die "Failed to install man pages"
+ mv ${D}/usr/share/man/man3/netcdf.3f ${D}/usr/share/man/man3f/. \
+ || die "Failed to move man pages"
+
+ dodoc COPYRIGHT MANIFEST README RELEASE_NOTES VERSION \
+ fortran/cfortran.doc || die "Failed to install docs"
+}