summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-25 10:35:22 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-25 10:35:22 +0000
commit2500387ca22d6ee7f0ee8ac95cf580f18eb3c5e4 (patch)
tree5701414509a79ff42a794ed785f04064dbbcfc92 /sci-libs/netcdf
parentmarked x86 per bug 407793 (diff)
downloadgentoo-2-2500387ca22d6ee7f0ee8ac95cf580f18eb3c5e4.tar.gz
gentoo-2-2500387ca22d6ee7f0ee8ac95cf580f18eb3c5e4.tar.bz2
gentoo-2-2500387ca22d6ee7f0ee8ac95cf580f18eb3c5e4.zip
Fix eautoreconf handling by autotools_utils.eclass
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog8
-rw-r--r--sci-libs/netcdf/metadata.xml10
-rw-r--r--sci-libs/netcdf/netcdf-4.1.1-r4.ebuild9
-rw-r--r--sci-libs/netcdf/netcdf-4.1.3.ebuild12
4 files changed, 23 insertions, 16 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 97724968e977..d9688555291c 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/netcdf
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.93 2011/08/04 17:01:52 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.94 2012/03/25 10:35:22 jlec Exp $
+
+ 25 Mar 2012; Justin Lecher <jlec@gentoo.org> netcdf-4.1.1-r4.ebuild,
+ netcdf-4.1.3.ebuild, metadata.xml:
+ Fix eautoreconf handling by autotools_utils.eclass
*netcdf-4.1.3 (04 Aug 2011)
diff --git a/sci-libs/netcdf/metadata.xml b/sci-libs/netcdf/metadata.xml
index 9ce8a74bbd41..19e0ef6858c6 100644
--- a/sci-libs/netcdf/metadata.xml
+++ b/sci-libs/netcdf/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
NetCDF (network Common Data Form) is an interface for scientific
data access and a freely-distributed software library that provides an
implementation of the interface. The netCDF library also defines a
@@ -10,7 +10,7 @@
Together, the interface, library, and format support the creation,
access, and sharing of scientific data.
</longdescription>
-<use>
- <flag name="dap">Support for remote data access with the built-in OPeNDAP client</flag>
-</use>
+ <use>
+ <flag name="dap">Support for remote data access with the built-in OPeNDAP client</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild b/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild
index 681758566efa..0bcfefb1bf5d 100644
--- a/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild
+++ b/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild,v 1.12 2011/06/21 15:08:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild,v 1.13 2012/03/25 10:35:22 jlec Exp $
EAPI=3
-inherit autotools autotools-utils fortran-2
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2
DESCRIPTION="Scientific library and interface for array oriented data access"
HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
@@ -57,7 +59,6 @@ src_prepare() {
sed -i -e "/\$(NC_TEST4)/ s/man4//" Makefile.am || die
fi
autotools-utils_src_prepare
- eautoreconf
}
src_configure() {
diff --git a/sci-libs/netcdf/netcdf-4.1.3.ebuild b/sci-libs/netcdf/netcdf-4.1.3.ebuild
index b50e18bdd85f..17e19e8fef4f 100644
--- a/sci-libs/netcdf/netcdf-4.1.3.ebuild
+++ b/sci-libs/netcdf/netcdf-4.1.3.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.3.ebuild,v 1.1 2011/08/04 17:01:54 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.3.ebuild,v 1.2 2012/03/25 10:35:22 jlec Exp $
EAPI=4
-inherit autotools autotools-utils fortran-2
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2
DESCRIPTION="Scientific library and interface for array oriented data access"
HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
@@ -15,7 +17,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
IUSE="cxx dap doc fortran hdf5 static-libs"
-RDEPEND="fortran? ( virtual/fortran )
+RDEPEND="
+ fortran? ( virtual/fortran )
dap? ( net-misc/curl )
hdf5? ( >=sci-libs/hdf5-1.8.6[zlib,szip,fortran?] )"
@@ -54,7 +57,6 @@ src_prepare() {
sed -i -e "/\$(NC_TEST4)/ s/man4//" Makefile.am || die
fi
autotools-utils_src_prepare
- eautoreconf
}
src_configure() {