summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-29 21:31:12 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-29 21:31:12 +0000
commitc39c1f038b6eee7306137ad612220f91c953881c (patch)
treeb82f6d8b5f7abb7611100caa1ca0ae60491014d2 /sci-libs/pcl
parentConvert to CPU_FLAGS_X86. (diff)
downloadgentoo-2-c39c1f038b6eee7306137ad612220f91c953881c.tar.gz
gentoo-2-c39c1f038b6eee7306137ad612220f91c953881c.tar.bz2
gentoo-2-c39c1f038b6eee7306137ad612220f91c953881c.zip
Switch to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sci-libs/pcl')
-rw-r--r--sci-libs/pcl/ChangeLog9
-rw-r--r--sci-libs/pcl/pcl-1.7.2.ebuild8
-rw-r--r--sci-libs/pcl/pcl-9999.ebuild8
3 files changed, 14 insertions, 11 deletions
diff --git a/sci-libs/pcl/ChangeLog b/sci-libs/pcl/ChangeLog
index 511d1e04e571..90acfc7d42a3 100644
--- a/sci-libs/pcl/ChangeLog
+++ b/sci-libs/pcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/pcl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pcl/ChangeLog,v 1.4 2014/12/19 14:29:32 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pcl/ChangeLog,v 1.5 2015/01/29 21:31:12 mgorny Exp $
+
+ 29 Jan 2015; Michał Górny <mgorny@gentoo.org> pcl-1.7.2.ebuild,
+ pcl-9999.ebuild:
+ Switch to CPU_FLAGS_X86.
19 Dec 2014; Alexis Ballier <aballier@gentoo.org> pcl-1.7.2.ebuild,
pcl-9999.ebuild:
@@ -20,4 +24,3 @@
08 Dec 2014; Alexis Ballier <aballier@gentoo.org> +pcl-1.7.2.ebuild,
+pcl-9999.ebuild, +files/nogl.patch, +metadata.xml:
initial import, ebuild by me
-
diff --git a/sci-libs/pcl/pcl-1.7.2.ebuild b/sci-libs/pcl/pcl-1.7.2.ebuild
index 42ac1df7ba74..e9f15aa9984f 100644
--- a/sci-libs/pcl/pcl-1.7.2.ebuild
+++ b/sci-libs/pcl/pcl-1.7.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pcl/pcl-1.7.2.ebuild,v 1.4 2014/12/19 14:29:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pcl/pcl-1.7.2.ebuild,v 1.5 2015/01/29 21:31:12 mgorny Exp $
EAPI=5
@@ -25,7 +25,7 @@ HOMEPAGE="http://pointclouds.org/"
DESCRIPTION="2D/3D image and point cloud processing"
LICENSE="BSD"
SLOT="0"
-IUSE="cuda doc opengl openni openni2 pcap png +qhull qt4 usb vtk sse test tutorials"
+IUSE="cuda doc opengl openni openni2 pcap png +qhull qt4 usb vtk cpu_flags_x86_sse test tutorials"
RDEPEND="
>=sci-libs/flann-1.7.1
@@ -74,7 +74,7 @@ src_configure() {
"-DBUILD_OPENNI=$(usex openni TRUE FALSE)"
"-DWITH_OPENNI2=$(usex openni2 TRUE FALSE)"
"-DBUILD_OPENNI2=$(usex openni2 TRUE FALSE)"
- "-DPCL_ENABLE_SSE=$(usex sse TRUE FALSE)"
+ "-DPCL_ENABLE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
"-DWITH_DOCS=$(usex doc TRUE FALSE)"
"-DWITH_TUTORIALS=$(usex tutorials TRUE FALSE)"
"-DBUILD_TESTS=$(usex test TRUE FALSE)"
diff --git a/sci-libs/pcl/pcl-9999.ebuild b/sci-libs/pcl/pcl-9999.ebuild
index 768ff62177e8..c7345bcd5137 100644
--- a/sci-libs/pcl/pcl-9999.ebuild
+++ b/sci-libs/pcl/pcl-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pcl/pcl-9999.ebuild,v 1.4 2014/12/19 14:29:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pcl/pcl-9999.ebuild,v 1.5 2015/01/29 21:31:12 mgorny Exp $
EAPI=5
@@ -25,7 +25,7 @@ HOMEPAGE="http://pointclouds.org/"
DESCRIPTION="2D/3D image and point cloud processing"
LICENSE="BSD"
SLOT="0"
-IUSE="cuda doc opengl openni openni2 pcap png +qhull qt4 usb vtk sse test tutorials"
+IUSE="cuda doc opengl openni openni2 pcap png +qhull qt4 usb vtk cpu_flags_x86_sse test tutorials"
RDEPEND="
>=sci-libs/flann-1.7.1
@@ -70,7 +70,7 @@ src_configure() {
"-DBUILD_OPENNI=$(usex openni TRUE FALSE)"
"-DWITH_OPENNI2=$(usex openni2 TRUE FALSE)"
"-DBUILD_OPENNI2=$(usex openni2 TRUE FALSE)"
- "-DPCL_ENABLE_SSE=$(usex sse TRUE FALSE)"
+ "-DPCL_ENABLE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
"-DWITH_DOCS=$(usex doc TRUE FALSE)"
"-DWITH_TUTORIALS=$(usex tutorials TRUE FALSE)"
"-DBUILD_TESTS=$(usex test TRUE FALSE)"