summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-01-31 09:03:43 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-01-31 09:03:43 +0000
commit3519ed7baa18fb52814083d76d9fa1284b5e2dee (patch)
tree1e9ff387e60b626f5800eaaf14dcf7f1ad4b09bd /sci-libs/scipy
parentVersion bump to 1.0 . Bug #155788 (diff)
downloadgentoo-2-3519ed7baa18fb52814083d76d9fa1284b5e2dee.tar.gz
gentoo-2-3519ed7baa18fb52814083d76d9fa1284b5e2dee.tar.bz2
gentoo-2-3519ed7baa18fb52814083d76d9fa1284b5e2dee.zip
version bump with fix for bug 149153
(Portage version: 2.1.2-r4)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog9
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.3.22
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.5.23
-rw-r--r--sci-libs/scipy/scipy-0.5.2.ebuild101
4 files changed, 113 insertions, 2 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 2675a541524e..7b8374e70851 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/scipy
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.14 2006/11/01 00:51:46 dberkholz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.15 2007/01/31 09:03:43 nerdboy Exp $
+
+*scipy-0.5.2 (31 Jan 2007)
+
+ 31 Jan 2007; Steve Arnold <nerdboy@gentoo.org> +scipy-0.5.2.ebuild:
+ version bump with fix for bug 149153 (needs cleanup and stablization)
01 Nov 2006; Donnie Berkholz <dberkholz@gentoo.org>; ChangeLog:
Update for my nick change spyderous -> dberkholz.
diff --git a/sci-libs/scipy/files/digest-scipy-0.3.2 b/sci-libs/scipy/files/digest-scipy-0.3.2
index 1daba1be229f..47ecb96b9982 100644
--- a/sci-libs/scipy/files/digest-scipy-0.3.2
+++ b/sci-libs/scipy/files/digest-scipy-0.3.2
@@ -1 +1,3 @@
MD5 5ae2280ab2c4c653cb0ff8479e81284a SciPy_complete-0.3.2.tar.gz 3368595
+RMD160 15abb0d60577132bf38090fa7e4840bb0347cab8 SciPy_complete-0.3.2.tar.gz 3368595
+SHA256 bd1addc8d41d79f8866e7960cea391cfbfc3c6b36d5af205864d7f30a2fb98e8 SciPy_complete-0.3.2.tar.gz 3368595
diff --git a/sci-libs/scipy/files/digest-scipy-0.5.2 b/sci-libs/scipy/files/digest-scipy-0.5.2
new file mode 100644
index 000000000000..89b1226c8e1b
--- /dev/null
+++ b/sci-libs/scipy/files/digest-scipy-0.5.2
@@ -0,0 +1,3 @@
+MD5 e24387ac7f9e589816364db7c64c3185 scipy-0.5.2.tar.gz 6362164
+RMD160 fa945185df7fc48e03bafdddeaaea72a8eb4914d scipy-0.5.2.tar.gz 6362164
+SHA256 38e42155d3445699f28c36facdaa82200d8e017b4ca608f95f6d928065dc03ed scipy-0.5.2.tar.gz 6362164
diff --git a/sci-libs/scipy/scipy-0.5.2.ebuild b/sci-libs/scipy/scipy-0.5.2.ebuild
new file mode 100644
index 000000000000..00856bf72100
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.5.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.5.2.ebuild,v 1.1 2007/01/31 09:03:43 nerdboy Exp $
+
+inherit distutils fortran
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DESCRIPTION="Open source scientific tools for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+IUSE="fftw"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# doc says scipy needs to compile all libraries with the same compiler
+RDEPEND=">=dev-lang/python-2.3.3
+ >=dev-python/numpy-1.0
+ virtual/blas
+ virtual/lapack
+ fftw? ( sci-libs/fftw )"
+
+DEPEND="${RDEPEND}"
+
+# install doc claims fftw-2 is faster for complex ffts.
+# wxwindows seems to have disapeared : ?
+# f2py seems to be in numpy.
+
+FORTRAN="g77 gfortran"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ echo "[atlas]" > site.cfg
+ echo "include_dirs = /usr/include/atlas" >> site.cfg
+ echo -n "library_dirs = /usr/$(get_libdir)/lapack:/usr/$(get_libdir):" \
+ >> site.cfg
+ if [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ]; then
+ echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas, pthread" >> site.cfg
+ else
+ echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
+ fi
+
+ export FFTW3=None
+ if use fftw; then
+ echo "[fftw] " >> site.cfg
+ echo "fftw_libs = rfftw, fftw" >> site.cfg
+ echo "fftw_opt_libs = rfftw_threads, fftw_threads" >> site.cfg
+ else
+ export FFTW=None
+ fi
+}
+
+src_compile() {
+ # Map compilers to what scipy calls them
+ local SCIPY_FC
+ case "${FORTRANC}" in
+ gfortran)
+ SCIPY_FC="gnu95"
+ ;;
+ g77)
+ SCIPY_FC="gnu"
+ ;;
+ g95)
+ SCIPY_FC="g95"
+ ;;
+ ifc|ifort)
+ if use ia64; then
+ SCIPY_FC="intele"
+ else
+ SCIPY_FC="intel"
+ fi
+ ;;
+ *)
+ local msg="Invalid Fortran compiler \'${FORTRANC}\'"
+ eerror "${msg}"
+ die "${msg}"
+ ;;
+ esac
+
+ # http://projects.scipy.org/scipy/numpy/ticket/182
+ # Can't set LDFLAGS
+ unset LDFLAGS
+
+ # need to build with -fPIC (bug #149153)
+ export F77LFLAGS="${F77LFLAGS} -fPIC"
+
+ distutils_src_compile \
+ config_fc \
+ --fcompiler=${SCIPY_FC} \
+ --opt="${CFLAGS}" \
+ || die "compilation failed"
+}
+
+src_install() {
+ distutils_src_install
+ dodoc *.txt
+}